Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000197KdenliveEffectspublic2008-10-12 15:572010-09-22 17:54
Reportermadsdyd 
Assigned ToGranjow 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.8Fixed in Version0.7.8 
Summary0000197: Speed effect does not appear to work well for flv
DescriptionIn rev 2442 it does not appear that changing the speed for a flv or mpeg clip works well. It does appear that changing it for an avi clip works reasonable.

My experience: Cutting a clip into three parts, and setting the speed of a clip in the context sensitive menu, for a flv file or mpeg file, produces weird results: the display contains wrong images ( from the beginning of the clip ), the clip restarts at the third clip, and in general it just does not appear to work.

Cutting an avi into three and changing the speed of the middle clip, appears to work better, but at least once, I experienced a crash (log attached).

Also, although it appears to work better, it does not actually work as expected. Cutting a file into ABC and changing B's speed to 20%, will slow down the beginning of C for 4 times the length of B. It is as if C's speed is overwritten by B's

I am creating this issue in order to close 3 speed related bugs against kdenlive 0.5.
Additional InformationKdenlive Builder Wizard version: 0.5.1
ffmpeg: Revision: 15596 Last Changed Date: 2008-10-11 16:52:00 +0200 (lør, 11 okt 2008)
mlt: Revision: 1184 Last Changed Date: 2008-10-08 11:45:03 +0200 (ons, 08 okt 2008)
mlt++: Revision: 1184 Last Changed Date: 2008-08-06 09:16:10 +0200 (ons, 06 aug 2008)
kdenlive: Revision: 2442 Last Changed Date: 2008-10-10 13:00:40 +0200 (fre, 10 okt 2008)
Qt: 4.4.1
KDE: 4.1.2 (KDE 4.1.2)
Kdenlive: 0.7
TagsNo tags attached.
Build/Install Method
Attached Files? file icon kbw.gdb.output.fhP10198 [^] (95,499 bytes) 2008-10-12 15:57
? file icon kdenlive-bug-197.avi [^] (2,813,486 bytes) 2008-10-28 17:43

- Relationships
related to 0000188acknowledged changing clip speed is faulty/unintuitive 

-  Notes
(0000369)
madsdyd (administrator)
2008-10-12 16:01

Forgot to mention: There also seems to be no way to reverse (play backward) a clip.
(0000732)
jmpoure (developer)
2008-10-28 17:08
edited on: 2008-10-28 17:44

Same problem: changing speed make kdenlive crash.
I uploaded a small clip for testing purpose :)

(0000740)
madsdyd (administrator)
2008-10-28 23:31

jmpoure can also produce, acknowleding, but for version 0.7.1

This is not a bad candidate to fix for 0.7.0 though, but I do not think there are time.
(0004954)
Granjow (developer)
2010-04-10 13:02

Works well for me in current svn. Marking as resolved.

- Issue History
Date Modified Username Field Change
2008-10-12 15:57 madsdyd New Issue
2008-10-12 15:57 madsdyd File Added: kbw.gdb.output.fhP10198
2008-10-12 16:01 madsdyd Note Added: 0000369
2008-10-23 21:07 madsdyd Relationship added related to 0000188
2008-10-28 17:08 jmpoure Note Added: 0000732
2008-10-28 17:43 jmpoure File Added: kdenlive-bug-197.avi
2008-10-28 17:44 jmpoure Note Edited: 0000732
2008-10-28 23:31 madsdyd Note Added: 0000740
2008-10-28 23:31 madsdyd Severity minor => crash
2008-10-28 23:31 madsdyd Status new => acknowledged
2008-10-28 23:31 madsdyd Target Version Recent git => 0.7.1
2008-11-17 20:54 madsdyd Target Version 0.7.1 => future version
2010-04-10 13:02 Granjow Note Added: 0004954
2010-04-10 13:02 Granjow Status acknowledged => resolved
2010-04-10 13:02 Granjow Fixed in Version => Recent git
2010-04-10 13:02 Granjow Resolution open => unable to reproduce
2010-04-10 13:02 Granjow Assigned To => Granjow
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:00 j-b-m Status resolved => closed
2010-09-22 17:54 Granjow Target Version future version => 0.7.8


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker