Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000198KdenliveUser Interfacepublic2008-10-12 16:172008-11-12 22:22
Reporterandrewz 
Assigned To 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.0Fixed in Version0.7.0 
Summary0000198: crash on startup before seeing GUI
Descriptionkdenlive(6696) MainWindow::parseProfiles: RESULTINGĂ‚ MLT PATH: "/usr/share/mlt/profiles/"
KCrash: Application 'kdenlive' crashing...
sock_file=/home/z/.kde/socket-z.localdomain/kdeinit4__0
Warning: connect() failed: : No such file or directory
KCrash cannot reach kdeinit, launching directly.
KCrash failed to exec(), errno = 2
Additional Informationkdenlive-0.7beta1
mlt 0.3.0
mlt++ 0.3.0
Fedora 9
TagsNo tags attached.
Build/Install Method
Attached Files

- Relationships

-  Notes
(0000370)
andrewz (reporter)
2008-10-12 16:41

After installing kdebase, it goes a little further. The KDE GUI gives me this backtrace

Application: Kdenlive (kdenlive), signal SIGSEGV
[?1034h[Thread debugging using libthread_db enabled]
[New Thread 0xb80ce9a0 (LWP 11095)]
[KCrash handler]
0000006 0x02aece74 in QMutexPool::get () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000007 0x027c3f01 in QMetaObjectCleanUp::QMetaObjectCleanUp ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000008 0x02ba7b69 in ?? () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000009 0x02ba7f0d in ?? () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000010 0x02d8f694 in QDataTable::falseText ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
0000011 0x091fbc40 in ?? ()
0000012 0xbfcf5118 in ?? ()
0000013 0x026cb0ec in _init () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
Backtrace stopped: frame did not save the PC
(0000373)
administrator (administrator)
2008-10-12 19:32

Looks like you have compiled MLT with the Qt3 version of QImage producer. Try deleting the file libmltqimage.so installed by MLT, or recompile MLT with Qt4 qimage producer (by giving the path to your Qt4 includes and libraries at MLT configure.
(0000374)
nadavkav (reporter)
2008-10-12 20:45

i have/had the same issue on debian sid
i removed the /usr/lib/mlt/libmltqimage.so
and it started to work :-)

i got mlt for qt3 (probably) from the official repositories
i will try to make my own mlt & mlt++ versions

after it starts... all works fine :-)

super thanks !
great application !!!

- Issue History
Date Modified Username Field Change
2008-10-12 16:17 andrewz New Issue
2008-10-12 16:41 andrewz Note Added: 0000370
2008-10-12 19:32 administrator Note Added: 0000373
2008-10-12 20:45 nadavkav Note Added: 0000374
2008-10-13 10:49 administrator Status new => resolved
2008-10-13 10:49 administrator Resolution open => fixed
2008-10-13 10:49 administrator Description Updated
2008-10-23 00:20 madsdyd Target Version => 0.7.0
2008-10-23 00:22 madsdyd Status resolved => closed
2008-11-12 22:22 madsdyd Fixed in Version => 0.7.0


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker