Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002026KdenliveMLTpublic2011-02-17 15:462011-06-10 10:49
ReporterGranjow 
Assigned Toddennedy 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.8 
Summary0002026: Speed effekt is broken. Deadlock?
DescriptionI tried to apply a speed effect to a video. As soon as I try to show the zone in the project monitor, nothing else happens anymore.

One thread stays here:
0 __lll_lock_wait lowlevellock.S 136 0x7ffff5f38be4
1 _L_lock_953 /lib/libpthread.so.0 0 0x7ffff5f340e9
2 __pthread_mutex_lock pthread_mutex_lock.c 61 0x7ffff5f33f0b
3 mlt_service_get_frame mlt_service.c 444 0x7ffff7bcd810
4 producer_get_frame mlt_producer.c 629 0x7ffff7bcee1e
5 mlt_service_get_frame mlt_service.c 457 0x7ffff7bcd875
6 producer_get_frame mlt_playlist.c 1769 0x7ffff7bd20c4
7 producer_get_frame mlt_producer.c 578 0x7ffff7bcf0bf
8 mlt_service_get_frame mlt_service.c 457 0x7ffff7bcd875
9 producer_get_frame mlt_multitrack.c 453 0x7ffff7bcf8ee
10 producer_get_frame mlt_producer.c 578 0x7ffff7bcf0bf
11 mlt_service_get_frame mlt_service.c 457 0x7ffff7bcd875
12 transition_get_frame mlt_transition.c 358 0x7ffff7bd5061
13 mlt_service_get_frame mlt_service.c 457 0x7ffff7bcd875
14 transition_get_frame mlt_transition.c 358 0x7ffff7bd5061
15 mlt_service_get_frame mlt_service.c 457 0x7ffff7bcd875
16 transition_get_frame mlt_transition.c 358 0x7ffff7bd5061
17 mlt_service_get_frame mlt_service.c 457 0x7ffff7bcd875
18 transition_get_frame mlt_transition.c 290 0x7ffff7bd4e51
19 mlt_service_get_frame mlt_service.c 457 0x7ffff7bcd875
20 producer_get_frame mlt_tractor.c 392 0x7ffff7bd5948
21 producer_get_frame mlt_producer.c 578 0x7ffff7bcf0bf
22 mlt_service_get_frame mlt_service.c 457 0x7ffff7bcd875
23 mlt_service_get_frame mlt_service.c 457 0x7ffff7bcd875
24 mlt_consumer_get_frame mlt_consumer.c 544 0x7ffff7bd2ad7
25 consumer_thread consumer_sdl_preview.c 301 0x7fffe11d085a
26 start_thread pthread_create.c 300 0x7ffff5f318ba
27 clone clone.S 112 0x7ffff1cb502d
28 ?? 0

And the other one here:
0 pthread_cond_timedwait@@GLIBC_2.3.2 pthread_cond_timedwait.S 211 0x7ffff5f364d9
1 mlt_consumer_get_frame mlt_consumer.c 533 0x7ffff7bd2c6a
2 mlt_consumer_rt_frame mlt_consumer.c 1241 0x7ffff7bd3d9f
3 consumer_thread consumer_sdl_still.c 570 0x7fffe11d13ec
4 start_thread pthread_create.c 300 0x7ffff5f318ba
5 clone clone.S 112 0x7ffff1cb502d
6 ?? 0
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0006436)
Granjow (developer)
2011-02-17 20:27

Another one, this time without the speed effect, just playing and cutting. Happens regularily after some minutes. The project monitor stops showing anything.

Four threads constantly at the same place (I started kdenlive with qtcreator and paused it, then let it run and again paused it, no changes at all):

0 pthread_cond_timedwait@@GLIBC_2.3.2 pthread_cond_timedwait.S 211 0x7ffff5f364d9
1 mlt_consumer_put_frame mlt_consumer.c 486 0x7ffff7bd2ac0
2 consumer_thread consumer_sdl_preview.c 368 0x7fffe11d0da4
3 start_thread pthread_create.c 300 0x7ffff5f318ba
4 clone clone.S 112 0x7ffff1cb502d
5 ?? 0


0 nanosleep syscall-template.S 82 0x7ffff5f397dd
1 consumer_thread consumer_sdl.c 824 0x7fffe11cdb62
2 start_thread pthread_create.c 300 0x7ffff5f318ba
3 clone clone.S 112 0x7ffff1cb502d
4 ?? 0


0 pthread_cond_wait@@GLIBC_2.3.2 pthread_cond_wait.S 162 0x7ffff5f3616c
1 consumer_read_ahead_thread mlt_consumer.c 680 0x7ffff7bd300b
2 start_thread pthread_create.c 300 0x7ffff5f318ba
3 clone clone.S 112 0x7ffff1cb502d
4 ?? 0


0 pthread_cond_wait@@GLIBC_2.3.2 pthread_cond_wait.S 162 0x7ffff5f3616c
1 sdl_fill_audio consumer_sdl.c 336 0x7fffe11ce1e3
2 ?? /usr/lib/libSDL-1.2.so.0 0 0x7fffe0f1a158
3 ?? /usr/lib/libSDL-1.2.so.0 0 0x7fffe0f21dc5
4 ?? /usr/lib/libSDL-1.2.so.0 0 0x7fffe0f693b9
5 start_thread pthread_create.c 300 0x7ffff5f318ba
6 clone clone.S 112 0x7ffff1cb502d
7 ?? 0
(0006448)
Granjow (developer)
2011-02-19 10:15

Seems to be especially well reproducible when rendering at the same time.
(0006501)
ptitmain (developer)
2011-02-27 23:48

I am not sure it this the same bug but I have many difficulties with the speed effect in the SVN version (0.7.8+svn20110226).

Starting with a new project and adding some clips, when using the speed effect at 500% or 700%, kdenlive freezes just after some clips have been added. When reopening the project, it freeze again.

It seems that it is a new bug because I did some clips with the 0.7.8 and all was going well.
(0006502)
ptitmain (developer)
2011-02-27 23:54

In fact, it is very easy to reproduce, even with only one clip:

- put a clip in the timeline
- add the speed effect at 500%
- move the clip several times on the timeline
- after 2 or 3 move, the interface is frozen

(0.7.8+svn20110226)
(0006503)
ptitmain (developer)
2011-02-28 12:55

Just upgraded to 0.7.9+svn20110228.r5462-0ubuntu0~sunab

The issue is still there...
(0006511)
sunab (reporter)
2011-03-02 14:26
edited on: 2011-03-02 14:27

For me it is fixed by latest mlt commits, this morning.

@ptitmain : packages updated.

(0006512)
Granjow (developer)
2011-03-02 14:36

Confirmed, works here as well. Thanks Dan!

- Issue History
Date Modified Username Field Change
2011-02-17 15:46 Granjow New Issue
2011-02-17 20:27 Granjow Note Added: 0006436
2011-02-19 10:15 Granjow Note Added: 0006448
2011-02-27 23:48 ptitmain Note Added: 0006501
2011-02-27 23:54 ptitmain Note Added: 0006502
2011-02-28 12:55 ptitmain Note Added: 0006503
2011-03-02 14:26 sunab Note Added: 0006511
2011-03-02 14:27 sunab Note Edited: 0006511 View Revisions
2011-03-02 14:36 Granjow Note Added: 0006512
2011-03-02 14:36 Granjow Status new => resolved
2011-03-02 14:36 Granjow Fixed in Version => Recent git
2011-03-02 14:36 Granjow Resolution open => fixed
2011-03-02 14:36 Granjow Assigned To => ddennedy
2011-04-26 21:58 j-b-m Fixed in Version Recent git => 0.8
2011-06-10 10:49 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker