Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002068KdenliveEffectspublic2011-03-18 19:082011-11-01 18:56
Reporterddennedy 
Assigned Tottill 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.8.2 
Target VersionFixed in Version0.8.2 
Summary0002068: effects are not adaptive to implementation version
DescriptionBoth MLT and frei0r expose version information (aside the fact that MLT metadata is under-developed). However, the Kdenlive effects XML do not adapt based upon the version. I suggest we add support for multiple XML files with a version identifier.
TagsNo tags attached.
Build/Install Method(select)
Attached Files

- Relationships

-  Notes
(0006594)
ttill (developer)
2011-03-18 19:22

I partly implemented this for the curves filter: There are two GUIs available: cubic (up to 5 points) curves and Bézier curves.
< effect tag="frei0r.curves" id="frei0r.bezier_curves" version="0.2" >
The Bézier GUI is only available if the filter's version is >= 0.2.

When automatically choosing between two GUIs we might break existing projects.
(0006596)
ddennedy (developer)
2011-03-18 19:46

Nice. What is the limitation preventing this be used for all effects XML? Is the code you added to support this specific to the curves UI?

hmm, good point about breaking existing projects. Plugins can break API and affect old projects regardless of UI. I have seen this with sox effects and have been guilty of it myself in frei0r OpenCV filters (not that they were exposed to Kdenlive users, but at least theoretically). I try to be conscientious within MLT, and I will try to be alert within frei0r, but I am not involved with LADSPA or Sox. We can only control this so much and need to advise users not to assume things will continue to work the same and therefore render and archive a high quality master upon project completion (and revisions). Since the build script generates dated builds, one can load an old project into a more compatible build. I could extend the build script to do sox and some ladspa collections, but it will never be 100% compatible with platform changes to things such as qt, gtk, and to a lesser degree glibc.
(0006599)
ttill (developer)
2011-03-18 20:07
edited on: 2011-03-18 20:07

It is of course not limited to the curves filter, but curves was the reason why I implemented it ;)
I wouldn't think to much about LADSPA or Sox. In the worst case it is probably easier to provide a simple bash script to convert projects.
mlt and frei0r filters are both more used and we have greater influence.

I have the same problem when it comes to removing effects. For example Gain (keyframable effects, including volume, come with only 1 keyframe by default in 0.8) and "Rotate and shear" (keyframable rotate, corners) are obsolete. However they are widely used.
Maybe a flag (additionally linked to the version) to hide them from the effect list would work out?

(0007396)
ttill (developer)
2011-10-02 22:13

I guess this can be marked as resolved now?

- Issue History
Date Modified Username Field Change
2011-03-18 19:08 ddennedy New Issue
2011-03-18 19:22 ttill Note Added: 0006594
2011-03-18 19:22 ttill Assigned To => ttill
2011-03-18 19:22 ttill Status new => feedback
2011-03-18 19:46 ddennedy Note Added: 0006596
2011-03-18 19:46 ddennedy Status feedback => assigned
2011-03-18 20:07 ttill Note Added: 0006599
2011-03-18 20:07 ttill Note Edited: 0006599 View Revisions
2011-10-02 22:13 ttill Note Added: 0007396
2011-10-02 22:13 ttill Status assigned => feedback
2011-10-03 02:44 ddennedy Status feedback => resolved
2011-10-03 02:44 ddennedy Fixed in Version => Recent git
2011-10-03 02:44 ddennedy Resolution open => fixed
2011-10-03 20:08 ttill Product Version 0.7.8 => 0.8.2
2011-10-31 15:23 j-b-m Fixed in Version Recent git => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker