Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002073KdenliveRenderingpublic2011-03-22 22:362014-05-09 00:28
Reporternewbi462 
Assigned Tovpinon 
PriorityhighSeveritymajorReproducibilityalways
StatusresolvedResolutionno change required 
PlatformLinuxOSPCLinuxOSOS VersionRolling distro
Product Version 
Target VersionFixed in Version 
Summary0002073: Some sort of error in the WebM profiles..
DescriptionOK not sure what it is but when you render video using KdenLive in .webm format most browsers can not play it.

In fact only Chrome desktop browser can, no mobile browsers, not FF4, not IE with WebM addon.

It is obviously an error in the rendering profile but no clue what it is.
Steps To ReproduceRender a file in WebM

Make and publish a webpage using the HTML5 Video tag aside from Chrome desktop no browsers that support WebM can play the Video
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0009742)
jbennett (reporter)
2014-02-25 06:31
edited on: 2014-02-25 07:01

This is an ancient bug report, but is still quite accurate. Kdenlive does not generate correct webm files. Google's webminspector agrees with this. Most notably, IE will not play them, even with the webm addon from Google.

The solution should be dead simple. FFmpeg requires a "-f webm" as part of the encoding command to output a properly formed webm file.

I can run a .webm file rendered by kdenlive through ffmpeg with "-acodec copy -vcodec copy -f webm" and I get a correctly formatted file.

Unfortunately, adding this to the kdenlive webm render profile does not seem to have the same effect as adding it to the ffmpeg command line.

(0009743)
jbennett (reporter)
2014-02-28 07:01

Potentially disregard my comments above. It seems that the problem lies solely with ffmpeg v2.1+ A self compiled ffmpeg 2.0.3 produced a usable webm file. Continuing to investigate the issue.
(0009749)
vpinon (administrator)
2014-03-02 22:21

see bug#3221 : I updated encoding profiles using MLT presets, maybe it is better like this?
(0009783)
vpinon (administrator)
2014-03-19 20:31

hello, any news about this entry, or should I close it?
(0010031)
vpinon (administrator)
2014-05-09 00:28

libav problem, not kdenlive

- Issue History
Date Modified Username Field Change
2011-03-22 22:36 newbi462 New Issue
2014-02-25 06:31 jbennett Note Added: 0009742
2014-02-25 07:01 jbennett Note Edited: 0009742 View Revisions
2014-02-28 07:01 jbennett Note Added: 0009743
2014-03-02 22:21 vpinon Note Added: 0009749
2014-03-02 22:21 vpinon Assigned To => vpinon
2014-03-02 22:21 vpinon Status new => feedback
2014-03-19 20:31 vpinon Note Added: 0009783
2014-05-09 00:28 vpinon Note Added: 0010031
2014-05-09 00:28 vpinon Status feedback => resolved
2014-05-09 00:28 vpinon Resolution open => no change required


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker