Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002113KdenliveUser Interfacepublic2011-05-01 10:362011-11-01 18:56
Reporternazgul 
Assigned Tottill 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.8.2 
Summary0002113: crash when removing clip from project
DescriptionApplication: kdenlive (0.7.8)
KDE Platform Version: 4.5.5 (KDE 4.5.5)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic x86_64
Distribution: Ubuntu 10.10
Steps To ReproduceI did not reproduce, but this is what I did:

Add a clip to the project
add the video to the lower video bar
physically delete the clip from the disk
remove the clip from the project
Additional Information-- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f07e74ce760 (LWP 4614))]

Thread 6 (Thread 0x7f07d94b3700 (LWP 4615)):
#0 0x00007f07e499ec9d in __pthread_mutex_unlock_usercnt (mutex=0x12832a8) at pthread_mutex_unlock.c:52
#1 __pthread_mutex_unlock (mutex=0x12832a8) at pthread_mutex_unlock.c:290
0000002 0x00007f07de76ab51 in g_main_context_prepare (context=0x12832a0, priority=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2497
0000003 0x00007f07de76ae78 in g_main_context_iterate (context=0x12832a0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2760
0000004 0x00007f07de76b7b5 in g_main_loop_run (loop=0x1283380) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2988
0000005 0x00007f07d9bea3c4 in gdbus_shared_thread_func (data=<value optimized out>) at /build/buildd/glib2.0-2.26.1/gio/gdbusprivate.c:277
0000006 0x00007f07de7907e4 in g_thread_create_proxy (data=0x12833a0) at /build/buildd/glib2.0-2.26.1/glib/gthread.c:1897
0000007 0x00007f07e499b971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
0000008 0x00007f07e301592d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000009 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f07bf0a5700 (LWP 4844)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1 0x00007f07c5d05105 in consumer_thread (arg=<value optimized out>) at consumer_sdl_preview.c:428
0000002 0x00007f07e499b971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
0000003 0x00007f07e301592d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000004 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f07b3ffe700 (LWP 4857)):
#0 pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1 0x00007f07e70e8c0a in mlt_consumer_get_frame (this=0x1954790) at mlt_consumer.c:502
0000002 0x00007f07e70e8d6d in mlt_consumer_rt_frame (this=0x19548ac) at mlt_consumer.c:900
0000003 0x00007f07c5d057cc in consumer_thread (arg=<value optimized out>) at consumer_sdl_still.c:560
0000004 0x00007f07e499b971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
0000005 0x00007f07e301592d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000006 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f07b37fd700 (LWP 9275)):
#0 pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1 0x00007f07e70e8c0a in mlt_consumer_get_frame (this=0x18383d0) at mlt_consumer.c:502
0000002 0x00007f07e70e8d6d in mlt_consumer_rt_frame (this=0x18384ec) at mlt_consumer.c:900
0000003 0x00007f07c5d057cc in consumer_thread (arg=<value optimized out>) at consumer_sdl_still.c:560
0000004 0x00007f07e499b971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
0000005 0x00007f07e301592d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000006 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f07be8a4700 (LWP 9276)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1 0x00007f07c5d05105 in consumer_thread (arg=<value optimized out>) at consumer_sdl_preview.c:428
0000002 0x00007f07e499b971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
0000003 0x00007f07e301592d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000004 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f07e74ce760 (LWP 4614)):
[KCrash Handler]
0000006 value (this=0x181bf00, prop=) at /usr/include/qt4/QtCore/qmap.h:498
0000007 DocClipBase::getProperty (this=0x181bf00, prop=) at /build/buildd/kdenlive-0.7.7.1+svn4571/src/docclipbase.cpp:226
0000008 0x000000000051c913 in ClipItem::paint (this=0x1aff230, painter=0x7ffff2102040, option=<value optimized out>) at /build/buildd/kdenlive-0.7.7.1+svn4571/src/clipitem.cpp:776
0000009 0x00007f07e4263629 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x1aff240, painter=0x7ffff2102040, viewTransform=<value optimized out>, transformPtr=<value optimized out>, exposedRegion=<value optimized out>, widget=0x1b22c10, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4893
0000010 0x00007f07e4263f42 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x1aff240, painter=0x7ffff2102040, viewTransform=0x7ffff2101dd0, exposedRegion=0x1b0e600, widget=0x1b22c10, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
0000011 0x00007f07e4264784 in QGraphicsScenePrivate::drawItems (this=0x1b0d900, painter=0x7ffff2102040, viewTransform=0x7ffff2101dd0, exposedRegion=0x1b0e600, widget=0x1b22c10) at graphicsview/qgraphicsscene.cpp:4699
0000012 0x00007f07e42802e3 in QGraphicsView::paintEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3467
0000013 0x00007f07e3c5ec2e in QWidget::event (this=0x1b0df60, event=0x7ffff2102970) at kernel/qwidget.cpp:8333
0000014 0x00007f07e402a5e6 in QFrame::event (this=0x1b0df60, e=0x7ffff2102970) at widgets/qframe.cpp:557
0000015 0x00007f07e427c87b in QGraphicsView::viewportEvent (this=0x1b0df60, event=0x7ffff2102970) at graphicsview/qgraphicsview.cpp:2862
0000016 0x00007f07e4d19507 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1b22c10, event=0x7ffff2102970) at kernel/qcoreapplication.cpp:847
0000017 0x00007f07e3c08fac in QApplicationPrivate::notify_helper (this=0x122eba0, receiver=0x1b22c10, e=0x7ffff2102970) at kernel/qapplication.cpp:4392
0000018 0x00007f07e3c0eaed in QApplication::notify (this=0x7ffff2104580, receiver=0x1b22c10, e=0x7ffff2102970) at kernel/qapplication.cpp:4277
0000019 0x00007f07e6a97586 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000020 0x00007f07e4d19cdc in QCoreApplication::notifyInternal (this=0x7ffff2104580, receiver=0x1b22c10, event=0x7ffff2102970) at kernel/qcoreapplication.cpp:732
0000021 0x00007f07e3c6567d in sendSpontaneousEvent (this=0x1b22c40, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x16be640) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
0000022 QWidgetPrivate::drawWidget (this=0x1b22c40, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x16be640) at kernel/qwidget.cpp:5420
0000023 0x00007f07e3e393a6 in QWidgetBackingStore::sync (this=0x16be640) at painting/qbackingstore.cpp:1320
0000024 0x00007f07e3c58730 in QWidgetPrivate::syncBackingStore (this=0x14b60f0) at kernel/qwidget.cpp:1805
0000025 0x00007f07e3c5f2f5 in QWidget::event (this=0x14b5e50, event=0x179eb30) at kernel/qwidget.cpp:8480
0000026 0x00007f07e404641b in QMainWindow::event (this=0x14b5e50, event=0x179eb30) at widgets/qmainwindow.cpp:1417
0000027 0x00007f07e6bb4c93 in KXmlGuiWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
0000028 0x00007f07e3c08fdc in QApplicationPrivate::notify_helper (this=0x122eba0, receiver=0x14b5e50, e=0x179eb30) at kernel/qapplication.cpp:4396
0000029 0x00007f07e3c0eaed in QApplication::notify (this=0x7ffff2104580, receiver=0x14b5e50, e=0x179eb30) at kernel/qapplication.cpp:4277
0000030 0x00007f07e6a97586 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000031 0x00007f07e4d19cdc in QCoreApplication::notifyInternal (this=0x7ffff2104580, receiver=0x14b5e50, event=0x179eb30) at kernel/qcoreapplication.cpp:732
0000032 0x00007f07e4d1cc22 in sendEvent (receiver=0x14b5e50, event_type=<value optimized out>, data=0x1216790) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
0000033 QCoreApplicationPrivate::sendPostedEvents (receiver=0x14b5e50, event_type=<value optimized out>, data=0x1216790) at kernel/qcoreapplication.cpp:1373
0000034 0x00007f07e426680a in dispatchPendingUpdateRequests (this=0x1b0d900) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
0000035 QGraphicsScenePrivate::_q_processDirtyItems (this=0x1b0d900) at graphicsview/qgraphicsscene.cpp:510
0000036 0x00007f07e4266d92 in QGraphicsScene::qt_metacall (this=0x1b0a170, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x1ce8490) at .moc/release-shared/moc_qgraphicsscene.cpp:130
0000037 0x00007f07e4d2bbde in QObject::event (this=0x1b0a170, e=0x7ffff2101430) at kernel/qobject.cpp:1219
0000038 0x00007f07e4260020 in QGraphicsScene::event (this=0x1b0a170, event=0x80af520) at graphicsview/qgraphicsscene.cpp:3548
0000039 0x00007f07e3c08fdc in QApplicationPrivate::notify_helper (this=0x122eba0, receiver=0x1b0a170, e=0x80af520) at kernel/qapplication.cpp:4396
0000040 0x00007f07e3c0eaed in QApplication::notify (this=0x7ffff2104580, receiver=0x1b0a170, e=0x80af520) at kernel/qapplication.cpp:4277
0000041 0x00007f07e6a97586 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000042 0x00007f07e4d19cdc in QCoreApplication::notifyInternal (this=0x7ffff2104580, receiver=0x1b0a170, event=0x80af520) at kernel/qcoreapplication.cpp:732
0000043 0x00007f07e4d1cc22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1216790) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
0000044 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1216790) at kernel/qcoreapplication.cpp:1373
0000045 0x00007f07e4d46653 in sendPostedEvents (s=0x1232770) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
0000046 postEventSourceDispatch (s=0x1232770) at kernel/qeventdispatcher_glib.cpp:277
0000047 0x00007f07de767342 in g_main_dispatch (context=0x12315f0) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2149
0000048 g_main_context_dispatch (context=0x12315f0) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2702
0000049 0x00007f07de76b2a8 in g_main_context_iterate (context=0x12315f0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2780
0000050 0x00007f07de76b45c in g_main_context_iteration (context=0x12315f0, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
0000051 0x00007f07e4d46193 in QEventDispatcherGlib::processEvents (this=0x12162d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
0000052 0x00007f07e3cbba4e in QGuiEventDispatcherGlib::processEvents (this=0x7ffff2101430, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
0000053 0x00007f07e4d18a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
0000054 0x00007f07e4d18dec in QEventLoop::exec (this=0x7ffff21044d0, flags=) at kernel/qeventloop.cpp:201
0000055 0x00007f07e4d1cebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
0000056 0x00000000004463f5 in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/kdenlive-0.7.7.1+svn4571/src/main.cpp:87
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0007394)
ttill (developer)
2011-10-02 22:08

Did you ever get this crash again?
Especially with a newer version of Kdenlive?
(0007404)
nazgul (reporter)
2011-10-03 21:58

Hi

no, I have not used kdenlive for quite some time.
The steps are very easy, you may want to repeat them on your own.
(0007409)
j-b-m (administrator)
2011-10-04 21:03

Cannot reproduce anymore in current svn. Clips removed from disk are now monitored by Kdenlive and no crash happens.

- Issue History
Date Modified Username Field Change
2011-05-01 10:36 nazgul New Issue
2011-10-02 22:08 ttill Note Added: 0007394
2011-10-02 22:08 ttill Assigned To => ttill
2011-10-02 22:08 ttill Status new => feedback
2011-10-03 21:58 nazgul Note Added: 0007404
2011-10-03 21:58 nazgul Status feedback => assigned
2011-10-04 21:03 j-b-m Note Added: 0007409
2011-10-04 21:03 j-b-m Status assigned => resolved
2011-10-04 21:03 j-b-m Fixed in Version => 0.8.2
2011-10-04 21:03 j-b-m Resolution open => fixed
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker