Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002119KdenliveFile Loadingpublic2011-05-07 19:052011-11-01 18:56
Reportersupercow 
Assigned Toj-b-m 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformPCOSArchLinuxOS VersionKDE 4.6.3
Product Version0.8 
Target VersionFixed in Version0.8.2 
Summary0002119: Crash on loading .MTS file
Descriptionanytime I try to load a .MTS (1080i from SONY HX5-V) file in kdenlive it crashes..

here is error message :

[lesbecs@arch ~]$ kdenlive
project monitor connected
clip monitor connected
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action

************
I load my clip
****************
KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
QSocketNotifier: Invalid socket 20 and type 'Read', disabling...
sock_file=/home/lesbecs/.kde4/socket-arch/kdeinit4__0

information on my version on arch :
[lesbecs@arch ~]$ pacman -Q kdenlive
kdenlive 0.8-1
[lesbecs@arch ~]$ pacman -Q mlt
mlt 0.7.2-1

If I open a existing project, I can read, edit but not add a new file....
Steps To Reproduceopen kdenlive
load a .MTS file.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon 00014.MTS [^] (7,372,800 bytes) 2011-05-07 19:05
txt file icon mlt-ffplay-logs.txt [^] (19,162 bytes) 2011-05-09 11:44 [Show Content]

- Relationships
related to 0002132feedback Crash adding clips from a certain camera to project 

-  Notes
(0006699)
j-b-m (administrator)
2011-05-08 22:27

Works for me. Can you please try playing the file with MLT and FFMEG to see if the problem is in one of those?

In a terminal:

melt 00014.MTS

ffplay 00014.MTS
(0006702)
supercow (reporter)
2011-05-09 11:45

melt => KO
ffplay => OK
I think it is more a KDE issue rather than KDENLIVE because my problem appeared with the upgrade to 4.6.3...

regards
Olivier
(0006703)
MiguelAngel_LV (reporter)
2011-05-09 19:29

Same problem.
With mlt 0.7.0 work fine for me.

You can install from here:
http://arm.konnichi.com/search/index.php?a=32&q=mlt&core=1&extra=1&community=1 [^]
(0006723)
Fabricio Rocha (reporter)
2011-05-18 17:25

Happens similarly with me as well, and I am using MLT 0.7.2 from Christian Marillat's debian-multimedia repository. Differences are:

1) I'm using 1080p files from a Panasonic HS700K camera.

2) It does not happen ALL the times, but quite often.

3) I noticed it happens specially when I try to open a project which contains the files. My source files are in removable media. If the media is not mounted, Kdenlive shows the "missing files" dialog, and when I mount the media and go on, the files are correctly imported and it everything works (for a while). If I start Kdenlive then load the project with the media already mounted, bang.

4) I noticed that, along the "null action" message from QWidget, there is also a similar "QCoreApplication" (or something alike, I can't recall or reproduce it at the moment) complaint on stderr about a null.

Thanks!

Fabricio
(0006781)
supercow (reporter)
2011-05-29 22:17

I have same crash with Amarok. so I guess it is not a pure Kdenlive issue...do you think these software should be rebuild after latest KDE update ?
(0006788)
supercow (reporter)
2011-05-30 23:07

ok. definitively a problem with mlt 0.7.2. I downgraded to mlt 0.7.0 and it works fine...thanks MiguelAngel for the tip.
(0006805)
supercow (reporter)
2011-06-03 22:09

can anyone open a new bug in MLT ? I tried to register twice but never received the confirmation mail from sourceforge....
(0007070)
supercow (reporter)
2011-07-09 20:28

you can now close this bug. package was rebuild for arch 64bits architecture (version mlt 0.7.2-1.1) and it works fine now.

regards
Olivier

- Issue History
Date Modified Username Field Change
2011-05-07 19:05 supercow New Issue
2011-05-07 19:05 supercow File Added: 00014.MTS
2011-05-08 22:27 j-b-m Note Added: 0006699
2011-05-08 22:27 j-b-m Assigned To => j-b-m
2011-05-08 22:27 j-b-m Status new => feedback
2011-05-09 11:44 supercow File Added: mlt-ffplay-logs.txt
2011-05-09 11:45 supercow Note Added: 0006702
2011-05-09 11:45 supercow Status feedback => assigned
2011-05-09 19:29 MiguelAngel_LV Note Added: 0006703
2011-05-18 17:25 Fabricio Rocha Note Added: 0006723
2011-05-19 20:53 j-b-m Relationship added related to 0002132
2011-05-29 22:17 supercow Note Added: 0006781
2011-05-30 23:07 supercow Note Added: 0006788
2011-06-03 22:09 supercow Note Added: 0006805
2011-07-09 20:28 supercow Note Added: 0007070
2011-07-10 12:13 j-b-m Status assigned => resolved
2011-07-10 12:13 j-b-m Fixed in Version => 0.8.2
2011-07-10 12:13 j-b-m Resolution open => no change required
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker