Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000212KdenliveMLTpublic2008-10-16 10:182008-11-12 22:22
Reporterdoitux 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.0Fixed in Version0.7.0 
Summary0000212: crash when deleting a transition in a saved project
DescriptionThis bug only appear if you save and reopen a project.

1. start a clean project.
2. add two clips to the timeline.
3. place a transition between the clips
4. save the project, close kdenlive.
5. start kdenlive, reopen the project
6. click on the transition try to delete --> crash
Additional Informationhere is the gdb output:

kdenlive(13166) EffectStackEdit::transferParamDesc: in form
kdenlive(13166) Render::mltDeleteTransition: // FOUND EXISTING TRANS, IN: 1447 , OUT: 1588 , TRACK: 5

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb16ffb90 (LWP 13195)]
0xb7c67520 in pthread_mutex_lock () from /lib/libpthread.so.0
(gdb) bt
#0 0xb7c67520 in pthread_mutex_lock () from /lib/libpthread.so.0
#1 0xb806ca69 in mlt_properties_dec_ref (this=0x338b) at mlt_properties.c:211
0000002 0xb807153e in mlt_service_close (this=0xb2791bc0) at mlt_service.c:498
0000003 0xb80685eb in mlt_frame_close (this=0x871f9b0) at mlt_frame.c:510
0000004 0xb806c149 in mlt_property_close (this=0x87205e0) at mlt_property.c:56
0000005 0xb806cb50 in mlt_properties_close (this=0xb27209e8)
    at mlt_properties.c:910
0000006 0xb806860d in mlt_frame_close (this=0xb27209e8) at mlt_frame.c:512
0000007 0xb3c380f3 in consumer_thread (arg=0xb1f64318) at consumer_sdl_still.c:573
0000008 0xb7c66175 in start_thread () from /lib/libpthread.so.0
0000009 0xb65e8dce in clone () from /lib/libc.so.6
TagsNo tags attached.
Build/Install Method
Attached Files? file icon kbw.gdb.output.xtY25677 [^] (54,250 bytes) 2008-10-17 18:30

- Relationships

-  Notes
(0000425)
doitux (updater)
2008-10-16 12:26

I recognized if you change any transition parameter (transition type e.g) after reloading the project and then delete the transition the crash doesnt appear.
(0000429)
madsdyd (administrator)
2008-10-17 18:30

I have confirmed this on my system, will be attaching a full log file from the second instantiation of Kdenlive.
(0000445)
administrator (administrator)
2008-10-18 22:23

Should be fixed in svn revision 2481, can you please confirm that it now works ?
(0000446)
doitux (updater)
2008-10-18 23:03

I cannot reproduce it anymore. Seems to work fine. Thx for fixing.

- Issue History
Date Modified Username Field Change
2008-10-16 10:18 doitux New Issue
2008-10-16 12:26 doitux Note Added: 0000425
2008-10-17 18:30 madsdyd Note Added: 0000429
2008-10-17 18:30 madsdyd Status new => acknowledged
2008-10-17 18:30 madsdyd File Added: kbw.gdb.output.xtY25677
2008-10-18 22:23 administrator Note Added: 0000445
2008-10-18 23:03 doitux Note Added: 0000446
2008-10-18 23:22 administrator Status acknowledged => resolved
2008-10-18 23:22 administrator Resolution open => fixed
2008-10-23 00:20 madsdyd Target Version => 0.7.0
2008-10-23 00:22 madsdyd Status resolved => closed
2008-11-12 22:22 madsdyd Fixed in Version => 0.7.0


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker