Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002144KdenliveFile Loadingpublic2011-05-27 08:082011-05-27 17:56
Reporterevorster 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusassignedResolutionreopened 
PlatformSorcererOSLinuxOS Version2.6.34.6
Product Version0.8 
Target VersionFixed in VersionRecent git 
Summary0002144: Hangs when I load a project.
DescriptionI was happily editing something trivial for my work. I had a lot of PAL footage, and one NTSC clip. So, I tried running the NTSC clip at 83% speed to see if I can get all the frames to display and get rid of the jerkiness when doing panning.

I rendered the project a few times, and as far as I could tell my hack did not work, but nothing else was wrong with the project. I rendered it and saved it. Now that I want to open it again, it hangs at 50% Loading.
Steps To ReproduceLoad attached project file. It's only 60kb, but it hangs my kdenlive solid, even when I remove the drive the clips are on and just replace them with palceholders.
Additional InformationI am attaching the project file to see if anyone else can reproduce the failure.
TagsNo tags attached.
Build/Install MethodManual build from release
Attached Files? file icon 2011_05_Columbus_Improvements.kdenlive [^] (61,820 bytes) 2011-05-27 08:08
? file icon fixed.kdenlive [^] (61,819 bytes) 2011-05-27 10:31

- Relationships

-  Notes
(0006741)
evorster (reporter)
2011-05-27 08:12

When I open kdenlive from a terminal and try to load the project, I get this error message repeating until I kill kdenlive:

kdenlive(17014) TrackView::slotAddProjectTrack: CANNOT INSERT CLIP "3_2"

Could it be that my project file is just corrupt?
(0006744)
j-b-m (administrator)
2011-05-27 09:54

I can reproduce the freeze, working on it...
(0006745)
j-b-m (administrator)
2011-05-27 10:31

Thanks for the bug report, I discovered 3 different issues that are now fixed in svn (rev. 5611). I am uploading a fixed project file so that you can continue working.
(0006747)
j-b-m (administrator)
2011-05-27 10:39

Oh, and I wanted to ask you one thing:

Did you start the project with a previous Kdenlive version (0.7.8 of previous) or was the project entirely done in 0.8? Because I think the project corruption might be due to a bug I fixed in Kdenlive 0.8...
(0006748)
evorster (reporter)
2011-05-27 17:56

It was created in 0.8.

As I said, it was trivial, but thanks for fixing the project file in any case.

It was just curious that just loading a file can hang kdenlive so badly, so I felt the need to report it.

:)


Happy hacking.

- Issue History
Date Modified Username Field Change
2011-05-27 08:08 evorster New Issue
2011-05-27 08:08 evorster File Added: 2011_05_Columbus_Improvements.kdenlive
2011-05-27 08:12 evorster Note Added: 0006741
2011-05-27 09:54 j-b-m Note Added: 0006744
2011-05-27 09:54 j-b-m Assigned To => j-b-m
2011-05-27 09:54 j-b-m Status new => acknowledged
2011-05-27 10:31 j-b-m Note Added: 0006745
2011-05-27 10:31 j-b-m Status acknowledged => resolved
2011-05-27 10:31 j-b-m Fixed in Version => Recent git
2011-05-27 10:31 j-b-m Resolution open => fixed
2011-05-27 10:31 j-b-m File Added: fixed.kdenlive
2011-05-27 10:39 j-b-m Note Added: 0006747
2011-05-27 10:39 j-b-m Status resolved => feedback
2011-05-27 10:39 j-b-m Resolution fixed => reopened
2011-05-27 17:56 evorster Note Added: 0006748
2011-05-27 17:56 evorster Status feedback => assigned


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker