Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002166KdenliveMLTpublic2011-06-13 22:112011-11-01 18:56
Reporterstef716 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformAMD64OSDebianOS VersionWheezy
Product Version0.8 
Target VersionFixed in Version0.8.2 
Summary0002166: crash after adding Canon HG-20 1080i clip
DescriptionHi,

I'm using the latest Debian Wheezy kdenlive 0.8-4 and other required packages from more recent Debian Multimedia repository:

melt 1:0.7.2-0.1
libmlt++3 1:0.7.2-0.1
libmlt-data 1:0.7.2-0.1
libmlt4 1:0.7.2-0.1
ffmpeg 5:0.6.2-0.4
libqtgui4 4:4.7.3-1
libqtcore4 4:4.7.3-1
libkdeui5 4:4.6.3-3
Linux kernel 2.6.32 or 2.6.38.

When I add a clip kdenlive crashes every time (even on new empty project).
When I open an existing project I can work as usual with the clips already added before. But same crash when I select Clip Properties.

My clips are .MTS from Canon HG-20 camcorder (AVCHD, 1080i 25fps, 24MBit/s).
Pictures and low quality videos work fine. I tried 1080i, 576p, .mp4, .mpg and can't really see what is so special about the videos crashing. It's just the high bandwidth material crashes regularly.

Workaround for me is to delete the file:
/usr/lib/mlt/libmltxine.so

Then everything works fine.

thanks
Stefan
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files? file icon kdenlive-20110613-213453.kcrash [^] (5,191 bytes) 2011-06-13 22:11 [Show Content]

- Relationships

-  Notes
(0006906)
stef716 (reporter)
2011-06-18 11:15

The camera is already registered in your database:
http://www.kdenlive.org/video-editor/canon-hg21 [^]
The sample file stored on this page crashes in the same way:

ffplay HG21_MXP_30PF.mts ... works
melt HG21_MXP_30PF.mts ... crash
(0007179)
ttill (developer)
2011-08-10 16:14

That sounds like you triggered:
http://sourceforge.net/tracker/?func=detail&aid=3316086&group_id=96039&atid=613414 [^]
(0007187)
stef716 (reporter)
2011-08-10 20:24

yes. Looks like the same issue.

Debian Multimedia package maintainer already released a working version

- Issue History
Date Modified Username Field Change
2011-06-13 22:11 stef716 New Issue
2011-06-13 22:11 stef716 File Added: kdenlive-20110613-213453.kcrash
2011-06-18 11:15 stef716 Note Added: 0006906
2011-08-10 16:14 ttill Note Added: 0007179
2011-08-10 16:14 ttill Status new => feedback
2011-08-10 20:24 stef716 Note Added: 0007187
2011-08-10 20:24 stef716 Status feedback => new
2011-08-12 10:57 ttill Status new => resolved
2011-08-12 10:57 ttill Fixed in Version => 0.8.2
2011-08-12 10:57 ttill Resolution open => fixed
2011-08-12 10:57 ttill Assigned To => ddennedy
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker