Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002189KdenliveUser Interfacepublic2011-06-25 01:512011-11-01 18:56
Reporterigloo 
Assigned Toj-b-m 
PriorityhighSeveritymajorReproducibilityrandom
StatusclosedResolutionfixed 
Platformamd64OSDebian LinuxOS Versionunstable
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002189: Moving multiple clips/transitions goes wrong ("Error removing clip at ...)
DescriptionI have r5728.
Steps To ReproduceOpen attached move.kdenlive.

Select "Use placeholders for missing clips", then "OK".

Answer "No" to the request to create "/nosuchpath".

Answer "OK" to the message about document project folders.

Shift-click-and-drag to select all the clips and transitions.

Click and drag to move left a few seconds.
Click and drag to move left a few seconds again.
Keep doing so (or try moving right instead). After two or three moves you should get a message like "Error removing clip at 00:26:07:02 on track 3".
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files? file icon move.kdenlive [^] (78,617 bytes) 2011-06-25 01:51

- Relationships

-  Notes
(0006947)
j-b-m (administrator)
2011-06-25 22:19

I changed the handling of placeholder clips in svn rev. 5729, it should fix the problem, please test
(0006950)
igloo (reporter)
2011-06-25 22:32

Does the change only affect placeholder clips?

My real problem is with real clips, but my testcase uses placeholder clips as I don't want to upload several gigabytes of video :-)
(0006951)
j-b-m (administrator)
2011-06-25 22:40

Oh, ok. I fixed a problem related to missing / placeholder clips. I did not understand the problem happend with real clips. That is a bigger problem.

I see that your project uses proxy, that might be a proxy issue. Could you try to disable proxies and tell me if the problem is still here?
(0006952)
igloo (reporter)
2011-06-25 23:00

If I turn off proxies in the testcase, with the placeholders, then I can still reproduce it. Incidentally, my ~/kdenlive/ doesn't have proxies for the clips anyway, so I don't think that can be relevant.

I just tried to turn proxy off in the real project, but ran into this:
http://kdenlive.org/mantis/view.php?id=2194 [^]
(0006953)
igloo (reporter)
2011-06-26 00:51

Just to clarify my last comment: The real project does have proxies of the clips, but its project folder isn't ~/kdenlive/.
(0006962)
j-b-m (administrator)
2011-06-27 09:54

Could you please test again with latest svn (both in real project and with placeholders)? I made several changes to the handling of proxies that should prevent crashes...
(0006964)
igloo (reporter)
2011-06-27 13:19

With r5734, and the testcase in this ticket:

After "Use placeholders for missing clips" the proxies stay as crosses rather than ticks. I continue anyway, but kdenlive seems to freeze at "Loading project 75%".

$ strace -p 13356
Process 13356 attached - interrupt to quit
futex(0x2297f8c, FUTEX_WAIT_PRIVATE, 1, NULL
(0006965)
j-b-m (administrator)
2011-06-27 13:29

Thanks. The freeze shoud be fixed in svn 5736
(0006966)
igloo (reporter)
2011-06-27 13:40

With 5736, moving things around in the testcase now seems to be OK. However, kdenlive is crashing a lot more. When trying to zoom out with the mouse wheel in the real project, I got a crash twice in a row:

Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fac66127780 (LWP 14538))]

Thread 2 (Thread 0x7fac35a29700 (LWP 14542)):
#0 0x00007fac63b7463b in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007fac651f061e in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
0000002 0x00007fac651e4d6f in ?? () from /usr/lib/libQtCore.so.4
0000003 0x00007fac651f0215 in ?? () from /usr/lib/libQtCore.so.4
0000004 0x00007fac63b6fb40 in start_thread () from /lib/libpthread.so.0
0000005 0x00007fac5fd9d2ed in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fac66127780 (LWP 14538)):
[KCrash Handler]
0000006 mlt_deque_pop_back (self=0x0) at mlt_deque.c:130
0000007 0x00007fac44d5f8ec in producer_avformat_close (self=0x40d2ce0) at producer_avformat.c:2573
0000008 0x00007fac65d3d636 in cache_object_close (object=<value optimized out>, data=0x0, cache=<value optimized out>) at mlt_cache.c:131
0000009 0x00007fac65d3db58 in mlt_cache_put (cache=0x3a2b250, object=0x35d7ac0, data=0x32fc190, size=0, destructor=0x7fac44d5f7d0 <producer_avformat_close>) at mlt_cache.c:355
0000010 0x00007fac44d639b1 in producer_avformat_init (profile=0x2d2ffc0, service=<value optimized out>, file=0x330c758 "/home/ian/ext1/wedding/2_ceremony/kdenlive/proxy/1277f8406663555d9cc382daa2c727db.ts") at producer_avformat.c:215
0000011 0x00007fac65d3b18a in mlt_factory_producer (profile=0x2d2ffc0, service=0x3351eb0 "avformat", input=0x330c758) at mlt_factory.c:250
0000012 0x00007fac44f70e42 in create_from (profile=0x2d2ffc0, file=0x330c758 "/home/ian/ext1/wedding/2_ceremony/kdenlive/proxy/1277f8406663555d9cc382daa2c727db.ts") at producer_loader.c:43
0000013 create_producer (profile=0x2d2ffc0, file=0x330c758 "/home/ian/ext1/wedding/2_ceremony/kdenlive/proxy/1277f8406663555d9cc382daa2c727db.ts") at producer_loader.c:98
0000014 0x00007fac44f7113c in producer_loader_init (profile=0x2d2ffc0, type=<value optimized out>, id=0x2862960 "loader", arg=<value optimized out>) at producer_loader.c:198
0000015 0x00007fac65d3b18a in mlt_factory_producer (profile=0x2d2ffc0, service=0x2862960 "loader", input=0x330c758) at mlt_factory.c:250
0000016 0x00007fac65b13d7e in Mlt::Producer::Producer(Mlt::Profile&, char const*, char const*) () from /home/ian/code/melt/inst/lib/libmlt++.so.3
0000017 0x00000000004c3639 in Render::getFileProperties (this=0x2d300c0, xml=..., clipId=..., imageHeight=36, replaceProducer=false, selectClip=false) at /home/ian/code/kdenlive/kdenlive/src/renderer.cpp:598
0000018 0x00000000004c8636 in Render::qt_metacall (this=0x2d300c0, _c=<value optimized out>, _id=22, _a=0x7fac3006dfc0) at /home/ian/code/kdenlive/kdenlive/build/src/cmake_bindir/renderer.moc:156
0000019 0x00007fac652ecd2a in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
0000020 0x00007fac60c4c6d4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000021 0x00007fac60c51561 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000022 0x00007fac64d42fb6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000023 0x00007fac652d65fc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000024 0x00007fac652d9944 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
0000025 0x00007fac65300cc3 in ?? () from /usr/lib/libQtCore.so.4
0000026 0x00007fac5eeb34a3 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000027 0x00007fac5eeb3c80 in ?? () from /lib/libglib-2.0.so.0
0000028 0x00007fac5eeb3f1d in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000029 0x00007fac6530111f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000030 0x00007fac60cf068e in ?? () from /usr/lib/libQtGui.so.4
0000031 0x00007fac652d5802 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000032 0x00007fac652d59ff in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000033 0x00007fac652d9bd7 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000034 0x0000000000451fbb in main (argc=2, argv=0x7fff93d443a8) at /home/ian/code/kdenlive/kdenlive/src/main.cpp:89
(0006979)
j-b-m (administrator)
2011-06-28 20:43

Ok, was a bit tricky, but I think I now fixed the proxy related crashes. At least works for me now on simple projects. Can you try again (svn rev. 5743)
(0006982)
igloo (reporter)
2011-06-28 23:28

Now, with r5744, crashes just loading the project:

Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4f4234a780 (LWP 3314))]

Thread 2 (Thread 0x7f4f11c4c700 (LWP 3318)):
#0 0x00007f4f3fd9763b in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f4f4141361e in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
0000002 0x00007f4f41407d6f in ?? () from /usr/lib/libQtCore.so.4
0000003 0x00007f4f41413215 in ?? () from /usr/lib/libQtCore.so.4
0000004 0x00007f4f3fd92b40 in start_thread () from /lib/libpthread.so.0
0000005 0x00007f4f3bb1c2ed in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4f4234a780 (LWP 3314)):
[KCrash Handler]
0000006 mlt_deque_pop_back (self=0x0) at mlt_deque.c:130
0000007 0x00007f4f20f828ec in producer_avformat_close (self=0x3fec180) at producer_avformat.c:2573
0000008 0x00007f4f41f60636 in cache_object_close (object=<value optimized out>, data=0x0, cache=<value optimized out>) at mlt_cache.c:131
0000009 0x00007f4f41f60b58 in mlt_cache_put (cache=0x39446f0, object=0x7f4f0c00e870, data=0x7f4f0c108760, size=0, destructor=0x7f4f20f827d0 <producer_avformat_close>) at mlt_cache.c:355
0000010 0x00007f4f20f869b1 in producer_avformat_init (profile=0x2c459f0, service=<value optimized out>, file=0x7f4f0c107a28 "/home/ian/ext1/wedding/2_ceremony/kdenlive/proxy/1277f8406663555d9cc382daa2c727db.ts") at producer_avformat.c:215
0000011 0x00007f4f41f5e18a in mlt_factory_producer (profile=0x2c459f0, service=0x7f4f0c09d910 "avformat", input=0x7f4f0c107a28) at mlt_factory.c:250
0000012 0x00007f4f21193e42 in create_from (profile=0x2c459f0, file=0x7f4f0c107a28 "/home/ian/ext1/wedding/2_ceremony/kdenlive/proxy/1277f8406663555d9cc382daa2c727db.ts") at producer_loader.c:43
0000013 create_producer (profile=0x2c459f0, file=0x7f4f0c107a28 "/home/ian/ext1/wedding/2_ceremony/kdenlive/proxy/1277f8406663555d9cc382daa2c727db.ts") at producer_loader.c:98
0000014 0x00007f4f2119413c in producer_loader_init (profile=0x2c459f0, type=<value optimized out>, id=0x2773cf0 "loader", arg=<value optimized out>) at producer_loader.c:198
0000015 0x00007f4f41f5e18a in mlt_factory_producer (profile=0x2c459f0, service=0x2773cf0 "loader", input=0x7f4f0c107a28) at mlt_factory.c:250
0000016 0x00007f4f41d36d7e in Mlt::Producer::Producer(Mlt::Profile&, char const*, char const*) () from /home/ian/code/melt/inst/lib/libmlt++.so.3
0000017 0x00000000004c3dda in Render::getFileProperties (this=0x2c45af0, xml=..., clipId=..., imageHeight=36, replaceProducer=false, selectClip=false) at /home/ian/code/kdenlive/kdenlive/src/renderer.cpp:598
0000018 0x00000000004c8dd6 in Render::qt_metacall (this=0x2c45af0, _c=<value optimized out>, _id=22, _a=0x7f4f0c0a9f60) at /home/ian/code/kdenlive/kdenlive/build/src/cmake_bindir/renderer.moc:156
0000019 0x00007f4f4150fd2a in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
0000020 0x00007f4f3c9cb6d4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000021 0x00007f4f3c9d0561 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000022 0x00007f4f40f65fb6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000023 0x00007f4f414f95fc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000024 0x00007f4f414fc944 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
0000025 0x00007f4f41523cc3 in ?? () from /usr/lib/libQtCore.so.4
0000026 0x00007f4f3ac324a3 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000027 0x00007f4f3ac32c80 in ?? () from /lib/libglib-2.0.so.0
0000028 0x00007f4f3ac32f1d in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000029 0x00007f4f4152411f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000030 0x00007f4f3ca6f68e in ?? () from /usr/lib/libQtGui.so.4
0000031 0x00007f4f414f8802 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000032 0x00007f4f414f89ff in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000033 0x00007f4f414fcbd7 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000034 0x00000000004524bb in main (argc=2, argv=0x7fff9e3af638) at /home/ian/code/kdenlive/kdenlive/src/main.cpp:89
(0007027)
j-b-m (administrator)
2011-07-05 13:15

There was an issue with the "Do not validate clips on project opening" option that is in Kdenlive's settings dialog -> Misc.

If that option was enabled, it caused crashes. I now disabled it so could you please test latest svn?
(0007054)
igloo (reporter)
2011-07-07 02:53

I think you can close this.

- Issue History
Date Modified Username Field Change
2011-06-25 01:51 igloo New Issue
2011-06-25 01:51 igloo File Added: move.kdenlive
2011-06-25 22:19 j-b-m Note Added: 0006947
2011-06-25 22:19 j-b-m Assigned To => j-b-m
2011-06-25 22:19 j-b-m Status new => feedback
2011-06-25 22:32 igloo Note Added: 0006950
2011-06-25 22:32 igloo Status feedback => assigned
2011-06-25 22:40 j-b-m Note Added: 0006951
2011-06-25 23:00 igloo Note Added: 0006952
2011-06-26 00:51 igloo Note Added: 0006953
2011-06-27 09:54 j-b-m Note Added: 0006962
2011-06-27 13:19 igloo Note Added: 0006964
2011-06-27 13:29 j-b-m Note Added: 0006965
2011-06-27 13:40 igloo Note Added: 0006966
2011-06-28 20:43 j-b-m Note Added: 0006979
2011-06-28 23:28 igloo Note Added: 0006982
2011-07-05 13:15 j-b-m Note Added: 0007027
2011-07-07 02:53 igloo Note Added: 0007054
2011-07-07 11:22 j-b-m Status assigned => resolved
2011-07-07 11:22 j-b-m Fixed in Version => 0.8.2
2011-07-07 11:22 j-b-m Resolution open => fixed
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker