Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002213KdenliveEffectspublic2011-07-04 13:352011-11-01 18:56
ReporterAlexK 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
Platform32 bit intel and alikeOSDebian LinuxOS Version4.0
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002213: Pan & Zoom looses sync when panning with stacked clips
DescriptionUsing Pan & Zoom to animate a .png image across the screen works only when that image is viewed in isolation. If other clips are not hidden, the monitor shows the image about 50% (of x-zoom-region) to the left of where it should be. This affects only the first of 3 stacked PNGs.

This is complicated to describe. Therefore, 2 screen-shots uploaded:
postion-correct.jpg: in the project monitor, the view is correct
position-actual.jpg: the image is displaced, (zoom-region still accurate)

Please note:
With position-correct.jpg: title clips (track 2), avi clip (track 3) & colour clip (track 7) have their video hidden. This is what happens if those individual tracks are un-hidden:

title clips (track 2): image disappears
avi clip (track 3): image disappears
colour clip (track 7): misplaced-image appears
Steps To Reproduce1 drop titles, avi, PNGs & colour clips into the timeline
2 apply Pan & Zoom, keyframes to each AVI & PNGs & animate
3 play back
Additional Information$ $HOME/kdenlive/20110704/start-kdenlive --version
Kdenlive Builder Wizard version: 11
libvpx: commit b4f70084cc64b8304005a385cb0a670431aced20 Date: Fri Jul 1 07:14:34 2011 -0700
x264: commit 4c552d873ada1be3cf2d77965427fab599d051a0 Date: Thu Jun 9 01:34:14 2011 +0400
frei0r: commit 6c65d6a48b8c0d51791bc3ba7e25a161c95fac30 Date: Wed Mar 16 00:54:34 2011 -0700
ffmpeg: commit 80f1cfd09d15be441d6b22c259397aaec29a7b27 Date: Mon Jul 4 11:15:14 2011 +0200
mlt: commit 6481ebb58cf2f477d12fcf563903aeea6fe90928 Date: Sun Jul 3 13:12:26 2011 -0700
kdenlive: Revision: 5762 Last Changed Date: 2011-07-04 09:18:01 +0100 (Mon, 04 Jul 2011)
Qt: 4.7.3
KDE Development Platform: 4.4.5 (KDE 4.4.5)
Kdenlive: 0.8.1 (rev. 5762)
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filesjpg file icon position-correct.jpg [^] (184,189 bytes) 2011-07-04 13:35


jpg file icon position-actual.jpg [^] (196,242 bytes) 2011-07-04 13:36


? file icon ei.kdenlive [^] (129,357 bytes) 2011-07-04 13:37

- Relationships

-  Notes
(0007020)
AlexK (reporter)
2011-07-04 13:46

When I produced a test-project for another Pan & Zoom bug report (loss of keyframes - it failed for that test), this bug was reproduced perfectly.
(0007021)
AlexK (reporter)
2011-07-04 17:52

3 hours to render and, sure enough, the .avi shows exactly the same as the monitor view - the animation finishes near the centre of the screen, rather than at far RHS as the parameter at that keyframe stipulates.
(0007024)
j-b-m (administrator)
2011-07-05 00:00

Can you try to uncheck the "Align" and "Fill" properties of the composite transitions that are applied on the clips that show that wrong position problem? I think that might solve your problem.

By the way, I don't think you should be using the "Pan & Zoom" effect for this. Everything can be achieved with the parameters of the composite transitions.
(0007025)
AlexK (reporter)
2011-07-05 09:40

That did it - it was a combo of `Align' on all Composition transitions *below* the first PNG. I removed `Fill' also, although I could not detect any effects in doing so. Many thanks.

"Everything can be achieved with the parameters of the composite transitions"

Possibly so. Pan & Zoom was used because I have found it reliable plus simple to use & understand. The composites were there only because otherwise the PNGs would not display. I do not have the faintest clue what half of the Composite settings do.

Write this one down to user error & ignorance, please. My apologies, and grateful thanks for your advice.

- Issue History
Date Modified Username Field Change
2011-07-04 13:35 AlexK New Issue
2011-07-04 13:35 AlexK File Added: position-correct.jpg
2011-07-04 13:36 AlexK File Added: position-actual.jpg
2011-07-04 13:37 AlexK File Added: ei.kdenlive
2011-07-04 13:46 AlexK Note Added: 0007020
2011-07-04 17:52 AlexK Note Added: 0007021
2011-07-04 23:38 j-b-m Description Updated View Revisions
2011-07-05 00:00 j-b-m Note Added: 0007024
2011-07-05 00:00 j-b-m Assigned To => j-b-m
2011-07-05 00:00 j-b-m Status new => feedback
2011-07-05 09:40 AlexK Note Added: 0007025
2011-07-05 09:40 AlexK Status feedback => assigned
2011-07-05 12:11 j-b-m Status assigned => resolved
2011-07-05 12:11 j-b-m Fixed in Version => Recent git
2011-07-05 12:11 j-b-m Resolution open => no change required
2011-07-05 12:15 j-b-m Fixed in Version Recent git => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker