Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002217KdenliveFile Loadingpublic2011-07-06 03:382011-11-01 18:56
Reporterigloo 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformamd64OSDebian LinuxOS Versionunstable
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002217: Project corruption
Description
I have r5764.

I guess there are 2 bugs here: one that got the project into a bad state, and one that means kdenlive doesn't recover properly. I'm more keen in the first one being fixed, but sadly only know how to reproduce the second.
Steps To ReproduceOpen corrupts.kdenlive in kdenlive,

Box says:
Replaced wrong clip producer producer0 with 5
Replaced wrong clip producer producer0 with 5
Replaced wrong clip producer producer0 with 5
Replaced wrong clip producer producer0 with 5
Replaced wrong clip producer producer0 with 5
Replaced wrong clip producer producer0 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5
Replaced wrong clip producer producer1 with 5

Say OK.

After about 2.5mins of CPU time (!) the project has loaded.

Press the "Save" button.

At this point, a clip is shown with position 54:02:36, but the
project monitor is just black during that clip. Attempting to move
the clip yields "Cannot move clip to position ...".

Close kdenlive. Do not save changes.

Restart kdenlive, opening the project. The clip is not there.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files? file icon corrupts.kdenlive [^] (315,149 bytes) 2011-07-06 03:38

- Relationships

-  Notes
(0007042)
j-b-m (administrator)
2011-07-06 03:47

Thanks for your reports. I am sorry about all the corruption of these days, but it allowed me to fix several important issues. I just committed several changes that should fix the "broken producer" errors that appeared since a few days. Also fixed an issue in recovery, so please test with svn rev. 5767
(0007055)
igloo (reporter)
2011-07-07 02:55

Sorry for venting my frustration at you, j-b-m. Thanks for all your fixes, and I am glad the reports are useful. I was worried that just having the corrupted result wouldn't tell you anything about what caused it.

Anyway, I am no longer getting the "Replaced wrong clip producer producer1 with 5" error, so I think this can be closed.

- Issue History
Date Modified Username Field Change
2011-07-06 03:38 igloo New Issue
2011-07-06 03:38 igloo File Added: corrupts.kdenlive
2011-07-06 03:47 j-b-m Note Added: 0007042
2011-07-06 03:47 j-b-m Assigned To => j-b-m
2011-07-06 03:47 j-b-m Status new => feedback
2011-07-07 02:55 igloo Note Added: 0007055
2011-07-07 02:55 igloo Status feedback => assigned
2011-07-07 11:21 j-b-m Status assigned => resolved
2011-07-07 11:21 j-b-m Fixed in Version => 0.8.2
2011-07-07 11:21 j-b-m Resolution open => fixed
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker