Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002230KdenliveUser Interfacepublic2011-07-11 20:362011-11-01 18:56
Reporterigloo 
Assigned Toj-b-m 
PriorityhighSeverityblockReproducibilityalways
StatusclosedResolutionno change required 
Platformamd64OSDebian LinuxOS Versionunstable
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002230: segfault starting kdenlive
Description
I've just upgraded various OS packages, removed the Debian frei0r* packages, built the latest frei0r git, and then recompiled the latest git mlt and svn kdenlive (r5787).

Now when I run "kdenlive" I get a segfault:

Application: Kdenlive (kdenlive), signal: Segmentation fault
[KCrash Handler]
0000006 mlt_properties_find (self=0x0, name=0x73b237 "window_id") at mlt_properties.c:479
0000007 mlt_properties_fetch (self=0x0, name=0x73b237 "window_id") at mlt_properties.c:555
0000008 0x00007fa53cb7601c in mlt_properties_set_int (self=0x0, name=0x73b237 "window_id", value=37748817) at mlt_properties.c:887
0000009 0x00007fa53c95b332 in Mlt::Properties::set(char const*, int) () from /home/ian/code/melt/inst/lib/libmlt++.so.3
0000010 0x00000000004c1649 in Render::buildConsumer (this=0x164f670, profileName=<value optimized out>) at /home/ian/code/kdenlive/kdenlive/src/renderer.cpp:245
0000011 0x00000000004c204f in Render::Render (this=0x164f670, rendererName=<value optimized out>, winid=37748817, profile=..., parent=<value optimized out>) at /home/ian/code/kdenlive/kdenlive/src/renderer.cpp:120
0000012 0x00000000004b0487 in Monitor::Monitor (this=0x1263220, name=..., manager=<value optimized out>, profile=<value optimized out>, parent=<value optimized out>) at /home/ian/code/kdenlive/kdenlive/src/monitor.cpp:170
0000013 0x00000000004819d7 in MainWindow::MainWindow (this=0x1295e10, MltPath=<value optimized out>, Url=..., clipsToLoad=..., parent=<value optimized out>, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /home/ian/code/kdenlive/kdenlive/src/mainwindow.cpp:202
0000014 0x0000000000452853 in main (argc=1, argv=0x7fff833bc048) at /home/ian/code/kdenlive/kdenlive/src/main.cpp:84
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0007077)
igloo (reporter)
2011-07-12 00:37

Using the script on
http://www.mltframework.org/twiki/bin/view/MLT/BuildScripts#Kdenlive [^]
gives me a working kdenlive, so I must have done something wrong. Still, a nicer error than a segfault would be nice!

I'll try to put together instructions to reproduce shortly.
(0007086)
igloo (reporter)
2011-07-15 19:13

Hmm, I can't reproduce this now. Maybe something got fixed, or maybe I just screwed up. Please close this ticket, and sorry for the noise.

- Issue History
Date Modified Username Field Change
2011-07-11 20:36 igloo New Issue
2011-07-12 00:37 igloo Note Added: 0007077
2011-07-15 19:13 igloo Note Added: 0007086
2011-07-16 17:47 j-b-m Status new => resolved
2011-07-16 17:47 j-b-m Fixed in Version => 0.8.2
2011-07-16 17:47 j-b-m Resolution open => no change required
2011-07-16 17:47 j-b-m Assigned To => j-b-m
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker