Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002235KdenliveEffectspublic2011-07-12 20:522013-01-28 19:50
ReportereSyr 
Assigned Tovpinon 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86-64OSDebian GNU/LinuxOS Version6.0
Product Version0.7.8 
Target VersionFixed in Version0.9.4 
Summary0002235: Crop applies before any other effect
DescriptionCrop applies before any other effect
Steps To Reproduce * Add several effects, like "Rotate and Shear" or "Corners"
 * Add Crop effect after them
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filespng file icon kdenlive_crop_3.png [^] (1,143,605 bytes) 2011-07-12 20:52
png file icon kdenlive_crop_1.png [^] (1,503,037 bytes) 2011-07-12 21:16

- Relationships

-  Notes
(0007170)
ttill (developer)
2011-08-10 15:47

Yes.
The MLT maintainer (Dan) wants it to be that way because it is also used for some internal stuff.
Maybe another Crop filter should be created and the current one then hidden.
(0007183)
ddennedy (developer)
2011-08-10 17:37

Use Scale and Tilt.

Crop uses the video/image at its full resolution prior to any automatic scaling and padding to make it fit in the project resolution. Then, all other effects apply. For best quality, it is best to crop the image at its full resolution before scaling an input down to project resolution. This is useful for high resolution photos or HD-to-SD conversion, especially when using the center option to eliminate padding.

Perhaps we should rename 'Crop' to 'Edge Crop' and 'Scale and Tilt' to 'Crop, Scale, and Position' (and its parameters).
(0008164)
PeterA (reporter)
2012-07-18 19:31
edited on: 2012-07-18 19:38

I stumbled over this bug a few weeks ago. I had a tight deadline, so I had not time to look up the bugtracker. I made up a workaround (working for my case), using a Title-Clip with black rectangles on each side and "Composite" transition. But this is not very nice and works only you want to "crop to black".

Now with more time, I found this bug report and tested ddennedy's tip, using the "Scale and Tilt" filter. Result: It did perfectly crop, what I wanted to be cropped.

So I definitely vote for renaming "Scale and Tilt" to "Crop, Scale, and Position". Since I would never have found this solution without this bugreport.

(Maybe someone sets this bug to "confirmed"?)

I use:
 - kdenlive 0.9.2
 - kde 4.8.3
 - mlt 0.8.0

(0008220)
vpinon (administrator)
2012-08-24 13:42

git f5eccec (2012/08/24)

- Issue History
Date Modified Username Field Change
2011-07-12 20:52 eSyr New Issue
2011-07-12 20:52 eSyr File Added: kdenlive_crop_3.png
2011-07-12 21:16 eSyr File Added: kdenlive_crop_1.png
2011-08-10 15:47 ttill Note Added: 0007170
2011-08-10 17:37 ddennedy Note Added: 0007183
2012-07-18 19:31 PeterA Note Added: 0008164
2012-07-18 19:34 PeterA Note Edited: 0008164 View Revisions
2012-07-18 19:38 PeterA Note Edited: 0008164 View Revisions
2012-08-24 12:35 vpinon Assigned To => vpinon
2012-08-24 12:35 vpinon Status new => acknowledged
2012-08-24 13:42 vpinon Note Added: 0008220
2012-08-24 13:42 vpinon Status acknowledged => resolved
2012-08-24 13:42 vpinon Resolution open => fixed
2013-01-28 19:50 j-b-m Fixed in Version => 0.9.4
2013-01-28 19:50 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker