Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002275KdenliveEffectspublic2011-08-04 20:132011-11-01 18:56
Reportermoorsey 
Assigned Tottill 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.10
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002275: Speed effect does not work over 999
DescriptionIf the speed effect is raised over 999, then the clip in question reverts back to it's normal length on the timeline. Up to 999 works OK and as expected.

This is being done with 1920x1080 MTS clips, but have also tried with a few other random videos and the same happens
Steps To Reproduceput clip on timeline
apply speed effect with 1000+ speed
clips length will not be changed
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships

-  Notes
(0007142)
evorster (reporter)
2011-08-07 05:48

I can confirm this.

Also, it's difficult to slide the speed effect in small increments, so one spends an age with the scroll wheel. I would like to suggest a logarithmic slider for the speed effect.

I am using kdenlive 0.8.1 pulled from as a tarball, on the 4th Aug 2011.
The clips I am using is 1080p DNxHD 25fps.
(0007143)
ttill (developer)
2011-08-07 10:09

Yes it's a locale issue I'll have a look at.

@evorster: right click -> scaling -> non-linear scale. Then start dragging on the slider.
(0007144)
evorster (reporter)
2011-08-07 10:26

Hmm, my locale is either "C" or "en-za" or "en-us"
It really depends on who's asking. How does kdenlive determine the locale?

Anyways, thanks for the tip on the slider. I really love working with kdenlive.
(0007152)
ttill (developer)
2011-08-09 12:58

Should be fixed in r5824.
However this issue might still appear in other effects.

@jb: could you please have a look at it (since it is locale related).
The problem was that the speed 1000 was stored like this '1,000' (english locale). .toDouble() did not interpret this correctly...
I guess we have to replace every usage of .toDouble() and .toInt() related to EffectsList?
If you have a better idea let me know. If you want I can do it then.
(0007188)
moorsey (reporter)
2011-08-10 21:38

cool, thanks, appreciate you taking a look. Will check when I next update kdenlive
(0007233)
ttill (developer)
2011-08-28 21:12

@jb: in r5844 I did now address this in a more general approach for all effects by doing locale.setNumberOptions(QLocale::OmitGroupSeparator); in effectstackedit.
So if this problems occurs somewhere else we'll just have to add this line.

- Issue History
Date Modified Username Field Change
2011-08-04 20:13 moorsey New Issue
2011-08-06 16:36 ttill Assigned To => ttill
2011-08-06 16:36 ttill Status new => assigned
2011-08-07 05:48 evorster Note Added: 0007142
2011-08-07 10:09 ttill Note Added: 0007143
2011-08-07 10:26 evorster Note Added: 0007144
2011-08-09 12:58 ttill Note Added: 0007152
2011-08-10 21:38 moorsey Note Added: 0007188
2011-08-28 21:12 ttill Note Added: 0007233
2011-08-28 21:13 ttill Status assigned => resolved
2011-08-28 21:13 ttill Fixed in Version => 0.8.2
2011-08-28 21:13 ttill Resolution open => fixed
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker