Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000230KdenliveTranslationpublic2008-10-20 13:032010-11-19 22:00
Reportermtxd 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.4 
Summary0000230: Changing application language
DescriptionHow do I change the application language? "Help -> Switch app lang" is empty.
Tagsold
Build/Install Method(select)
Attached Files

- Relationships

-  Notes
(0000483)
administrator (administrator)
2008-10-20 19:18

How did you install Kdenlive ( wizard, source compilation,... ) ?
My guess is that you installed Kdenlive locally (e.g. in your home folder). That means the translation files cannot be found.

If you installed Kdenlive in $HOME/kdenlive, you should have a folder named:
$HOME/kdenlive/share/locale

In this folder, there are subfolders for each language. For example, the german translation file is:
$HOME/kdenlive/share/locale/de/LC_MESSAGES/kdenlive.mo

If you copy that file to:
/usr/share/locale/de/LC_MESSAGES

The corresponding translation should be available.

Please try and let me know.
(0000490)
madsdyd (administrator)
2008-10-20 21:43

I think this is a build issue too, but I just wanted to comment that I do install outside /usr/share, (my case: /scratch/KdenliveInstall/<date>/) and I do have all the translations available. (8 + English).

I am building with the wizard (obviously, have to eat my own dogfood).

I think I remember I had to do "something" to enable translations, but I think it was more of a "install some kde4 language pack" or something like that.
(0000538)
madsdyd (administrator)
2008-10-21 21:19

We need more feedback on this, in order to be able to acknowledge... :-(
(0000545)
mtxd (reporter)
2008-10-22 07:17

I installed using a well known 0000172 bug :)
Yes, I saw 7 languages in /opt/kdenlive/share/locale, but there are no localizations in the program itself. Seems like some hardcoded paths in the source.
(0000565)
madsdyd (administrator)
2008-10-22 14:03

Please try adminstrators advice/test, and let us know if that changes anything. You do not have to copy more than a single language to test it.
(0000571)
mtxd (reporter)
2008-10-22 15:58

>If you copy that file to:
>/usr/share/locale/de/LC_MESSAGES

>The corresponding translation should be available.

That doesn't help either.
(0000690)
madsdyd (administrator)
2008-10-25 14:47

Another user experience translations troubles with the Mandriva 2009 builds.

http://www.kdenlive.org/bbforum/viewtopic.php?f=6&t=635&start=0&st=0&sk=t&sd=a [^]
(0000783)
mtxd (reporter)
2008-10-31 08:51
edited on: 2008-10-31 08:52

I do not use packages, I compiled it using your script. The .mo files are in the right place, according to your post above.

(0001108)
mtxd (reporter)
2008-11-11 14:29

Was it fixed?
(0001109)
madsdyd (administrator)
2008-11-11 15:16

mtxd: I do not think this has been fixed, because I think noone yet has been able to figure out why this happens.

Do you have any other KDE4 programs, that supports language different from default?
(0001110)
mtxd (reporter)
2008-11-11 15:34

Hm... I use english by default. Can you give an example so I could check this?
(0001111)
madsdyd (administrator)
2008-11-11 15:52

Yes - say you can run kate as a KDE 4 program. Can you change the language of kate to any other language than your default?
(0001112)
mtxd (reporter)
2008-11-11 15:59

I cant find language changing option in Kate's settings.
(0001115)
cinephiliac (updater)
2008-11-11 19:53

You're right.Kate doesn't seem to have a language switching option.

Try opening Konqueror and choosing Help -> Switch Application Language
(0001130)
mtxd (reporter)
2008-11-12 07:12

The same as for kdenlive.
KDE 4.1.3
(0001132)
madsdyd (administrator)
2008-11-12 09:07

OK, I understand it so, that you are actually not able to change language for any kde 4 application. My guess is that you need to install some sort of language support package for kde 4. Please check you repos for it, perhaps your package provider has some additional advise.

And, please report back if you can figure out a solution!
(0001134)
mtxd (reporter)
2008-11-12 09:20

madsdyd, all dependencies are standard for kde4 package (debian). Moreover, I've got many .mo files for different laguages and different software in /usr/share/locale/

Do you know what package should I check?
(0001288)
madsdyd (administrator)
2008-11-20 17:57

Perhaps you need to configure something in kcontrol? Language support or something?

If both konqueror and kdenlive have the same problem, it would appear more KDE related than Kdenlive related, no?
(0002202)
madsdyd (administrator)
2009-01-25 21:51

No resolution for this issue yet, but I realized recently, that if you are using kdenlive_start to run kdenlive, since 22/11 2008, it will only start kdenlive in English...

This is a bug in the builder wizard, which will be fixed at some point. Just wanted to fess up to it here. :-(
(0005220)
Granjow (developer)
2010-05-28 17:44

Fixed in the meantime?
(0006084)
ttill (developer)
2010-11-19 22:00

Closing, lack of response.

- Issue History
Date Modified Username Field Change
2008-10-20 13:03 mtxd New Issue
2008-10-20 19:18 administrator Note Added: 0000483
2008-10-20 21:43 madsdyd Note Added: 0000490
2008-10-21 21:19 madsdyd Note Added: 0000538
2008-10-21 21:19 madsdyd Status new => feedback
2008-10-22 07:17 mtxd Note Added: 0000545
2008-10-22 14:03 madsdyd Note Added: 0000565
2008-10-22 15:55 mtxd Note Added: 0000570
2008-10-22 15:56 mtxd Note Deleted: 0000570
2008-10-22 15:58 mtxd Note Added: 0000571
2008-10-25 14:47 madsdyd Note Added: 0000690
2008-10-31 08:51 mtxd Note Added: 0000783
2008-10-31 08:52 mtxd Note Edited: 0000783
2008-11-11 14:29 mtxd Note Added: 0001108
2008-11-11 15:16 madsdyd Note Added: 0001109
2008-11-11 15:34 mtxd Note Added: 0001110
2008-11-11 15:52 madsdyd Note Added: 0001111
2008-11-11 15:59 mtxd Note Added: 0001112
2008-11-11 19:53 cinephiliac Note Added: 0001115
2008-11-12 07:12 mtxd Note Added: 0001130
2008-11-12 09:07 madsdyd Note Added: 0001132
2008-11-12 09:20 mtxd Note Added: 0001134
2008-11-20 17:57 madsdyd Note Added: 0001288
2009-01-25 21:51 madsdyd Note Added: 0002202
2010-05-28 17:44 Granjow Note Added: 0005220
2010-05-28 18:12 Granjow Tag Attached: old
2010-11-19 22:00 ttill Build/Install Method => (select)
2010-11-19 22:00 ttill Status feedback => resolved
2010-11-19 22:00 ttill Resolution open => unable to reproduce
2010-11-19 22:00 ttill Fixed in Version => 0.7.4
2010-11-19 22:00 ttill Note Added: 0006084
2010-11-19 22:00 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker