Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002304KdenliveRenderingpublic2011-09-08 13:372011-11-01 18:56
Reporterfabien26 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSUbuntuOS Version11.04
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002304: Disappearing tracks after rendering when using a title clip and some video effects combined
DescriptionThat's something strange I spotted a while ago, I finished my project and when I look at the final video I see that after a title clip everything BUT the "main track disappeared".

I tried to know why, and reproducing it and succeeded !
Steps To Reproduce- Mix two videos one on top of another
- use composite transition
- apply a "corners" effect on the track on top
- make a title clip
- drop the title clip on top of everything
- composite transition on the title clip targeting one of the two over tracks
- After rendering, everything is great, and after the title clip appear, the track with "corners effect" applied will disappear. And every over track with or without corners will never show up.
Additional InformationI've made a little .kdenlive project with color clips showing the configuration needed to trigger this bug.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files? file icon TitleClipMakeTracksDisappear.kdenlive [^] (12,637 bytes) 2011-09-08 13:37

- Relationships

-  Notes
(0007285)
j-b-m (administrator)
2011-09-08 15:13

Oh, thanks a lot for the sample project file.

I could reproduce, and that is a locale issue in the MLT kdenlivetitle producer, so the bug only appears on non english locale. I am working on it.

I think that some bugs reported on the forum (disappearing transitions when using an image in a title clip) are also related to that problem.

(0007286)
j-b-m (administrator)
2011-09-08 15:42

Patch pending on MLT's mailing list:
http://sourceforge.net/mailarchive/forum.php?thread_name=5485724.zoQj8LVuPP%40two&forum_name=mlt-devel [^]
(0007287)
fabien26 (reporter)
2011-09-08 17:02

Thanks ! I use the stable release of MLT because I have another bug with 0.7.5. But I will try it as soon as possible !
(0007291)
fabien26 (reporter)
2011-09-09 10:10

I have tested with the patch, it's better, but not resolved yet.

The tracks are not disappearing after the title clip this time, but before !

The same with a newly created project or with the project I've send before.
(0007292)
j-b-m (administrator)
2011-09-09 11:55

A slightly improved version of the patch was committed to MLT, please test latest git.

I also see the track disappearing because of the "corner" effect, but this issue should only happen when you try to play a project created in a different locale.

To explain a little bit, here is the problem:

When using a french locale (as done in your project), your system uses a comma ',' as numeric separator, but when using an english locale, the system uses a dot '.'.

It means that the corner parameters looks like that on a french system:

<property name="Corner 1 X">0=0,333333</property>

When trying to open the project on a system with english locale, the '0,333333' property will not be recognized as a number and will be translated as 0 - which then causes the "black track" problem you are describing.

In my tests, this issue only happens when trying to play a project that uses a locale different from the system's locale.

The project locale can be seen in the .kdenlive file, on the second line of your attached project file you can see: LC_NUMERIC="fr_FR.UTF-8" which means it was created using a french locale.

Now the question is: which locale has the system you are using to play the project file? can you please paste the output of (in a terminal):

locale

I need to make sure that this problem only happens in the case of project locale != system locale, then I will try to patch it.
(0007293)
fabien26 (reporter)
2011-09-09 13:19

I'am already on the latest git (and I checked).

Locale report me:

LANG=fr_FR.UTF-8
LANGUAGE=
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

I'm worried about the: LANGUAGE= 'nothing' but this system seems to work great.

I tried to launch kdenlive with LANGUAGE=fr_FR:en and LANGUAGE=fr_FR but the problem remain the same on this computer.

I will try on another computer that have LANGUAGE=fr_FR:en by default.
(0007294)
j-b-m (administrator)
2011-09-09 13:34

I just committed a fix to Kdenlive so that rendering should work, but I don't understand why it doesn't work for you. I have changed my system's locale to french, I have exactly the same locale output as you and everything works.

Just to make sure, can you test in a terminal:

melt colour:red -attach brightness:0.5

and

melt colour:red -attach brightness:0,5

One of them will give you a black output and the other one a brown output. Which one is the black one (should be first one with your french locale)?
(0007295)
fabien26 (reporter)
2011-09-09 13:55

For some unknown reason the black one is the second ...

But on the over computer it behave like it should (with mlt 0.7.4). I think I should reinstall my test computer with a clean system ...

The last commit in kdenlive doesn't seem to workaround the problem with this silly system.

I will try if it works with the over computer.

By the way, thank you very much !
(0007296)
fabien26 (reporter)
2011-09-09 14:03

It's working great in the over computer, so no problem, bug resolved (except some weird cases)!

- Issue History
Date Modified Username Field Change
2011-09-08 13:37 fabien26 New Issue
2011-09-08 13:37 fabien26 File Added: TitleClipMakeTracksDisappear.kdenlive
2011-09-08 15:13 j-b-m Note Added: 0007285
2011-09-08 15:13 j-b-m Assigned To => j-b-m
2011-09-08 15:13 j-b-m Status new => acknowledged
2011-09-08 15:42 j-b-m Note Added: 0007286
2011-09-08 17:02 fabien26 Note Added: 0007287
2011-09-09 10:10 fabien26 Note Added: 0007291
2011-09-09 11:55 j-b-m Note Added: 0007292
2011-09-09 13:19 fabien26 Note Added: 0007293
2011-09-09 13:34 j-b-m Note Added: 0007294
2011-09-09 13:55 fabien26 Note Added: 0007295
2011-09-09 14:03 fabien26 Note Added: 0007296
2011-09-09 20:01 j-b-m Status acknowledged => resolved
2011-09-09 20:01 j-b-m Fixed in Version => 0.8.2
2011-09-09 20:01 j-b-m Resolution open => fixed
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker