Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002318KdenliveRenderingpublic2011-09-18 01:572011-11-01 18:56
Reportercolesen 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intelOSFedoraOS Version15
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002318: no audio on playback of rendering in some formats
Descriptiontried playback of a clip rendered in all the formats offered by kdenlive with the following result:
MPEG-2: ok except no audio
MPEG-4: ok
XVid4: ok except no video
H.264: ok except no audio
Flash: ok except bad aspect ratio
RealVideo: ok except no video
Theora: ok
WebM: ok except no audio
Steps To Reproduce1. get a hold of a clip (I used the m2t file saved by Kaffeine recording TV)
2. run kdenlive
3. add the clip in kdenlive
4. ensure presence of audio in the clip by playback in the Clip Monitor of kdenlive
5. drag the clip to the timeline in kdenlive
6. render the clip in the formats offered by kdenlive (I used quality 2000k)
7. verify playback of the rendered clips in the Clip Monitor of kdenlive
Additional Informationthe version of kdenlive used was downloaded and built today using the script offered on
http://www.mltframework.org/twiki/bin/view/MLT/BuildScripts [^] -> "show Kdenlive" -> "Run the script"

The build-script exited with error until I made the following change to it

# REPOLOCS[5]="git://review.webmproject.org/libvpx.git" [^]
  REPOLOCS[5]="http://git.chromium.org/webm/libvpx.git" [^]

see "Changed URLs" on http://www.webmproject.org/code/ [^]

if another version of kdenlive has been run then first rename or delete
~/.kde/share/apps/kdenlive
~/.kde/share/config/kdenliverc
to ensure a clean slate
TagsNo tags attached.
Build/Install MethodOther Method?
Attached Files

- Relationships

-  Notes
(0007336)
colesen (reporter)
2011-09-20 00:52

the problem of no audio of renderings in H.264 is the most important (at least to me) and perhaps the following observations are helpful in finding a resolution

renderings in "H.264 200k" and "H.264 400k" i.e. the 2 lowest bitrates do not exhibit the problem whereas those in "H.264 600k" and above do and that whether performed by clicking "Render to File" or running the script generated by clicking "Generate Script".
Also, renderings by running the script do not exhibit the problem if the bitrate specification e.g. "b=2000k" is removed in the script in which case a default applies I assume with a value around 1000k judging from comparing output file sizes.

for comparison, renderings by running the following command e.g.
ffmpeg -i infile -acodec aac -vcodec libx264 -b 2000k -strict experimental outfile
do not exhibit the problem irrespective of the value of the bitrate "-b".
(without the "-strict experimental" argument which applies to the audio the command won't run)
(0007337)
j-b-m (administrator)
2011-09-20 12:04

I can confirm the issue, I was unable to get audio on any MPEG-2 profile. After some tests, the problem seems to be in the way FFmpeg handles arguments order.

With my FFmpeg version (recent git), if I do:

ffmpeg -i test.mts -b 2000k test.mpg

It fails, the reason being that it sets both video AND audio bitrate to 2000k. It seems an FFmpeg bug in my opinion (at least from the documentation it should only set video bitrate).

In the same way, doing:

ffmpeg -i test.mts -ab 384k -b 2000k test.mpg

Fails, because audio bitrate is set to 2000k.

The solution is to put the audio bitrate argument after the global bitrate:

ffmpeg -i test.mts -b 2000k -ab 384k test.mpg

We could change our profiles to change that order, but I want to check first if this was solved in current FFmpeg git...


(0007338)
j-b-m (administrator)
2011-09-20 12:38

I opened an issue on FFmpeg's bug tracker:
https://ffmpeg.org/trac/ffmpeg/ticket/491 [^]
(0007339)
j-b-m (administrator)
2011-09-21 09:32

Should be fixed in svn commit 5919, but you also need the latest MLT from git. We changed the export profiles to use "vb" instead of "b" to set the video bitrate. Please test.
(0007340)
colesen (reporter)
2011-09-21 11:47

I just tested the version build by running the script i.e.
http://www.mltframework.org/twiki/pub/MLT/BuildScripts/build-kdenlive.sh [^]
and the problem is not fixed in that version

Also I made the following change to the build script
# REPOLOCS[5]="git://review.webmproject.org/libvpx.git" [^] [^]
   REPOLOCS[5]="http://git.chromium.org/webm/libvpx.git" [^] [^]
as I also did and mentioned initially
(0007341)
j-b-m (administrator)
2011-09-21 18:41

I double checked and it works correctly for me. If you have created render scripts, those will not be fixed but for new renderings, it should work. One thig you must check when using Kdenlive build with the build script is that you use the correct version of melt for rendering.

Go in Kdenlive settings, and in the environment tab, make sure that the "Melt" path (and profiles) point to the latest build version.

Also make sure Kdenlive is using the latest render profiles, for example the mpeg 2 profile should show:

f=mpeg acodec=mp2 ab=384k ar=48000 vcodec=mpeg2video minrate=0 vb=%bitrate+'k' bf=2 b_strategy=1 trellis=1 aspect=%dar pass=%passes

(it must be "vb=" before the %bitrate argument).
(0007342)
colesen (reporter)
2011-09-21 20:28

the problem was that the version of kdenlive built in my home dir by the script was picking up the config out under /usr/share/ for the rpm installed version because after I removed the rpm installed version then the problem vanished.

but shouldn't the built version look in its own config before that under /usr/share?

also, will the gui be updated with an option to adjust the audio bitrate? (it defaults to 384k in scripts)

also, will the changed URL be fixed in the build script?
(0007343)
j-b-m (administrator)
2011-09-21 23:39

I just made the audio bitrate selectable in svn rev. 5920, please test if you can. Yes, the build script could be improved, but we don't have a lot of people working on Kdenlive / MLT and we have more important stuff to do...

About the webm repository, Dan did put a note about this issue at:
http://www.mltframework.org/twiki/bin/view/MLT/BuildScripts [^]
(0007344)
colesen (reporter)
2011-09-22 01:45

I tested and it works
but I'd change the "Bitrate" label to "Video" for clarity and symmetry with the "Audio" label
(0007348)
j-b-m (administrator)
2011-09-22 20:28

Layout of render widget improved as proposed by reporter in svn rev. 5921

- Issue History
Date Modified Username Field Change
2011-09-18 01:57 colesen New Issue
2011-09-20 00:52 colesen Note Added: 0007336
2011-09-20 12:04 j-b-m Note Added: 0007337
2011-09-20 12:04 j-b-m Assigned To => j-b-m
2011-09-20 12:04 j-b-m Status new => acknowledged
2011-09-20 12:38 j-b-m Note Added: 0007338
2011-09-21 09:32 j-b-m Note Added: 0007339
2011-09-21 09:32 j-b-m Status acknowledged => feedback
2011-09-21 11:47 colesen Note Added: 0007340
2011-09-21 11:47 colesen Status feedback => assigned
2011-09-21 18:41 j-b-m Note Added: 0007341
2011-09-21 20:28 colesen Note Added: 0007342
2011-09-21 23:39 j-b-m Note Added: 0007343
2011-09-22 01:45 colesen Note Added: 0007344
2011-09-22 20:28 j-b-m Note Added: 0007348
2011-09-22 20:28 j-b-m Status assigned => resolved
2011-09-22 20:28 j-b-m Fixed in Version => 0.8.2
2011-09-22 20:28 j-b-m Resolution open => fixed
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker