Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002352KdenliveFile Loadingpublic2011-10-14 06:492011-11-01 18:56
Reportermschwinne 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformIntel 64bitOSOpensuseOS Version11.4
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002352: Crash when loading project file
DescriptionWhen I load the project file (created with 0.8.1 (rev. 5915)) I first get a warning about duration mismatch and missing clips. If I select fix duration mismatch and use place holder for missing clips all warnings are gone. The next dialog says that a backup file is created. Than kdenlive crashes.
I don't understand the warning about missing clips as all files are available. melt project.kdenlive plays the whole project without problem.

If I create a new project, add some clips and save it I'm able to load it again into kdenlive.

Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb7edcb57a0 (LWP 10298))]

Thread 4 (Thread 0x7fb7c8b87700 (LWP 10303)):
#0 0x00007fb7eb4066f9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1 0x00007fb7ed8ebae0 in mlt_consumer_get_frame (self=0x1110320) at mlt_consumer.c:536
0000002 0x00007fb7ed8ec37e in mlt_consumer_rt_frame (self=0x1110320) at mlt_consumer.c:1329
0000003 0x00007fb7d7c8ecf0 in consumer_thread (arg=0x1110320) at consumer_sdl_still.c:570
0000004 0x00007fb7e95c79e3 in ?? () from /usr/X11R6/lib64/libGL.so.1
0000005 0x00007fb7eb401a3f in start_thread () from /lib64/libpthread.so.0
0000006 0x00007fb7e6f5166d in clone () from /lib64/libc.so.6
0000007 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fb7c8386700 (LWP 10304)):
#0 0x00007fb7eb40638c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1 0x00007fb7d7c8e551 in consumer_thread (arg=0x13186f0) at consumer_sdl_preview.c:449
0000002 0x00007fb7e95c79e3 in ?? () from /usr/X11R6/lib64/libGL.so.1
0000003 0x00007fb7eb401a3f in start_thread () from /lib64/libpthread.so.0
0000004 0x00007fb7e6f5166d in clone () from /lib64/libc.so.6
0000005 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb7c60cb700 (LWP 10305)):
#0 0x00007fb7e6f484f3 in poll () from /lib64/libc.so.6
#1 0x00007fb7e6354114 in ?? () from /lib64/libglib-2.0.so.0
0000002 0x00007fb7e6354650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
0000003 0x00007fb7ecb70636 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
0000004 0x00007fb7ecb44c22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
0000005 0x00007fb7ecb44e35 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
0000006 0x00007fb7eca59be4 in QThread::exec() () from /usr/lib64/libQtCore.so.4
0000007 0x00007fb7ecb26358 in ?? () from /usr/lib64/libQtCore.so.4
0000008 0x00007fb7eca5c4d5 in ?? () from /usr/lib64/libQtCore.so.4
0000009 0x00007fb7e95c79e3 in ?? () from /usr/X11R6/lib64/libGL.so.1
0000010 0x00007fb7eb401a3f in start_thread () from /lib64/libpthread.so.0
0000011 0x00007fb7e6f5166d in clone () from /lib64/libc.so.6
0000012 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb7edcb57a0 (LWP 10298)):
[KCrash Handler]
0000006 mlt_properties_find (self=0x0, name=0x7fb7ca1aae23 "hide") at mlt_properties.c:484
0000007 mlt_properties_fetch (self=0x0, name=0x7fb7ca1aae23 "hide") at mlt_properties.c:560
0000008 0x00007fb7ed8e426c in mlt_properties_set_int (self=0x0, name=0x7fb7ca1aae23 "hide", value=1) at mlt_properties.c:892
0000009 0x00007fb7ca1a8d36 in on_end_track (ctx=<value optimized out>, name=<value optimized out>) at producer_xml.c:878
0000010 on_end_element (ctx=<value optimized out>, name=<value optimized out>) at producer_xml.c:1263
0000011 0x00007fb7e0023930 in xmlParseElement () from /usr/lib64/libxml2.so.2
0000012 0x00007fb7e002251a in xmlParseContent () from /usr/lib64/libxml2.so.2
0000013 0x00007fb7e0023663 in xmlParseElement () from /usr/lib64/libxml2.so.2
0000014 0x00007fb7e002251a in xmlParseContent () from /usr/lib64/libxml2.so.2
0000015 0x00007fb7e0023663 in xmlParseElement () from /usr/lib64/libxml2.so.2
0000016 0x00007fb7e002466a in xmlParseDocument () from /usr/lib64/libxml2.so.2
0000017 0x00007fb7ca1aa6f7 in producer_xml_init (profile=<value optimized out>, servtype=<value optimized out>, id=<value optimized out>, data=0x286b848 "<?xml version='1.0' encoding='utf-8'?>\n<mlt modified=\"1\" title=\"Anonymous Submission\" root=\"/home/michael\" LC_NUMERIC=\"C\">\n <playlist id=\"playlist1\"/>\n <playlist id=\"playlist3\">\n <blank length=\"602\"/"...) at producer_xml.c:1609
0000018 0x00007fb7ed8ef952 in mlt_factory_producer (profile=0x12df440, service=0x73260e "xml-string", input=0x286b848) at mlt_factory.c:287
0000019 0x00007fb7ed6c8158 in Mlt::Producer::Producer(Mlt::Profile&, char const*, char const*) () from /usr/lib64/libmlt++.so.3
0000020 0x00000000004ca64c in Render::setSceneList (this=0x1340c10, playlist=..., position=17283) at /home/michael/Downloads/kdenlive/src/renderer.cpp:1037
0000021 0x00000000004dd524 in KdenliveDoc::setSceneList (this=0x18eb850) at /home/michael/Downloads/kdenlive/src/kdenlivedoc.cpp:352
0000022 0x00000000004f825a in TrackView::TrackView (this=0x17481a0, doc=<value optimized out>, ok=0x7fff735ec22e, parent=<value optimized out>) at /home/michael/Downloads/kdenlive/src/trackview.cpp:111
0000023 0x000000000047b782 in MainWindow::doOpenFile (this=0xb20800, url=..., stale=<value optimized out>) at /home/michael/Downloads/kdenlive/src/mainwindow.cpp:2063
0000024 0x000000000047e037 in MainWindow::openFile (this=0xb20800, url=...) at /home/michael/Downloads/kdenlive/src/mainwindow.cpp:2018
0000025 0x000000000047e335 in MainWindow::openFile (this=0xb20800) at /home/michael/Downloads/kdenlive/src/mainwindow.cpp:1950
0000026 0x00000000004800aa in MainWindow::qt_metacall (this=0xb20800, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0x7fff735ec8f0) at /home/michael/Downloads/kdenlive/build/src/cmake_bindir/mainwindow.moc:399
0000027 0x00007fb7ecb59e8f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
0000028 0x00007fb7e7d81ed2 in QAction::triggered(bool) () from /usr/lib64/libQtGui.so.4
0000029 0x00007fb7e7d820ca in QAction::activate(QAction::ActionEvent) () from /usr/lib64/libQtGui.so.4
0000030 0x00007fb7e814097a in ?? () from /usr/lib64/libQtGui.so.4
0000031 0x00007fb7e8140c2c in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib64/libQtGui.so.4
0000032 0x00007fb7e81fd16a in QToolButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib64/libQtGui.so.4
0000033 0x00007fb7e7dd9e1c in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
0000034 0x00007fb7e7d88264 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000035 0x00007fb7e7d9109c in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000036 0x00007fb7ec5b2ae6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
0000037 0x00007fb7ecb457cc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
0000038 0x00007fb7e7d89275 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/libQtGui.so.4
0000039 0x00007fb7e7e07f08 in ?? () from /usr/lib64/libQtGui.so.4
0000040 0x00007fb7e7e065c9 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
0000041 0x00007fb7e7e2e6f2 in ?? () from /usr/lib64/libQtGui.so.4
0000042 0x00007fb7e6353bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
0000043 0x00007fb7e63543b0 in ?? () from /lib64/libglib-2.0.so.0
0000044 0x00007fb7e6354650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
0000045 0x00007fb7ecb705df in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
0000046 0x00007fb7e7e2e38e in ?? () from /usr/lib64/libQtGui.so.4
0000047 0x00007fb7ecb44c22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
0000048 0x00007fb7ecb44e35 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
0000049 0x00007fb7ecb4927b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
0000050 0x000000000045e736 in main (argc=1, argv=0x7fff735ee5f8) at /home/michael/Downloads/kdenlive/src/main.cpp:89

Additional InformationQt: 4.7.4
KDE: 4.7.2 (4.7.2)
Kdenlive: 0.8.1 (rev. 5951)
MLT melt 0.7.5 (latest repository)
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files? file icon project.kdenlive [^] (240,520 bytes) 2011-10-14 06:49
? file icon project_fixed.kdenlive [^] (240,546 bytes) 2011-10-14 18:06

- Relationships

-  Notes
(0007436)
j-b-m (administrator)
2011-10-14 18:12

Hmm, the crash should be fixed in the slightly modified version of your project that I just uploaded (project_fixed.kdenlive).

What happened is probably that you used latest Kdenlive for some time without upgrading MLT and the project file used some upgrades made in Kdenlive without the ones in MLT which produced a small problem, or maybe the other way ...

The crash happens because of a recent change in MLT/Kdenlive to correctly use the system's locale (language). You seem to have a german (de_DE.UTF-8) encoding on your system, which uses a comma ',' in numbers and not a dot '.' like in english locale. The project file did not have the correct tag to declare this, and Kdenlive tried to treat it like an english locale document...

Please try my attached version and let me know if everything is fixed.

(0007437)
mschwinne (reporter)
2011-10-15 00:09

Thanks a lot! I'm able to load the modified project file without problem into kdenlive :-)

- Issue History
Date Modified Username Field Change
2011-10-14 06:49 mschwinne New Issue
2011-10-14 06:49 mschwinne File Added: project.kdenlive
2011-10-14 18:06 j-b-m File Added: project_fixed.kdenlive
2011-10-14 18:12 j-b-m Note Added: 0007436
2011-10-14 18:12 j-b-m Assigned To => j-b-m
2011-10-14 18:12 j-b-m Status new => feedback
2011-10-15 00:09 mschwinne Note Added: 0007437
2011-10-15 00:09 mschwinne Status feedback => assigned
2011-10-15 12:27 j-b-m Status assigned => resolved
2011-10-15 12:27 j-b-m Fixed in Version => 0.8.2
2011-10-15 12:27 j-b-m Resolution open => fixed
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker