Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002381KdenliveUser Interfacepublic2011-11-03 18:422011-12-09 16:27
ReporterDavid Jordan 
Assigned Toj-b-m 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionduplicate 
Platform64 bitOSUbuntuOS Version10.10
Product Version0.8.2 
Target Version0.8.2.1Fixed in Version0.8.2.1 
Summary0002381: Kdenlive Crashes on start up
DescriptionI recently upgraded to Kdenlive 0.8.2. Now Kdenlive crashes or hangs at start up. I uninstalled and reinstalled using the recommended sunab repository and deleted user settings file kdenliverc, issue remains.
Steps To ReproduceTrying to start Kdenlive.
Additional Informationno more csLADSPA plugins
no more csLADSPA plugins
project monitor connected
clip monitor connected
detected format: YUV 4:2:2 (YUYV): YUYV
Size: 640x480: 1/30, 1/20, 1/15, 1/10, 1/5, 1/1,
Size: 320x240: 1/30, 1/20, 1/15, 1/10, 1589/15625, 1/1,
Size: 160x120: 1/30, 1/20, 1/15, 1/10, 1589/15625, 1/1,
Size: 176x144: 1/30, 1/20, 1/15, 1/10, 1589/15625, 1/1,
Size: 352x288: 1/30, 1/20, 1/15, 1/10, 1589/15625, 1/1,
Size: 800x600: 1/30, 1/20, 1/15, 1/10, 1589/15625, 1/1,
Size: 1024x960: 1/30, 1/20, 1/15, 1/10, 1589/15625, 1/1,
Size: 1280x1024: 1/9, 1/5, 1/1,
detected format: MJPEG: MJPG
Size: 640x480: 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30 etc.

Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f42a64077a0 (LWP 6408))]

Thread 2 (Thread 0x7f4295458700 (LWP 6409)):
#0 0x00007f42a0442203 in poll () from /lib/libc.so.6
#1 0x00007f429f55e009 in ?? () from /lib/libglib-2.0.so.0
0000002 0x00007f429f55e7b5 in g_main_loop_run () from /lib/libglib-2.0.so.0
0000003 0x00007f4295b8f3c4 in ?? () from /usr/lib/libgio-2.0.so.0
0000004 0x00007f429f5837e4 in ?? () from /lib/libglib-2.0.so.0
0000005 0x00007f42a2b24953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
0000006 0x00007f42a3ee2971 in start_thread () from /lib/libpthread.so.0
0000007 0x00007f42a044e92d in clone () from /lib/libc.so.6
0000008 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f42a64077a0 (LWP 6408)):
[KCrash Handler]
0000006 0x00007f42a03e9309 in strcat () from /lib/libc.so.6
0000007 0x000000000078b1e7 in snprintf (src=<value optimized out>, pixelformatdescription=0x7fffd8ce1a78) at /usr/include/bits/string3.h:146
0000008 query_v4ldevice (src=<value optimized out>, pixelformatdescription=0x7fffd8ce1a78) at /build/buildd/kdenlive-0.8.2/src/v4l/src.c:134
0000009 0x000000000078adde in V4lCaptureHandler::getDeviceName (input=) at /build/buildd/kdenlive-0.8.2/src/v4l/v4lcapture.cpp:67
0000010 0x00000000006b8419 in Wizard::slotDetectWebcam (this=0x27504a0) at /build/buildd/kdenlive-0.8.2/src/wizard.cpp:169
0000011 0x00000000006bbec7 in Wizard::Wizard (this=0x27504a0, upgrade=<value optimized out>, parent=<value optimized out>) at /build/buildd/kdenlive-0.8.2/src/wizard.cpp:155
0000012 0x00000000004680e1 in MainWindow::readOptions (this=0x17b5b70) at /build/buildd/kdenlive-0.8.2/src/mainwindow.cpp:1784
0000013 0x000000000047a571 in MainWindow::MainWindow (this=0x17b5b70, MltPath=<value optimized out>, Url=<value optimized out>, clipsToLoad=<value optimized out>, parent=<value optimized out>, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /build/buildd/kdenlive-0.8.2/src/mainwindow.cpp:407
0000014 0x000000000045a66a in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/kdenlive-0.8.2/src/main.cpp:84
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships
duplicate of 0002376closedj-b-m Crashes on launch 
related to 0002434feedbackj-b-m Try to launch program and it crashes. 

-  Notes
(0007496)
j-b-m (administrator)
2011-11-03 19:59

Thanks for your report, and I can confirm the crash.

Happens because your webcam returns some unexpected data... and Kdenlive does not correctly check the validity. I have a patch ready to fix the crash, will probably make a 0.8.2.1 release in 7-10 days to fix a few annoying issues uncovered after the 0.8.2 release.

- Issue History
Date Modified Username Field Change
2011-11-03 18:42 David Jordan New Issue
2011-11-03 19:59 j-b-m Note Added: 0007496
2011-11-03 19:59 j-b-m Assigned To => j-b-m
2011-11-03 19:59 j-b-m Status new => acknowledged
2011-11-03 21:01 j-b-m Target Version => 0.8.2.1
2011-11-05 17:42 j-b-m Target Version 0.8.2.1 => 0.8.4
2011-11-14 19:16 j-b-m Target Version 0.8.4 => 0.8.2.1
2011-11-20 10:08 j-b-m Relationship added duplicate of 0002376
2011-11-20 10:08 j-b-m Status acknowledged => resolved
2011-11-20 10:08 j-b-m Fixed in Version => 0.8.2.1
2011-11-20 10:08 j-b-m Resolution open => duplicate
2011-12-08 22:51 j-b-m Status resolved => closed
2011-12-09 16:27 j-b-m Relationship added related to 0002434


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker