Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002402KdenliveRenderingpublic2011-11-11 15:572011-12-08 22:51
Reportercolesen 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformi386OSFedora LinuxOS Version16
Product VersionRecent git 
Target VersionFixed in Version0.8.2.1 
Summary0002402: xvid as render format not available
DescriptionThe render popup says at the bottom
"Unsupported video codec: libxvid"
when selecting XVid4 in its list of formats
Steps To Reproduce1. build a fresh pull of kdenlive using the build script
(subdir kdenlive is nolonger automatically pulled by the script so I pulled it manually using
git clone git://anongit.kde.org/kdenlive.git [^])
2. delete/rename old personal kdenlive config
kde/share/apps/kdenlive
kde/share/config/kdenliverc
3. run the just built kdenlive
4. load a clip to render
5. click render
6. select XVid4 in the popup
7. observe message at the bottom of the render popup "Unsupported video codec: libxvid"
Additional Informationmy system is the just released Fedora 16 fully up to date

all checks by kdenlive during its first run are all check marked in blue

xvid is installed as shown by
ls -l /usr/lib/*xvid*
lrwxrwxrwx. 1 root root 18 Nov 6 21:17 /usr/lib/libxvidcore.so.4 -> libxvidcore.so.4.3
-rwxr-xr-x. 1 root root 737764 Jun 12 22:02 /usr/lib/libxvidcore.so.4.3

start-kdenlive lists the following video codecs
video_codecs:
  - a64multi
  - a64multi5
  - amv
  - asv1
  - asv2
  - bmp
  - dnxhd
  - dpx
  - dvvideo
  - ffv1
  - ffvhuff
  - flashsv
  - flashsv2
  - flv
  - gif
  - h261
  - h263
  - h263p
  - huffyuv
  - j2k
  - jpegls
  - ljpeg
  - mjpeg
  - mpeg1video
  - mpeg2video
  - mpeg4
  - msmpeg4v2
  - msmpeg4
  - msvideo1
  - pam
  - pbm
  - pcx
  - pgm
  - pgmyuv
  - png
  - ppm
  - prores
  - qtrle
  - rawvideo
  - roqvideo
  - rv10
  - rv20
  - sgi
  - snow
  - svq1
  - targa
  - tiff
  - v210
  - wmv1
  - wmv2
  - zlib
  - zmbv
  - libtheora
  - libvpx
  - libx264
...
TagsNo tags attached.
Build/Install MethodOther Method?
Attached Files

- Relationships

-  Notes
(0007546)
evorster (reporter)
2011-11-12 06:15

Which version of ffmpeg are you running? Did you recently upgrade ffmpeg?

I saw something similar, and I suspect it's ffmpeg 0.7.6 that is not exporting it's capabilities. This problem went away for me when I downgraded to 0.7.6
(0007561)
colesen (reporter)
2011-11-13 15:45

The command

ffmpeg -codecs | grep xvid

outputs

ffmpeg version 0.8.5, Copyright (c) 2000-2011 the FFmpeg developers
  built on Oct 27 2011 21:33:51 with gcc 4.6.1 20111003 (Red Hat 4.6.1-10)
  configuration: --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib --mandir=/usr/share/man --arch=i686 --extra-cflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables' --enable-bzlib --enable-libcelt --enable-libdc1394 --enable-libdirac --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-x11grab --enable-avfilter --enable-postproc --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-stripping --shlibdir=/usr/lib --cpu=i686 --enable-runtime-cpudetect
  libavutil 51. 9. 1 / 51. 9. 1
  libavcodec 53. 7. 0 / 53. 7. 0
  libavformat 53. 4. 0 / 53. 4. 0
  libavdevice 53. 1. 1 / 53. 1. 1
  libavfilter 2. 23. 0 / 2. 23. 0
  libswscale 2. 0. 0 / 2. 0. 0
  libpostproc 51. 2. 0 / 51. 2. 0
  EV libxvid libxvidcore MPEG-4 part 2
...

of which the first line shows the version as 0.8.5 and the last line shows xvid as available to ffmpeg.
(0007572)
j-b-m (administrator)
2011-11-14 15:54

I updated the build script to now use Kdenlive's git repository, so you might want to download the new version at:

http://www.mltframework.org/twiki/bin/view/MLT/BuildScripts [^]

However, the build script does not enable libxvid in FFmpeg. you might want to edit the build script, and at line 0000114:0000434, you will see the default ffmpeg compile flags:

CONFIG[0]="./configure --prefix=$FINAL_INSTALL_DIR --disable-doc (...)"

Add "--enable-libxvid" to the list of options and you should get libxvid support.
(0007573)
colesen (reporter)
2011-11-14 17:50

Run of the build script freshly pulled outputs as the last line the following

LOG: Process has finished. Reason: FAILURE Some kind of error occured: Unable to change to directory lame

Seeing "lame-3.99.1" but not "lame" in kdenlive/src dir I guessed the reason to a simple naming issue and as attempt of workaround I added the link
ln -s lame-3.99.1 lame
in that dir and rerun of the build script then as the last lines outputs

...cut...cut...cut...cut...cut...cut...cut...cut...cut...cut...
LOG: About to run command: rm -f CMakeCache.txt
LOG: About to run command: cmake -DCMAKE_INSTALL_PREFIX=/home/colesen/kdenlive/20111114 -DCMAKE_BUILD_TYPE=debugfull
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/lib/ccache/gcc
-- Check for working C compiler: /usr/lib/ccache/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/lib/ccache/c++
-- Check for working CXX compiler: /usr/lib/ccache/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Found Git: /usr/bin/git
Current Kdenlive Git revision is fatal: No tags can describe '79a58d4bd2faf4d6ee6576acc70219e95efb2865'.
Try --always, or create some tags.
-- Looking for include files HAVE_MALLOC_H
...cut...cut...cut...cut...cut...cut...cut...cut...cut...cut...
LOG: Building kdenlive - this could take some time
LOG: About to run command: make -j3
CMake Error: Parse error in cache file /home/colesen/kdenlive/src/kdenlive/CMakeCache.txt. Offending entry: Try --always, or create some tags.)"()]
CMake Error: Parse error in cache file /home/colesen/kdenlive/src/kdenlive/CMakeCache.txt. Offending entry: Try --always, or create some tags.)"()]
CMake Error: Parse error in cache file /home/colesen/kdenlive/src/kdenlive/CMakeCache.txt. Offending entry: Try --always, or create some tags.)"()]
CMake Error: Parse error in cache file /home/colesen/kdenlive/src/kdenlive/CMakeCache.txt. Offending entry: Try --always, or create some tags.)"()]
CMake Error: Parse error in cache file /home/colesen/kdenlive/src/kdenlive/CMakeCache.txt. Offending entry: Try --always, or create some tags.)"()]
Current Kdenlive Git revision is fatal: No tags can describe '79a58d4bd2faf4d6ee6576acc70219e95efb2865'.
Try --always, or create some tags.
-- Found Qt-Version 4.8.0 (using /usr/bin/qmake-qt4)
...cut...cut...cut...cut...cut...cut...cut...cut...cut...cut...
-- Configuring incomplete, errors occurred!
make: *** [cmake_check_build_system] Error 1
ERROR: Unable to build kdenlive
LOG: Process has finished. Reason: FAILURE Some kind of error occured: Unable to build kdenlive
(0007574)
j-b-m (administrator)
2011-11-14 17:58

Thanks, I am aware of these issues currently working on it.
(0007575)
j-b-m (administrator)
2011-11-14 18:19

Fixed in Kdenlive's git now. The lame error was caused by me forgetting to update one of the build script variable, you can manually edit it, and at line ~ 406, change the lame version to look like that:

  REVISIONS[7]="lame-3.99.1"

I sent an updated version of the script to Dan, so the version of the script on mltframework.org should be updated in a few hours.

regards
(0007577)
colesen (reporter)
2011-11-14 21:06

Run of the build script downloaded just now completes successfully without making any modifications.
 
Rerunning it after making the following change to it

FFMPEG_SUPPORT_XVID=0 -> 1

outputs

...cut...cut...cut...cut...cut...cut...cut...cut...cut...cut...
LOG: Configuring ffmpeg
LOG: About to run command: ./configure --prefix=/home/colesen/kdenlive/20111114 --disable-doc --disable-network --disable-ffserver --enable-gpl --enable-version3 --enable-shared --enable-debug --disable-stripping --enable-pthreads --enable-runtime-cpudetect --enable-libtheora --enable-libvorbis --enable-libxvid --enable-libmp3lame --enable-libx264 --enable-libvpx
ERROR: libxvid not found
...cut...cut...cut...cut...cut...cut...cut...cut...cut...cut...
ERROR: Unable to configure ffmpeg
LOG: Process has finished. Reason: FAILURE Some kind of error occured: Unable to configure ffmpeg

The name of the xvid so file is
/usr/lib/libxvidcore.so.4 -> libxvidcore.so.4.3
and thinking that it is not found perhaps because the name is not
libxvid.so
I symlinked
that name and reran the build script but it made no difference.
(0007578)
j-b-m (administrator)
2011-11-14 21:10

Have you installed the libxvidcore-dev package? It is required to compile ffmpeg with xvid support...
(0007579)
colesen (reporter)
2011-11-14 21:46

I forgot. But with that it now builds and allows rendering using xvid.

- Issue History
Date Modified Username Field Change
2011-11-11 15:57 colesen New Issue
2011-11-12 06:15 evorster Note Added: 0007546
2011-11-13 15:45 colesen Note Added: 0007561
2011-11-14 15:54 j-b-m Note Added: 0007572
2011-11-14 15:54 j-b-m Assigned To => j-b-m
2011-11-14 15:54 j-b-m Status new => feedback
2011-11-14 17:50 colesen Note Added: 0007573
2011-11-14 17:50 colesen Status feedback => assigned
2011-11-14 17:58 j-b-m Note Added: 0007574
2011-11-14 18:19 j-b-m Note Added: 0007575
2011-11-14 21:06 colesen Note Added: 0007577
2011-11-14 21:10 j-b-m Note Added: 0007578
2011-11-14 21:46 colesen Note Added: 0007579
2011-11-14 22:01 j-b-m Status assigned => resolved
2011-11-14 22:01 j-b-m Fixed in Version => 0.8.2.1
2011-11-14 22:01 j-b-m Resolution open => fixed
2011-12-08 22:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker