Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002410KdenliveMLTpublic2011-11-17 19:002011-12-08 22:51
ReporterSmeefer 
Assigned Toj-b-m 
PriorityurgentSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
Platform64 bitOSUbuntuOS Version11.04
Product Version0.8.2 
Target VersionFixed in Version0.8.2 
Summary0002410: Kdenlive 0.8.2 crashes as soon as I try to open the application.
DescriptionWhen opening Kdenlive 0.8.2, it immediately crashes. Every time I try to start the application, it crashes. This is the information I get from it:

Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fcc1e34a7c0 (LWP 8516))]

Thread 3 (Thread 0x7fcc0cf2a700 (LWP 8518)):
#0 0x00007fcc1815bf03 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007fcc1573e104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000002 0x00007fcc1573e9f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000003 0x00007fcc0d889c44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
0000004 0x00007fcc157653e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000005 0x00007fcc19948853 in ?? () from /usr/lib/nvidia-current/libGL.so.1
0000006 0x00007fcc1a780d8c in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
0000007 0x00007fcc1816904d in clone () from /lib/x86_64-linux-gnu/libc.so.6
0000008 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fcc0164c700 (LWP 8519)):
#0 0x00007fcc1a785f2b in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007fcc14c2c392 in ?? () from /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0
0000002 0x00007fcc157132af in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000003 0x00007fcc15713ca9 in g_async_queue_timed_pop () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000004 0x00007fcc15767a5a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000005 0x00007fcc157653e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000006 0x00007fcc19948853 in ?? () from /usr/lib/nvidia-current/libGL.so.1
0000007 0x00007fcc1a780d8c in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
0000008 0x00007fcc1816904d in clone () from /lib/x86_64-linux-gnu/libc.so.6
0000009 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fcc1e34a7c0 (LWP 8516)):
[KCrash Handler]
0000006 mlt_properties_find (self=0x0, name=0x7fcbfa90f658 "0", length=0x0) at mlt_properties.c:484
0000007 mlt_properties_get_data (self=0x0, name=0x7fcbfa90f658 "0", length=0x0) at mlt_properties.c:1045
0000008 0x00007fcbfa90e771 in metadata (type=<value optimized out>, id=0x2917788 "sox.allpass", data=<value optimized out>) at factory.c:53
0000009 0x00007fcc1add35d6 in mlt_repository_metadata (self=<value optimized out>, type=filter_type, service=0x2917788 "sox.allpass") at mlt_repository.c:348
0000010 0x00007fcc1abb08d6 in Mlt::Repository::metadata (this=<value optimized out>, type=<value optimized out>, service=<value optimized out>) at MltRepository.cpp:80
0000011 0x00000000005da6eb in initEffects::createDescriptionFromMlt (repository=0x2596950, filtername=...) at /build/buildd/kdenlive-0.8.3+git20111117-10.0c39f0c1/src/initeffects.cpp:423
0000012 0x00000000005e7030 in initEffects::parseEffectFiles () at /build/buildd/kdenlive-0.8.3+git20111117-10.0c39f0c1/src/initeffects.cpp:232
0000013 0x00000000004b79ef in MainWindow::MainWindow (this=0x25834c0, MltPath=<value optimized out>, Url=..., clipsToLoad=..., parent=<value optimized out>, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /build/buildd/kdenlive-0.8.3+git20111117-10.0c39f0c1/src/mainwindow.cpp:191
0000014 0x000000000049497b in main (argc=5, argv=<value optimized out>) at /build/buildd/kdenlive-0.8.3+git20111117-10.0c39f0c1/src/main.cpp:84

TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon kdenlive-20111120-001901.kcrash [^] (3,012 bytes) 2011-11-20 06:24 [Show Content]

- Relationships
has duplicate 0002412closedj-b-m crash on open 

-  Notes
(0007596)
morvan-1 (reporter)
2011-11-20 06:28

I am reporting the same issue in Ubuntu Oneiric 11.10, with v. 8.2 (sunab build). Segfault on startup.
(0007597)
j-b-m (administrator)
2011-11-20 12:50

I cannot reproduce. Can you please try the following:

1 - Delete the Kdenlive config file ($HOME/.kde/share/config/kdenliverc) and restart Kdenlive

2 - Make sure you don't have several MLT versions installed:

dpkg -l '*mlt*' | grep '^ii'

Also make sure you didn't manually install MLT in /usr/local/lib, remove it if necessary

3 - Check your sox version
dpkg -l '*mlt*' | grep '^ii'

Also, make sure you didn't manually install sox in /usr/local/lib
(0007601)
Smeefer (reporter)
2011-11-21 08:44

MLT versions installed are:

ii libmlt++-dev 0.7.7+git20111113.c83a2435-0ubuntu0~sunab~natty1 MLT multimedia framework C++ wrapper (development)
ii libmlt++3 0.7.7+git20111113.c83a2435-0ubuntu0~sunab~natty1 MLT multimedia framework C++ wrapper (runtime)
ii libmlt-data 1:0.6.2-0.0 multimedia framework (data)
ii libmlt-dbg 0.7.7+git20111113.c83a2435-0ubuntu0~sunab~natty1 multimedia framework (debugging symbols)
ii libmlt-dev 0.7.7+git20111113.c83a2435-0ubuntu0~sunab~natty1 multimedia framework (development)
ii libmlt4 0.7.7+git20111113.c83a2435-0ubuntu0~sunab~natty1 multimedia framework (runtime)

Is this a problem? I see that I have libmlt4 AND libmlt++3 installed.

My sox version is 14.3.1-2ubuntu1.
(0007602)
j-b-m (administrator)
2011-11-21 10:31

Your mlt packages are ok. Can you try this in a terminal:
melt -query filters
melt -query filter=sox.allpass
(0007603)
Smeefer (reporter)
2011-11-21 12:25

1) melt -query filters:

---
filters:
  - videostab
  - videostab2
  - sox
Segmentation fault

2) melt -query filter=sox.allpass:

Segmentation fault
(0007611)
j-b-m (administrator)
2011-11-21 21:41

Oh! I missed a line when checking your MLT:

ii libmlt-data 1:0.6.2-0.0 multimedia framework (data)

You have an old MLT package installed, that is probably the cause of your problems, because I replicated your setup in a virtual machine and no crash for me...
(0007620)
Smeefer (reporter)
2011-11-23 04:46

libmlt-data!!

Which version do you have installed? How can I update this libmlt-data? I haven't got an update for it in the sunab ppa yet...
(0007621)
j-b-m (administrator)
2011-11-23 19:53

libmlt-data 0.7.7 is in the sunab experimental repository:
https://launchpad.net/~sunab/+archive/kdenlive-svn [^]

I would recommand that you remove all MLT and Kdenlive packages, then reinstall kdenlive, it should fetch the correct packages.
(0007623)
Smeefer (reporter)
2011-11-23 22:54

That worked perfectly. Thanks for the help!

- Issue History
Date Modified Username Field Change
2011-11-17 19:00 Smeefer New Issue
2011-11-20 06:24 morvan-1 File Added: kdenlive-20111120-001901.kcrash
2011-11-20 06:28 morvan-1 Note Added: 0007596
2011-11-20 12:50 j-b-m Note Added: 0007597
2011-11-20 12:50 j-b-m Assigned To => j-b-m
2011-11-20 12:50 j-b-m Status new => feedback
2011-11-20 12:56 j-b-m Relationship added has duplicate 0002412
2011-11-21 08:44 Smeefer Note Added: 0007601
2011-11-21 08:44 Smeefer Status feedback => assigned
2011-11-21 10:31 j-b-m Note Added: 0007602
2011-11-21 12:25 Smeefer Note Added: 0007603
2011-11-21 21:41 j-b-m Note Added: 0007611
2011-11-23 04:46 Smeefer Note Added: 0007620
2011-11-23 19:53 j-b-m Note Added: 0007621
2011-11-23 22:54 Smeefer Note Added: 0007623
2011-11-23 22:56 j-b-m Status assigned => resolved
2011-11-23 22:56 j-b-m Fixed in Version => 0.8.2
2011-11-23 22:56 j-b-m Resolution open => no change required
2011-12-08 22:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker