Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000243KdenliveEffectspublic2008-10-21 15:052010-11-15 13:29
Reporteraspiers 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.5 
Summary0000243: Composite transition has strange resizing artefacts
DescriptionHow to reproduce:

- add two overlapping 832x604 clips
- add a Composite transition
- add a keyframe at the end of the transition
- set its opacity to 0
- render

When the transition starts, the first clip jumps to a smaller size (approximately 80% of original size, with top-left corner in the same place at the top-left of the rendered video). The second one fades in at the correct size. If I select the first keyframe at the start of the transition and do resize 200%, the scaling artefact vanishes. No idea why - found that solution by trial and error!

See result here: http://adamspiers.org/video/crossfade-scaling-artefact.avi [^]
TagsNo tags attached.
Build/Install Method(select)
Attached Files? file icon test-0000.mpeg [^] (688,188 bytes) 2008-10-27 22:04
? file icon test-0001.mpeg [^] (166,438 bytes) 2008-10-27 22:04
? file icon test-243.kdenlive [^] (5,753 bytes) 2008-10-27 22:04
? file icon customprofile0 [^] (180 bytes) 2008-10-27 22:05 [Show Content]

- Relationships

-  Notes
(0000537)
madsdyd (administrator)
2008-10-21 21:18

I can reproduce this issue, IF, I do not have a project settings profile, that matches my source stuff.

If I use a project settings profile that matches my clips, I have no issues!

Also, the "Distort" check box is quite confusing, but unchecking it leaves me with something that acts more or less like I expect.

Can you confirm my observations?
(0000554)
aspiers (reporter)
2008-10-22 12:07

No - I get the rescaling with a project settings profile which has the same resolution as my clips.
(0000556)
aspiers (reporter)
2008-10-22 13:12

This also happens with a title clip in the same project - but this time the resize 200% trick does not help :-(
(0000705)
aspiers (reporter)
2008-10-26 23:32

madsdyd suggested that setting the project's DAR correctly might help with this - will try it tomorrow.
(0000709)
aspiers (reporter)
2008-10-27 12:52

It didn't help with this bug (though it did help fix 0000257).
(0000716)
madsdyd (administrator)
2008-10-27 22:07

Finally able to acknowledge - please use attached clips, project, and profile to test.

clip 0000 will change size in the preview pane when changing from the last frame without the composition effect to the first frame with the composition effect.

Tested with versions:

Kdenlive Builder Wizard version: 0.6.1
ffmpeg: Revision: 15728 Last Changed Date: 2008-10-27 01:25:19 +0100 (man, 27 okt 2008)
mlt: Revision: 1207 Last Changed Date: 2008-10-27 06:28:01 +0100 (man, 27 okt 2008)
mlt++: Revision: 1207 Last Changed Date: 2008-10-25 21:05:12 +0200 (lør, 25 okt 2008)
kdenlive: Revision: 2571 Last Changed Date: 2008-10-26 19:32:42 +0100 (søn, 26 okt 2008)
Qt: 4.4.1
KDE: 4.1.2 (KDE 4.1.2)
Kdenlive: 0.7
(0000752)
augu (reporter)
2008-10-29 14:57

I can reproduce the mentioned issue. I would consider the severity of this bug more than minor, because AFAIK the Composite transition is now the only way to get a video fade between clips, that is a very common type of transition (at least for me).
(0000755)
administrator (administrator)
2008-10-29 21:46

I just fixed a problem when opening a project with a transition: all transitions added after the project opening had the same settings as the one already present in the project.

Should work better now. But it seems that if you export to a different size than the current profile you get problems with composite transitions (to be confirmed).

Please note that you can create simpler video crossfades using the "Luma" or "Wipe" transitions.
(0001035)
madsdyd (administrator)
2008-11-10 16:03

This problem is still present in svn rev 2639. Here is how to reproduce

- Create a custom profile with params (left to right, top to bottom): 832/604/10/1/1/1/832/604 and save it.
- restart kdenlive
- in project settings, choose the new project profile
- add the two clips attached to this bug to the project
- drag test-0000.mpeg to the first videotrack
- drag test-0001.mpeg to the second videotrack, make it overlap test-0000.mpeg
- add a composite transition to test-0000.mpeg in the end
- adjust to fit end and start
- slide back and forth, note, no size change, but also, no real changes.
- add a keyframe at the end of the composition transition, set its opacity to 0
- slide back and forth, note the size change in test-0000.mpeg when entering the transition.

Something happens to the composition parameters for the first keyframe, I think, when adding the second.
(0002956)
administrator (administrator)
2009-05-29 02:37

Issue now seems to be fixed in svn
(0002963)
aspiers (reporter)
2009-05-29 12:43

This issue seems to be marked as awaiting my feedback, however unfortunately I will not have time to give feedback any time soon. Please do not wait for me before taking the appropriate action, thanks.
(0003270)
Richard42 (reporter)
2009-06-17 23:12

I have also encountered this bug when making text overlays with kdenlive 0.7.4. I am creating an NTSC DVD, 720x480 resolution. I can reproduce with the following steps:

1. Add a video clip to project, place clip in video track 1
2. Make a new Title clip, use 'show background' to position text within video clip
3. Drag title clip into video track 0, overlapping with video clip
4. Make a composite transition between the two clips and select the transition
5. At this point the text will be positioned properly
6. Add a new keyframe at any point in the transition
7. Now the *size* of the title clip in the first keyframe will be wrong, and this will mess up the position of the whole title

The only way that I have found to avoid this bug is to preemptively adjust the size of the overlay in the first keyframe before adding a second. If I grab and drag the right edge of the red box in the transition and make it wider than the initial size of the red box, I can adjust it so that the title is scaled correctly. Any keyframes that I subsequently add will also be correctly sized. Unfortunately I need to do this for each new transition that I create.

- Issue History
Date Modified Username Field Change
2008-10-21 15:05 aspiers New Issue
2008-10-21 21:18 madsdyd Note Added: 0000537
2008-10-21 21:18 madsdyd Status new => feedback
2008-10-22 12:07 aspiers Note Added: 0000554
2008-10-22 13:12 aspiers Note Added: 0000556
2008-10-26 23:32 aspiers Note Added: 0000705
2008-10-27 12:52 aspiers Note Added: 0000709
2008-10-27 22:04 madsdyd File Added: test-0000.mpeg
2008-10-27 22:04 madsdyd File Added: test-0001.mpeg
2008-10-27 22:04 madsdyd File Added: test-243.kdenlive
2008-10-27 22:05 madsdyd File Added: customprofile0
2008-10-27 22:07 madsdyd Note Added: 0000716
2008-10-27 22:07 madsdyd Status feedback => acknowledged
2008-10-27 22:07 madsdyd Target Version => 0.7.1
2008-10-29 14:57 augu Note Added: 0000752
2008-10-29 21:46 administrator Note Added: 0000755
2008-11-10 16:03 madsdyd Note Added: 0001035
2008-11-17 20:54 madsdyd Target Version 0.7.1 => future version
2009-05-29 02:37 administrator Build/Install Method => (select)
2009-05-29 02:37 administrator Note Added: 0002956
2009-05-29 02:37 administrator Status acknowledged => feedback
2009-05-29 12:43 aspiers Note Added: 0002963
2009-06-17 23:12 Richard42 Note Added: 0003270
2010-11-15 13:28 ttill Assigned To => j-b-m
2010-11-15 13:28 ttill Status feedback => resolved
2010-11-15 13:28 ttill Resolution open => fixed
2010-11-15 13:28 ttill Fixed in Version => 0.7.5
2010-11-15 13:29 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker