Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002432KdenliveFile Loadingpublic2011-12-08 13:202011-12-08 22:50
Reporterhpweiss 
Assigned Toj-b-m 
PriorityhighSeveritycrashReproducibilityhave not tried
StatusclosedResolutionduplicate 
Platform32 bit intel and alikeOSUbuntuOS Version10.04
Product Version0.8.2 
Target VersionFixed in Version0.8.2.1 
Summary0002432: Crash when creating a new project
DescriptionRecently I noticed the problem, that kdenlive crashes when creating a new project via File/New
Additional InformationApplication: kdenlive (0.8.2)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-36-generic i686
Distribution: Ubuntu 10.04.3 LTS

-- Information about the crash:
<Erklären Sie bitte ganz genau, was Sie machten, als das Programm abstürzte.>

The crash can be reproduced every time.

 -- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7894720 (LWP 2384))]

Thread 3 (Thread 0xb522cb70 (LWP 2385)):
#0 0x0018c422 in __kernel_vsyscall ()
#1 0x0017c342 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0x0052cc5e in mlt_consumer_get_frame () from /usr/lib/libmlt.so.4
0000003 0x0052e0e1 in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.4
0000004 0x041c2ea0 in ?? () from /usr/lib/mlt/libmltsdl.so
0000005 0x0017796e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000006 0x0538da4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xb4a2bb70 (LWP 2386)):
#0 0x0018c422 in __kernel_vsyscall ()
#1 0x0017c015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0x041c2718 in ?? () from /usr/lib/mlt/libmltsdl.so
0000003 0x0017796e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000004 0x0538da4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7894720 (LWP 2384)):
[KCrash Handler]
0000006 0x003d0183 in KBookmarkManager::internalDocument (this=0xb425850) at ../../kio/bookmarks/kbookmarkmanager.cc:335
0000007 0x003d01ef in KBookmarkManager::root (this=0xb425850) at ../../kio/bookmarks/kbookmarkmanager.cc:465
0000008 0x003d02ce in KBookmarkMap::update (this=0xb431d80) at ../../kio/bookmarks/kbookmarkmanager.cc:101
0000009 0x003cf559 in KBookmarkManager::parse (this=0xb6743c0) at ../../kio/bookmarks/kbookmarkmanager.cc:394
0000010 0x003d0191 in KBookmarkManager::internalDocument (this=0xb6743c0) at ../../kio/bookmarks/kbookmarkmanager.cc:337
0000011 0x003d01ef in KBookmarkManager::root (this=0xb6743c0) at ../../kio/bookmarks/kbookmarkmanager.cc:465
0000012 0x08127334 in KdenliveDoc::updateProjectFolderPlacesEntry (this=0xb5ab8a0) at /build/buildd/kdenlive-0.8.2/src/kdenlivedoc.cpp:1578
0000013 0x08137f79 in KdenliveDoc (this=0xb5ab8a0, url=..., projectFolder=..., undoGroup=0xa1172d0, profileName=..., properties=..., tracks=..., render=0xab85488, notes=0xa5d64a0, openBackup=0xbff8e96f,
    parent=0xa0f1ff0, progressDialog=0x0) at /build/buildd/kdenlive-0.8.2/src/kdenlivedoc.cpp:329
0000014 0x080b7171 in MainWindow::newFile (this=0xa0f1ff0, showProjectSettings=true, force=false) at /build/buildd/kdenlive-0.8.2/src/mainwindow.cpp:1847
0000015 0x080c9637 in MainWindow::qt_metacall (this=0xa0f1ff0, _c=QMetaObject::InvokeMetaMethod, _id=188897360, _a=0xbff8eb48)
    at /build/buildd/kdenlive-0.8.2/obj-i486-linux-gnu/src/cmake_bindir/mainwindow.moc:394
0000016 0x00cf3c9a in QMetaObject::metacall (object=0xa0f1ff0, cl=188952000, idx=54, argv=0xbff8eb48) at kernel/qmetaobject.cpp:237
0000017 0x00d023d5 in QMetaObject::activate (sender=0xa3dc4b0, m=0x8456500, local_signal_index=1, argv=0xbff8eb48) at kernel/qobject.cpp:3293
0000018 0x012eabd9 in QAction::triggered (this=0xa3dc4b0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
0000019 0x012ecdcc in QAction::activate (this=0xa3dc4b0, event=QAction::Trigger) at kernel/qaction.cpp:1255
0000020 0x017dfbd2 in QAction::trigger (this=0x58) at ../../include/QtGui/../../src/gui/kernel/qaction.h:218
0000021 QToolButton::nextCheckState (this=0x58) at widgets/qtoolbutton.cpp:1147
0000022 0x016fccb3 in QAbstractButtonPrivate::click (this=0xb3cfa80) at widgets/qabstractbutton.cpp:528
0000023 0x016fcfae in QAbstractButton::mouseReleaseEvent (this=0xb3cfa68, e=0xbff8f2b0) at widgets/qabstractbutton.cpp:1121
0000024 0x017e009c in QToolButton::mouseReleaseEvent (this=0xb3cfa68, e=0xbff8f2b0) at widgets/qtoolbutton.cpp:721
0000025 0x0134f7f8 in QWidget::event (this=0xb3cfa68, event=0xbff8f2b0) at kernel/qwidget.cpp:7998
0000026 0x016fbd4e in QAbstractButton::event (this=0xb3cfa68, e=0x58) at widgets/qabstractbutton.cpp:1080
0000027 0x017e2bca in QToolButton::event (this=0xb3cfa68, event=0xbff8f2b0) at widgets/qtoolbutton.cpp:1163
0000028 0x012f14dc in QApplicationPrivate::notify_helper (this=0x9f72a50, receiver=0xb3cfa68, e=0xbff8f2b0) at kernel/qapplication.cpp:4300
0000029 0x012f89f7 in QApplication::notify (this=0xbff8fb64, receiver=0xb3cfa68, e=0xbff8f2b0) at kernel/qapplication.cpp:3865
0000030 0x00fe440a in KApplication::notify (this=0xbff8fb64, receiver=0xb3cfa68, event=0xbff8f2b0) at ../../kdeui/kernel/kapplication.cpp:302
0000031 0x00ceea3b in QCoreApplication::notifyInternal (this=0xbff8fb64, receiver=0xb3cfa68, event=0xbff8f2b0) at kernel/qcoreapplication.cpp:704
0000032 0x012f7952 in QCoreApplication::sendEvent (receiver=0xb3cfa68, event=0xbff8f2b0, alienWidget=0xb3cfa68, nativeWidget=0xb3ce250, buttonDown=0x1c35058, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
0000033 QApplicationPrivate::sendMouseEvent (receiver=0xb3cfa68, event=0xbff8f2b0, alienWidget=0xb3cfa68, nativeWidget=0xb3ce250, buttonDown=0x1c35058, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
0000034 0x01383088 in QETWidget::translateMouseEvent (this=0xb3ce250, event=0xbff8f7cc) at kernel/qapplication_x11.cpp:4368
0000035 0x01382511 in QApplication::x11ProcessEvent (this=0xbff8fb64, event=0xbff8f7cc) at kernel/qapplication_x11.cpp:3379
0000036 0x013b160a in x11EventSourceDispatch (s=0x9f75ca8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
0000037 0x09a8a5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000038 0x09a8e2d8 in ?? () from /lib/libglib-2.0.so.0
0000039 0x09a8e4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000040 0x00d1a5d5 in QEventDispatcherGlib::processEvents (this=0x9f5cdd0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
0000041 0x013b1135 in QGuiEventDispatcherGlib::processEvents (this=0x9f5cdd0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
0000042 0x00ced059 in QEventLoop::processEvents (this=0xbff8fac4, flags=) at kernel/qeventloop.cpp:149
0000043 0x00ced4aa in QEventLoop::exec (this=0xbff8fac4, flags=...) at kernel/qeventloop.cpp:201
0000044 0x00cf169f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
0000045 0x012f1577 in QApplication::exec () at kernel/qapplication.cpp:3579
0000046 0x0809630d in main (argc=5, argv=0xbff8fd94) at /build/buildd/kdenlive-0.8.2/src/main.cpp:89

An http://kdenlive.org/mantis [^] berichten
TagsNo tags attached.
Build/Install Method(select)
Attached Files

- Relationships
duplicate of 0002363closedj-b-m Crash when trying to save project as a new file using "save as" 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-12-08 13:20 hpweiss New Issue
2011-12-08 22:49 j-b-m Relationship added duplicate of 0002363
2011-12-08 22:49 j-b-m Status new => resolved
2011-12-08 22:49 j-b-m Fixed in Version => 0.8.2.1
2011-12-08 22:49 j-b-m Resolution open => duplicate
2011-12-08 22:49 j-b-m Assigned To => j-b-m
2011-12-08 22:50 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker