Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002438KdenliveBuild Systempublic2011-12-13 02:292012-05-15 10:58
Reporterelchivo 
Assigned Toj-b-m 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSUbuntu LinuxOS Version11.10
Product Version0.8.2 
Target VersionFixed in Version0.9 
Summary0002438: Crash after launch
DescriptionI tried to install Kdenlive from various sources (distribution, sunab PPA,
compilation from source), on various destop managers (unity, KDE). Each time
the probleme is the same : Kdenlive starts, but as soon as I click anywhere
(menu, tracks, ...), the program crashes.
The last version I tried is 0.8.2.1. MLT is up to date, as required. The only
missing modules are QImage and Title, that I could'nt find.
Steps To ReproduceRun Kdenlive
Click anywhere
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon kdenlive-20111213-011124.kcrash [^] (5,293 bytes) 2011-12-13 02:29 [Show Content]

- Relationships

-  Notes
(0007666)
j-b-m (administrator)
2011-12-13 16:43

How did you install MLT? Make sure you don't have several MLT versions installed:

ls -la /usr/local/lib/libmlt*
ls -la /usr/lib/libmlt*

Also, try playing a clip with MLT:

melt color:red

(Should bring a red color clip)
(0007668)
elchivo (reporter)
2011-12-13 17:49

> ls -la /usr/local/lib/libmlt*
> ls -la /usr/lib/libmlt*
Thanks for your quick answer .
Here is the result of the above commands :
----------------------------
$ ls -la /usr/local/lib/libmlt*
lrwxrwxrwx 1 root root 15 2011-12-11 22:29 /usr/local/lib/libmlt.so -> libmlt.so.0.7.6
lrwxrwxrwx 1 root root 17 2011-12-11 22:29 /usr/local/lib/libmlt++.so -> libmlt++.so.0.7.6
-rwxr-xr-x 1 root root 447343 2011-12-11 22:29 /usr/local/lib/libmlt.so.0.7.6
-rwxr-xr-x 1 root root 150810 2011-12-11 22:29 /usr/local/lib/libmlt++.so.0.7.6
lrwxrwxrwx 1 root root 17 2011-12-11 22:29 /usr/local/lib/libmlt++.so.3 -> libmlt++.so.0.7.6
lrwxrwxrwx 1 root root 15 2011-12-11 22:29 /usr/local/lib/libmlt.so.4 -> libmlt.so.0.7.6

$ ls -la /usr/lib/libmlt*
lrwxrwxrwx 1 root root 15 2011-11-01 13:42 /usr/lib/libmlt.so -> libmlt.so.0.7.6
lrwxrwxrwx 1 root root 17 2011-11-01 13:43 /usr/lib/libmlt++.so -> libmlt++.so.0.7.6
-rw-r--r-- 1 root root 157260 2011-11-01 13:47 /usr/lib/libmlt.so.0.7.6
-rw-r--r-- 1 root root 108896 2011-11-01 13:48 /usr/lib/libmlt++.so.0.7.6
lrwxrwxrwx 1 root root 17 2011-11-01 13:43 /usr/lib/libmlt++.so.3 -> libmlt++.so.0.7.6
lrwxrwxrwx 1 root root 15 2011-11-01 13:43 /usr/lib/libmlt.so.4 -> libmlt.so.0.7.6
--------------------------------------
I tried to move /usr/lib/libmlt* to root home directory, and then run kdenlive
(from a non root user account), and the problem remains the same : crash after click.
>
> Also, try playing a clip with MLT:
>
> melt color:red
>
> (Should bring a red color clip)
>
This works fine, before moving /usr/lib/libmlt* or after : I get a red window,
with a counter in the lauch window, and the displayed control shortcuts work.
(0007669)
elchivo (reporter)
2011-12-14 00:13

SOLVED !!!
You were right : the problem was in the double install of MLT.
This time, I moved /usr/local/lib/libmlt* to the home root directory,
and now kdenlive doesn't crash anymore. It work quite fine, so far...
Thanks again !

- Issue History
Date Modified Username Field Change
2011-12-13 02:29 elchivo New Issue
2011-12-13 02:29 elchivo File Added: kdenlive-20111213-011124.kcrash
2011-12-13 16:43 j-b-m Note Added: 0007666
2011-12-13 16:43 j-b-m Assigned To => j-b-m
2011-12-13 16:43 j-b-m Status new => feedback
2011-12-13 17:49 elchivo Note Added: 0007668
2011-12-13 17:49 elchivo Status feedback => assigned
2011-12-14 00:13 elchivo Note Added: 0007669
2011-12-14 00:40 j-b-m Status assigned => resolved
2011-12-14 00:40 j-b-m Fixed in Version => Recent git
2011-12-14 00:40 j-b-m Resolution open => no change required
2012-05-15 10:57 j-b-m Fixed in Version Recent git => 0.9
2012-05-15 10:58 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker