Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000247KdenliveMLTpublic2008-10-21 21:362009-06-03 07:01
ReporterArtInvent 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000247: won't play back clips
DescriptionRunning 0.7b built from builder wizard. On Ubuntu Hardy 64 bit. Starting program through kdenlive_start command. Cannot import but not play back any clips. Clip appears with thumbnail and frame on Clip Monitor, can drag to timeline. In some clips I can advance the cursor through and see various frames of an imported clip. When trying to play a clip or the timeline, nothing happens, program becomes unresponsive. Force quit - gdb output attached.
TagsNo tags attached.
Build/Install Method
Attached Filestxt file icon kdenlive bug 2 playback.txt [^] (93,553 bytes) 2008-10-21 21:36 [Show Content]
txt file icon kdenlive_crash_on_add_clip.txt [^] (45,200 bytes) 2008-10-22 17:27 [Show Content]
txt file icon kdenlive_crash_on_Open.txt [^] (41,661 bytes) 2008-10-30 00:21 [Show Content]
txt file icon kdenlive_crash_build_in_tmp.txt [^] (39,063 bytes) 2008-11-01 16:27 [Show Content]

- Relationships

-  Notes
(0000563)
madsdyd (administrator)
2008-10-22 13:49

There seems to be an issue here, with many lines of this form, which I have not noted before:
virtual QVariant Solid::Backends::Hal::HalDevice::property(const QString&) const error: "org.freedesktop.Hal.NoSuchDevice" , ""

Could you try in a terminal, something like this
. /home/e/.kdenlive/bin/kdenlive_env
which inigo
inigo some-clip-that-did-not-play-back

And let us know how it went?

Thanks.
(0000573)
ArtInvent (reporter)
2008-10-22 16:28

Tried the above. Inigo opens a playback window with the clip inside, is unresponsive. On some clips a frame of video is shown, others are black. Will not play, will not advance, will not quit.
(0000577)
ArtInvent (reporter)
2008-10-22 17:30

I've rebuilt from builder wizard 0.6.1, kdenlive 2528. Pretty much the same problems. Now it crashes when I try to add a clip. At first I got to the file browse dialog, but now it crashes every time I merely hit the add clip button.

I have attached a new gdb output 'kdenlive_crash_on_add_clip.txt'.

I also tried the inigo commands from CLI. Same basic freeze up.
(0000582)
madsdyd (administrator)
2008-10-22 20:48

Could you perhaps attach a clip exhibitin this behavour to this bug? It only accepts 5 MB attachments, so if you do not have a clip that is less than that size, could you put it online somewhere, and link to it?

Thanks.
(0000760)
ArtInvent (reporter)
2008-10-30 00:21

I can't even get to playing clips now. I rebuilt from SVN today. Program crashes before I can select a clip. Program crashes when I hit 'Open' or 'Add Clip'. Sure wish I could test some actual functionality but - not a whole lot I can do without some actual video on the screen. Have added output: 'kdenlive_crash_on_Open.txt'
(0000764)
madsdyd (administrator)
2008-10-30 07:08

OK, your build seems hosed. It could be that you have some old cruft from an earlier installation lying around.

Could you please try the builder, and set the sourcedir to /tmp and the install dir to /tmp. (Yes, I do realize that you will have to get all the sources again, but I still thinks this is the best way to determine what goes wrong.

If running this installation fails, could you please try running

. /tmp/bin/kdenlive_start
/tmp/bin/inigo some-video-clip

If this fails, could you please try running (in the same terminal)
/tmp/bin/ffmpeg -i some-video-clip
/tmp/bin/ffplay some-video-clip

and paste the output here?

If running this installation should succeed, we'll take it from there :-)

Regards
(0000798)
ArtInvent (reporter)
2008-11-01 17:06

I've installed today to /tmp and tried to run. Same problems, see output file from 11/01. Crashes now immediately on 'open' or 'add clip.'

It's no better with . /tmp/bin/kdenlive_start. And inigo just locks up immediately.

I've tried some avi, m2v, mov files of DV, HDV, and full 1080 resolutions and can get them to play fine with /tmp/bin/ffplay, but inigo locks up on the first few frames of every single file I've thrown at it.
(0001152)
madsdyd (administrator)
2008-11-12 11:25

I am pretty much stumped here. I'll try to get Dan Dennedy to take a look.
(0001177)
ddennedy (developer)
2008-11-13 19:09

All of the backtraces (except the first log, which is lacking) show a crash somewhere in Qt.

As for inigo not playing, let's stick to testing DV. I have an x86-64 install of Arch Linux, and I do not have this problem. Potentially, I could see perhaps some stalling when inigo used to set its process priority class to realtime. That has been removed somewhat recently. I guess we should get another test with inigo against the recent or released versions. Also, we can wait and see if others report a problem.
(0003042)
Granjow (developer)
2009-06-02 21:08

Any changes in that bug, ArtInvent?
(0003061)
ddennedy (developer)
2009-06-03 07:01

Closing due to age and lack of feedback.

- Issue History
Date Modified Username Field Change
2008-10-21 21:36 ArtInvent New Issue
2008-10-21 21:36 ArtInvent File Added: kdenlive bug 2 playback.txt
2008-10-22 13:49 madsdyd Note Added: 0000563
2008-10-22 13:49 madsdyd Status new => feedback
2008-10-22 16:28 ArtInvent Note Added: 0000573
2008-10-22 17:27 ArtInvent File Added: kdenlive_crash_on_add_clip.txt
2008-10-22 17:30 ArtInvent Note Added: 0000577
2008-10-22 20:48 madsdyd Note Added: 0000582
2008-10-30 00:21 ArtInvent File Added: kdenlive_crash_on_Open.txt
2008-10-30 00:21 ArtInvent Note Added: 0000760
2008-10-30 07:08 madsdyd Note Added: 0000764
2008-11-01 16:27 ArtInvent File Added: kdenlive_crash_build_in_tmp.txt
2008-11-01 17:06 ArtInvent Note Added: 0000798
2008-11-12 11:25 madsdyd Note Added: 0001152
2008-11-13 19:09 ddennedy Note Added: 0001177
2009-06-02 21:08 Granjow Note Added: 0003042
2009-06-03 07:01 ddennedy Status feedback => resolved
2009-06-03 07:01 ddennedy Resolution open => unable to reproduce
2009-06-03 07:01 ddennedy Assigned To => ddennedy
2009-06-03 07:01 ddennedy Note Added: 0003061
2009-06-03 07:01 ddennedy Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker