Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000253KdenliveUser Interfacepublic2008-10-22 12:282009-07-01 22:07
Reporteraspiers 
Assigned ToGranjow 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version 
Summary0000253: random crash while viewing clip
DescriptionI think I just clicked on a clip in the clip window, or maybe on the Clip Monitor tab, and it just crashed.

KBW gdb debug attached.
TagsNo tags attached.
Build/Install Method
Attached Files? file icon kbw.gdb.output.y5dvdPut [^] (96,169 bytes) 2008-10-22 12:28

- Relationships

-  Notes
(0000555)
aspiers (reporter)
2008-10-22 12:47

Just happened again...
(0000560)
madsdyd (administrator)
2008-10-22 13:37

Looks real from the log file.

The crash is SIGFPE, which makes it uncommon for Kdenlive, I think. Here are the lines:

Program received signal SIGFPE, Arithmetic exception.
[Switching to Thread 0xb5db0b90 (LWP 1747)]
0x01a12232 in filter_get_image (this=0x9db8178, image=0xb5db02d4, format=0xb5db02e0, width=0xb5db02d8, height=0xb5db02dc, writable=0) at filter_resize.c:107
107 owidth = rint( scaled_width * owidth / normalised_width );
Current language: auto; currently c
Missing separate debuginfos, use: debuginfo-install e2fsprogs.i386 faac.i386 faad2.i386 kdebase-runtime.i386 kdelibs.i386 keyutils.i386 lame.i386 libquicktime.i386 libsamplerate.i386 libxml2.i386 qt.i386 soprano.i386
(gdb) bt
(gdb) #0 0x01a12232 in filter_get_image (this=0x9db8178, image=0xb5db02d4, format=0xb5db02e0, width=0xb5db02d8, height=0xb5db02dc, writable=0) at filter_resize.c:107
#1 0x0011ab74 in mlt_frame_get_image (this=0x9db8178, buffer=0xb5db02d4, format=0xb5db02e0, width=0xb5db02d8, height=0xb5db02dc, writable=0) at mlt_frame.c:258
0000002 0x0674fb15 in filter_get_image (this=0x9db8178, image=0xb5db02d4, format=0xb5db02e0, width=0xb5db02d8, height=0xb5db02dc, writable=0) at filter_avcolour_space.c:99
0000003 0x0011ab74 in mlt_frame_get_image (this=0x9db8178, buffer=0xb5db02d4, format=0xb5db02e0, width=0xb5db02d8, height=0xb5db02dc, writable=0) at mlt_frame.c:258
0000004 0x017563a4 in consumer_thread (arg=0xb16dd0e0) at consumer_sdl_still.c:455
0000005 0x0077732f in start_thread (arg=<value optimized out>) at pthread_create.c:297
0000006 0x006b220e in clone () from /lib/libc.so.6

And some where full:

(gdb) #0 0x01a12232 in filter_get_image (this=0x9db8178, image=0xb5db02d4, format=0xb5db02e0, width=0xb5db02d8, height=0xb5db02dc, writable=0) at filter_resize.c:107
    input_ar = -nan(0x8000000000000)
    output_ar = -nan(0x8000000000000)
    normalised_width = 0
    normalised_height = 599

So, this looks very much like a divide by zero thingy. (FPE could be something else, but this sure does look like it).

Could you please provide the clip in question, or one of similar size? That may help the developer.

(0000568)
aspiers (reporter)
2008-10-22 14:25

Hmm, the second debug file didn't get added for some reason.

Anyway, you already have the clips ;-)

http://adamspiers.org/video/test-0000.mpeg [^]
http://adamspiers.org/video/test-0001.mpeg [^]
(0003035)
Granjow (developer)
2009-06-02 20:08

Closing. Clips are working, no crashes.

- Issue History
Date Modified Username Field Change
2008-10-22 12:28 aspiers New Issue
2008-10-22 12:28 aspiers File Added: kbw.gdb.output.y5dvdPut
2008-10-22 12:47 aspiers Note Added: 0000555
2008-10-22 13:37 madsdyd Note Added: 0000560
2008-10-22 13:37 madsdyd Status new => feedback
2008-10-22 14:25 aspiers Note Added: 0000568
2009-06-02 20:08 Granjow Note Added: 0003035
2009-06-02 20:08 Granjow Status feedback => resolved
2009-06-02 20:08 Granjow Resolution open => unable to reproduce
2009-06-02 20:08 Granjow Assigned To => Granjow
2009-06-27 02:17 j-b-m Target Version => 0.7.5
2009-07-01 22:07 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker