Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002555KdenliveFile Loadingpublic2012-03-27 15:252012-06-09 08:46
Reporterorbspider 
Assigned Toj-b-m 
PriorityhighSeveritymajorReproducibilityalways
StatusassignedResolutionopen 
Platformcompaq cq40 intel dualcoreOSdebian squeezeOS Version6.0.4
Product Version0.8.2.1 
Target VersionFixed in Version 
Summary0002555: crashes when loading clip: floating point exception
Descriptionwhen I load a clip the program crashes
either mp4, vob, mts
reporter says "floating point exception"

#melt video.mp4 (or other type)
also gives "floating point exception"

#ffplay video.mp4 plays the video

mlt 0.7.8-2 installed
Steps To Reproduceopen project or load a clip

project gets to 50% opened and program crashes
loading clip, gets a little way and crashes
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0007948)
orbspider (reporter)
2012-03-27 16:00
edited on: 2012-03-27 16:01

I've just tried with a previous version of libmlt4 libmlt++3 libmlt-data melt installed, (0.7.6) from snapshots.org, and I get the same crash as reported.

(0007991)
orbspider (reporter)
2012-04-20 08:32

I thought the floating exception came about because of the kernel being only 2.6. not relating to the processor properly.

After distro upgrade to wheezy and kernel 3.2 I still get this crash!

the PID varies but the FPE is an (8)

please offer a suggestion!
(0007992)
j-b-m (administrator)
2012-04-20 09:27

Ok, then first make sure that you don't have older mlt packages installed (either from packages or from a manual compilation in /usr/local).

Then, post a backtrace. From a terminal:

$ gdb melt
$ run video.mp4

When it crashes:

$ thread apply all bt

Then press enter until all info is printed and paste the result here

(0007994)
orbspider (reporter)
2012-04-20 16:05
edited on: 2012-04-20 16:11

q: where should mlt be installed? I have mlt-0/mlt-0.7.8 in my home dir

here's the output:


(gdb) run ~/1.mp4
Starting program: /usr/bin/melt ~/1.mp4
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe07c2700 (LWP 5686)]
[New Thread 0x7fffdffc1700 (LWP 5687)]
[New Thread 0x7fffdf7c0700 (LWP 5688)]

Program received signal SIGFPE, Arithmetic exception.
0x00007fffe09d6955 in filter_get_image (this=0x555555908fe0,
    image=0x7fffffffe220, format=0x7fffffffe23c, width=0x7fffffffe238,
    height=0x7fffffffe234, writable=0) at filter_resize.c:241
241 filter_resize.c: No such file or directory.
(gdb) thread apply all bt

Thread 4 (Thread 0x7fffdf7c0700 (LWP 5688)):
#0 0x00007ffff79a62d4 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007ffff4c662bb in ?? () from /usr/lib/x86_64-linux-gnu/libavcodec.so.53
0000002 0x00007ffff79a1b50 in start_thread ()
   from /lib/x86_64-linux-gnu/libpthread.so.0
0000003 0x00007ffff76ec90d in clone () from /lib/x86_64-linux-gnu/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fffdffc1700 (LWP 5687)):
#0 0x00007ffff79a62d4 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007ffff4c662bb in ?? () from /usr/lib/x86_64-linux-gnu/libavcodec.so.53
0000002 0x00007ffff79a1b50 in start_thread ()
   from /lib/x86_64-linux-gnu/libpthread.so.0
0000003 0x00007ffff76ec90d in clone () from /lib/x86_64-linux-gnu/libc.so.6
0000004 0x0000000000000000 in ?? ()


Thread 2 (Thread 0x7fffe07c2700 (LWP 5686)):
#0 0x00007ffff79a62d4 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007ffff4c662bb in ?? () from /usr/lib/x86_64-linux-gnu/libavcodec.so.53
---Type <return> to continue, or q <return> to quit---
0000002 0x00007ffff79a1b50 in start_thread ()
   from /lib/x86_64-linux-gnu/libpthread.so.0
0000003 0x00007ffff76ec90d in clone () from /lib/x86_64-linux-gnu/libc.so.6
0000004 0x0000000000000000 in ?? ()


Thread 1 (Thread 0x7ffff7fd6700 (LWP 5683)):
#0 0x00007fffe09d6955 in filter_get_image (this=0x555555908fe0,
    image=0x7fffffffe220, format=0x7fffffffe23c, width=0x7fffffffe238,
    height=0x7fffffffe234, writable=0) at filter_resize.c:241
#1 0x00007ffff7bc1eaa in mlt_frame_get_image (self=0x555555908fe0,
    buffer=0x7fffffffe220, format=0x7fffffffe23c, width=0x7fffffffe238,
    height=0x7fffffffe234, writable=<optimized out>) at mlt_frame.c:452
0000002 0x00007ffff7bd378d in producer_get_image (self=0x5555559088d0,
    buffer=0x7fffffffe220, format=0x7fffffffe23c, width=0x7fffffffe238,
    height=0x7fffffffe234, writable=<optimized out>) at mlt_tractor.c:273
0000003 0x00007ffff7bc1eaa in mlt_frame_get_image (self=0x5555559088d0,
    buffer=0x7fffffffe220, format=0x7fffffffe23c, width=0x7fffffffe238,
    height=0x7fffffffe234, writable=<optimized out>) at mlt_frame.c:452
0000004 0x00007ffff7bd5472 in mlt_profile_from_producer (profile=0x55555576c650,
    producer=0x5555558b82e0) at mlt_profile.c:409
0000005 0x0000555555556d5b in main (argc=2, argv=0x7fffffffe3c8) at melt.c:821
(gdb)

(0007997)
orbspider (reporter)
2012-04-23 21:25
edited on: 2012-04-23 21:31

I uninstalled libmlt4, libmlt++3, libmlt-data and melt, searched for mlt anywhere, and re-installed, then kdenlive

but still get floating point exc (8)

(0008121)
orbspider (reporter)
2012-06-09 08:46

Finally I have a working install!!
Fresh Debian wheezy install with following the (looks new!) debian man page here
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-compiled-packages/debian-packages [^]

but installing ffmpeg first
apt-get install ffmpeg x264 libmp3lame0 libquicktime2

then the rest
apt-get install kdenlive frei0r-plugins dvgrab recordmydesktop dvdauthor genisoimage

Will enjoy it very much now.
thanks for all your hard work on it.

- Issue History
Date Modified Username Field Change
2012-03-27 15:25 orbspider New Issue
2012-03-27 16:00 orbspider Note Added: 0007948
2012-03-27 16:01 orbspider Note Edited: 0007948 View Revisions
2012-04-20 08:32 orbspider Note Added: 0007991
2012-04-20 09:27 j-b-m Note Added: 0007992
2012-04-20 09:27 j-b-m Assigned To => j-b-m
2012-04-20 09:27 j-b-m Status new => feedback
2012-04-20 15:53 orbspider Note Added: 0007993
2012-04-20 15:53 orbspider Status feedback => assigned
2012-04-20 15:54 orbspider Note Edited: 0007993 View Revisions
2012-04-20 15:55 orbspider Note Deleted: 0007993
2012-04-20 16:05 orbspider Note Added: 0007994
2012-04-20 16:11 orbspider Note Edited: 0007994 View Revisions
2012-04-20 16:11 orbspider Note Edited: 0007994 View Revisions
2012-04-23 21:25 orbspider Note Added: 0007997
2012-04-23 21:31 orbspider Note Edited: 0007997 View Revisions
2012-04-24 10:58 orbspider Note Added: 0007998
2012-06-09 08:46 orbspider Note Added: 0008121
2012-06-09 08:47 orbspider Note Deleted: 0007998


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker