Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002623KdenliveTransitionspublic2012-05-26 00:282012-05-30 00:26
Reporterybecognee 
Assigned Toj-b-m 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformMacintel 64bitOSUbuntu LinuxOS Version11.10
Product Version0.9 
Target VersionFixed in Version0.9.2 
Summary0002623: Titles using composite are invisible in the movie exported.
DescriptionA title or a sequence of .png wearing composite transition works fine in the preview, but is invisible in the final file.
I think the sequence of .png became very tiny.
Is it the same bug as here : http://www.kdenlive.org/mantis/view.php?id=2613 [^] ?
Steps To ReproduceMakink a title with a composite transition.
Additional InformationI believe that the bug exists only when we shift the layer of the title. If you do not touch it, the title will be visible export.
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files? file icon Va en sport.kdenlive [^] (11,549 bytes) 2012-05-26 00:28

- Relationships

-  Notes
(0008085)
ybecognee (reporter)
2012-05-26 17:04

I tried to go around the bug by using the effect "pan and zoom" to resize instead of modifying the parameters of the composite transition. But the problem remains the same : the .png sequence is invisible in the exported file. Movies of my students (ages 9 to 11) contain many composites and can't be exported. But the projection approach ...
(0008087)
j-b-m (administrator)
2012-05-27 09:07

I would need the images used in the project to fully understand. Could you archive the project and mail it to me?

Go to Project > Archive Project, then check the "Compressed archive" option.
This will create a .ter.gz file with all clips used in the project.

Then mail it to me: jb@kdenlive.org
(0008090)
ybecognee (reporter)
2012-05-27 14:20

I did it.
At the preview, there is a bug : a right part of the .png sequence is missing.
Curiously, I can change the composite's settings in this file. While in all others, KDEnLive crash immediately :
http://kdenlive.org/mantis/view.php?id=2613 [^]
(0008091)
j-b-m (administrator)
2012-05-27 18:24

The project renders fine for me. However, I can reproduce the problem with a missing part of the png image.

In your timeline, you use both a "Pan & Zoom" effect (Panoramique & zoom) and a Composite transition. This is not necessary and somehow causes the bug with a missing part of the image.

The effect you want to achieve can be done entirely with the composite transition, no need to use the Pan & Zoom effect. Can you try deleting the Pan & Zoom effects, and adjust the size and position of your clips using the composite transition parameters?

Maybe it will solve your disappearing title problem. The composite crash is only there when you have sound in the clips that are in the transition...
(0008092)
ybecognee (reporter)
2012-05-27 18:47

The effect "pan & zoom" was only to test another solution without changing the composite parameter. I forgot to remove it.
You may have noticed the two transitions that I made after the sequence of .png : the one I changed a setting is invisible, the other is visible ...
(0008093)
ybecognee (reporter)
2012-05-27 19:15

I just made a new test. By making a new project from scratch : everything works fine : the png sequence is visible after rendering. Perhaps it is because the first project was started with 0.8.2.1 ?
What can be the difference between the code, "Va en sport" (dont export well) and "Va en sport - 0.9" (export well) ?
(see your email)
How to proceed with major projects ? (very long and complicated to be redone.)

Thank you
(0008094)
j-b-m (administrator)
2012-05-27 21:30

I have checked the working project file and the non working one.
There mostly are 2 differences:

1 - slideshow URL:
In the non working version, the filename in the url of the slideshow is:
sport-%.1d.png

But in the working version, it is:

sport-%1d.png

In the non working version, there is a dot '.' between the % and the d.

Could you open the non working .kdenlive project file and replace all occurences of %.1d
 with %1d then see if it renders correctly?

The second difference is in the file encoding, but let's first see if removing the dot helps...
(0008095)
ybecognee (reporter)
2012-05-27 21:51

I will see...
But it can not affect titles to...
(0008096)
ybecognee (reporter)
2012-05-27 22:26

No, it makes no difference. I also tried to export to DV ... But the png's animated text and the title which have been modified composite transitions are not exported.
(The animated text is in the final video: in very small !)
(0008097)
j-b-m (administrator)
2012-05-27 22:28

You're right it would not affect titles. So I checked and found the problem!

It is still related to the locale stuff. Your non-working projects have been created with a french locale (using a comma as decimal separator).

Your computer is now configured with a Nicaragua local which (should) uses a dot as separator.

I could reproduce your composite bug with this configuration: trying to render a french project on a system with a dot as separator. I still have to fix the problem.

But the good news is that you should be able to render your project using this:

LC_NUMERIC=fr_FR.UTF-8 kdenlive

Then open your project file and render should work
(0008098)
ybecognee (reporter)
2012-05-27 23:34

Yes ! It's work !!!
I should have guessed ! But the preview was good and there is another bug on the composite, so I did not think about the local setting...
Is there Monday the new version ?

Thank you again for the time you spent.

- Issue History
Date Modified Username Field Change
2012-05-26 00:28 ybecognee New Issue
2012-05-26 00:28 ybecognee File Added: Va en sport.kdenlive
2012-05-26 17:04 ybecognee Note Added: 0008085
2012-05-27 09:07 j-b-m Note Added: 0008087
2012-05-27 09:07 j-b-m Assigned To => j-b-m
2012-05-27 09:07 j-b-m Status new => feedback
2012-05-27 14:20 ybecognee Note Added: 0008090
2012-05-27 14:20 ybecognee Status feedback => assigned
2012-05-27 18:24 j-b-m Note Added: 0008091
2012-05-27 18:47 ybecognee Note Added: 0008092
2012-05-27 19:15 ybecognee Note Added: 0008093
2012-05-27 21:30 j-b-m Note Added: 0008094
2012-05-27 21:51 ybecognee Note Added: 0008095
2012-05-27 22:26 ybecognee Note Added: 0008096
2012-05-27 22:28 j-b-m Note Added: 0008097
2012-05-27 23:34 ybecognee Note Added: 0008098
2012-05-30 00:24 j-b-m Status assigned => resolved
2012-05-30 00:24 j-b-m Fixed in Version => 0.9.2
2012-05-30 00:24 j-b-m Resolution open => fixed
2012-05-30 00:26 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker