Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002668KdenliveEffectspublic2012-07-03 21:412013-01-28 19:50
Reportermrbumpy409 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformamd64OSKubuntuOS Version12.04
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002668: dissolve effect fails when clip has used "split audio"
DescriptionAfter using "split audio" on a video clip, the dissolve effect will no longer work between cut segments of the clip.
Steps To Reproduce1. Add a video clip containing audio to video track 1. (Attached is a short video file that can reproduce the bug)
2. Right-click on the clip and select "Split Audio".
3. Set the cursor in the middle of the clip and cut the clip there.
4. Drag the clip from the right side of the cut to video track 2. The audio clip that is grouped with this clip will automatically move to audio track 2 as well.
5. Drag the clip on video track 2 a bit to the left so that the clips on video tracks 1 and 2 overlap slightly.
6. Add a dissolve effect to transition between the two video clips.

Result: the dissolve effect doesn't work. If you repeat these steps without doing step 2 (split audio), the dissolve transition works fine.
Additional InformationTested with Kdenlive version 0.9.3+git20120701.53f9c1b9-0ubuntu0~sunab~precise1 from the SVN PPA for Ubuntu.
TagsNo tags attached.
Build/Install Method
Attached Filesgz file icon clapping.tar.gz [^] (470,367 bytes) 2012-07-03 21:44
png file icon Shot-004.png [^] (19,589 bytes) 2012-09-11 20:51

- Relationships

-  Notes
(0008169)
Zuf (reporter)
2012-07-26 16:17

melt also has this bug when playing project with dissolve transition on same clip.
(0008170)
ddennedy (developer)
2012-07-30 04:19

Kdenlive is supposed to create a separate producer for every instance of a clip on the timeline. Normally it does, but it looks like in this workflow it did not.
(0008171)
Zuf (reporter)
2012-07-30 12:43

Thank you, ddennedy!

I made a simple ruby script that fix project xml structure.
It works for me, hope some one can found it useful until this bug not been fixed.

Script itself: https://gist.github.com/3206118 [^]
To run it you need ruby and nokogiri library (for xml parsing).
(0008282)
eddrog (developer)
2012-09-06 11:34

With recent mlt I can not reproduce this bug. Anybody else?
(0008283)
gingerling (reporter)
2012-09-06 19:13

I have this bug, its very annoying as I cant do a "time passing montage" with the cat eating through his bowl of food, which i need to do. I use kxstudio OS, the guy there compiles kdenlive himself each month and makes a custom melt I believe. I will alert him to this issue to. I think I have experienced this bug a lot of times before and just not stumbled upon the solution as I didn't notice it was only effecting bugs within the same clip. I don't really want to edit xml files etc as I am not code savvy. Is there any chance of a patch?
(0008284)
gingerling (reporter)
2012-09-06 20:15

also, i haven't split my audio and still have this issue - the video HAS no audio however, as the audio is more like narration.
(0008285)
Zuf (reporter)
2012-09-06 20:33

I still has this issue.
(0008298)
gingerling (reporter)
2012-09-08 11:51

Hum, does seem to be intermittent though - had the issue with one clip but not another (same camera, same everything!).

Note to all - a very simple solution to this (no xml!) is to copy the source video and rename it then alternate between the two as needed. eg have video_1 and video_2 (otherwise identical files) and then alternate them video_1 fade to video_2 fade back to video_1 etc. I used this to achieve my time-passing montage. It's not ideal and this bug is really pesky - but at least you can get work done :)
(0008299)
vpinon (administrator)
2012-09-08 12:44

dan explained MLT internals and gave the trick in an old ticket (sorry I can't find it again): just import the same file again, kdenlive will offer to re-import it (with a new producer ID in xml). Then do your operations between the 2 different imports.
This saves disk space if you cut a big long rush (or you could have used symlinks also)...
(0008300)
gingerling (reporter)
2012-09-08 12:53

even better. This all said - the bug still needs fixing right? There may be work-arounds but its still not exactly convenient - prettey sure this isn't an issue in adobe etc.... :S
(0008302)
j-b-m (administrator)
2012-09-08 14:47

I am working on this issue. Waiting for some input from MLT's maintainer, then I will fix it.
(0008304)
eddrog (developer)
2012-09-08 15:45

Got it again. The dissolve does not work if audio is splitted and you make a cut or if you cut a video with no audio.

The workarround: importing the same clip two times in project and into timeline and cut both clips => dissolve works in any case (perhaps an info for j-b-m).
(0008309)
j-b-m (administrator)
2012-09-09 08:26

This was a regression in Mlt. Should now be fixed in MLT'git repo.
(0008310)
eddrog (developer)
2012-09-09 14:35

Yes it works again but the performance of the "not splitted" video is much better!!!
(0008313)
j-b-m (administrator)
2012-09-09 18:45

When using clips without audio, Kdenlive internally uses the same producer for all tracks. As Dan explained in his answer (*), making a transition with the same producer gives a bad seeking performance.

So we have to decide what we want:

1 - Keep things like now - bad seeking (preview) performance, but takes less memory

2 - Duplicate the producer for each track used (like we do for clips with audio), giving better seeking / preview performance, but taking more memory.

I don't have time to measure the performance improvment / penalty for each option, so if some users are interested to make some tests or if you think one option is really better, I am open to any of the 2 approaches.


(*) http://sourceforge.net/mailarchive/message.php?msg_id=29785288 [^]
(0008315)
Zuf (reporter)
2012-09-09 20:23

I prefer second approach. Memory cheaper then time :)
(0008316)
ddennedy (developer)
2012-09-09 20:45

The memory increase should not be much. The thing that uses up memory most is uncompressed images being cached, but that is governed automatically by the cache limit. Once you have more than a few clips, you have reached the cache limit. So, significant memory increase due to creating a new producer should only be noticeable if you have less than 5 clips in your project (actually depends on number of tracks). Otherwise, the only additional memory increase is for the producer object state/structures, which is much less than an uncompressed image. :-)
(0008317)
eddrog (developer)
2012-09-10 10:43

If the memory increase is not significant my choise is performance - well approach 2.

In my tests the performance difference was significant. With two producers I get a smooth transition. In other case its ceasing. Felt its two times faster.
(0008318)
mrbumpy409 (reporter)
2012-09-10 17:07

I would also prefer approach 0000002. Of course, I also have gobs of RAM :)
(0008319)
mrbumpy409 (reporter)
2012-09-10 17:09

Okay, note to self: don't use the number sign before a number or mantis thinks I'm referring to a bug report.
(0008322)
j-b-m (administrator)
2012-09-11 09:08

I just committed the change in Kdenlive, now splitted video clips also use the track duplication feature that will improve seeking performance. Please test (Note that it will not convert existing timeline clips but only affect clips that are dragged in timeline from now on)
(0008325)
eddrog (developer)
2012-09-11 20:52

1) I have tested with different formats => works so far pretty good.

2) Adding dissolve to audio: length not in sync with overlapping (see Shot-004.png)

3) Audio dissolve does not work. Not sure if it worked before (@j-b-m) ????
(0008327)
Zuf (reporter)
2012-09-12 21:59
edited on: 2012-09-12 21:59

Video dissolve works for me now.

(0008328)
ddennedy (developer)
2012-09-12 22:31

There are no explicit audio transitions in Kdenlive. IOW, the Dissolve transition is supposed to be for video only. If you want an audio crossfade, you need to adjust the audio Fade Out of clip A and the Fade In of clip B.
(0008333)
eddrog (developer)
2012-09-13 10:14

Thank you Dan.

I think to have it clear following has to be done:

1) Add a crossfade in the manner of the dissolve (its pretty handy) or

2) Remove the transition "dissolve for audio" in the gui
(0008339)
eddrog (developer)
2012-09-14 09:28

What I mean is to forbid transitions for audio track but low prio of course.
(0008340)
j-b-m (administrator)
2012-09-14 10:29

Transitions are now disabled for audio clips, closing this bug.

- Issue History
Date Modified Username Field Change
2012-07-03 21:41 mrbumpy409 New Issue
2012-07-03 21:44 mrbumpy409 File Added: clapping.tar.gz
2012-07-26 16:17 Zuf Note Added: 0008169
2012-07-30 04:19 ddennedy Note Added: 0008170
2012-07-30 12:43 Zuf Note Added: 0008171
2012-08-04 18:14 eddrog Note Added: 0008183
2012-08-24 12:04 vpinon Assigned To => vpinon
2012-08-24 12:04 vpinon Status new => acknowledged
2012-09-06 11:33 eddrog Note Deleted: 0008183
2012-09-06 11:34 eddrog Note Added: 0008282
2012-09-06 19:13 gingerling Note Added: 0008283
2012-09-06 20:15 gingerling Note Added: 0008284
2012-09-06 20:33 Zuf Note Added: 0008285
2012-09-08 11:51 gingerling Note Added: 0008298
2012-09-08 12:44 vpinon Note Added: 0008299
2012-09-08 12:53 gingerling Note Added: 0008300
2012-09-08 14:47 j-b-m Note Added: 0008302
2012-09-08 15:45 eddrog Note Added: 0008304
2012-09-09 08:26 j-b-m Note Added: 0008309
2012-09-09 14:35 eddrog Note Added: 0008310
2012-09-09 18:45 j-b-m Note Added: 0008313
2012-09-09 20:23 Zuf Note Added: 0008315
2012-09-09 20:45 ddennedy Note Added: 0008316
2012-09-10 10:43 eddrog Note Added: 0008317
2012-09-10 17:07 mrbumpy409 Note Added: 0008318
2012-09-10 17:09 mrbumpy409 Note Added: 0008319
2012-09-11 09:08 j-b-m Note Added: 0008322
2012-09-11 09:08 j-b-m Assigned To vpinon => j-b-m
2012-09-11 09:08 j-b-m Status acknowledged => feedback
2012-09-11 20:51 eddrog File Added: Shot-004.png
2012-09-11 20:52 eddrog Note Added: 0008325
2012-09-12 21:59 Zuf Note Added: 0008327
2012-09-12 21:59 Zuf Note Edited: 0008327 View Revisions
2012-09-12 22:31 ddennedy Note Added: 0008328
2012-09-13 10:14 eddrog Note Added: 0008333
2012-09-14 09:28 eddrog Note Added: 0008339
2012-09-14 10:29 j-b-m Note Added: 0008340
2012-09-14 10:29 j-b-m Status feedback => resolved
2012-09-14 10:29 j-b-m Fixed in Version => Recent git
2012-09-14 10:29 j-b-m Resolution open => fixed
2013-01-28 19:50 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:50 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker