Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002700KdenliveFile Loadingpublic2012-08-11 15:182013-01-28 19:50
Reportercatvomit 
Assigned Tovpinon 
PriorityimmediateSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSKubuntuOS Version11.04
Product Version0.9.2 
Target VersionFixed in Version0.9.4 
Summary0002700: Kdenlive Crashes When Adding Clip To Timeline
DescriptionI opened the program in a terminal in order to see what messages the program would output when reproducing the bug. It said:

luisetta@riverspiritfilms:~$ kdenlive
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
[mp3 @ 0x53b5680] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x53b5680] Invalid size in frame ck (, skipping the rest of tag.
[mp3 @ 0x53b5680] max_analyze_duration reached
[mp3 @ 0x53b8180] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x53b8180] Invalid size in frame ck (, skipping the rest of tag.
[mp3 @ 0x53b8180] max_analyze_duration reached
[mp3 @ 0x53c8640] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x53c8640] Invalid size in frame rack, skipping the rest of tag.
[mp3 @ 0x53c8640] max_analyze_duration reached
[mp3 @ 0x53c9040] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x53c9040] Invalid size in frame rack, skipping the rest of tag.
[mp3 @ 0x53c9040] max_analyze_duration reached
[mp3 @ 0x5617de0] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x5617de0] Invalid size in frame wor, skipping the rest of tag.
[mp3 @ 0x5617de0] max_analyze_duration reached
[mp3 @ 0x5669a60] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x5669a60] Invalid size in frame wor, skipping the rest of tag.
[mp3 @ 0x5669a60] max_analyze_duration reached
[wav @ 0x5654240] max_analyze_duration reached
[wav @ 0x565d600] max_analyze_duration reached
[mp3 @ 0x569a860] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x569a860] Invalid size in frame rack, skipping the rest of tag.
[mp3 @ 0x569a860] max_analyze_duration reached
[mp3 @ 0x5cf3980] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x5cf3980] Invalid size in frame rack, skipping the rest of tag.
[mp3 @ 0x5cf3980] max_analyze_duration reached
[mp3 @ 0x88de1c0] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x88de1c0] Invalid size in frame etta, skipping the rest of tag.
[mp3 @ 0x88de1c0] max_analyze_duration reached
[mp3 @ 0x8ec4980] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x8ec4980] Invalid size in frame etta, skipping the rest of tag.
[mp3 @ 0x8ec4980] max_analyze_duration reached
[mp3 @ 0x3daac20] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x3daac20] Invalid size in frame info, skipping the rest of tag.
[mp3 @ 0x3daac20] max_analyze_duration reached
[mp3 @ 0x3e37940] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x3e37940] Invalid size in frame info, skipping the rest of tag.
[mp3 @ 0x3e37940] max_analyze_duration reached
[mp3 @ 0x7ff0c802b840] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x7ff0c802b840] Invalid size in frame $, skipping the rest of tag.
[mp3 @ 0x7ff0c802b840] max_analyze_duration reached
[mp3 @ 0x7ff0c802dbc0] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x7ff0c802dbc0] Invalid size in frame $, skipping the rest of tag.
[mp3 @ 0x7ff0c802dbc0] max_analyze_duration reached
[mp3 @ 0x7ff0c82cfa20] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x7ff0c82cfa20] Invalid size in frame tex, skipping the rest of tag.
[mp3 @ 0x7ff0c82cfa20] max_analyze_duration reached
[mp3 @ 0x7ff0c8704640] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x7ff0c8704640] Invalid size in frame tex, skipping the rest of tag.
[mp3 @ 0x7ff0c8704640] max_analyze_duration reached
[mp3 @ 0x7ff0c99f9440] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x7ff0c99f9440] Invalid size in frame wor, skipping the rest of tag.
[mp3 @ 0x7ff0c99f9440] max_analyze_duration reached
[mp3 @ 0x7ff0ca734e20] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x7ff0ca734e20] Invalid size in frame wor, skipping the rest of tag.
[mp3 @ 0x7ff0ca734e20] max_analyze_duration reached
[mp3 @ 0x3db6080] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x3db6080] Invalid size in frame rmat, skipping the rest of tag.
[mp3 @ 0x3db6080] max_analyze_duration reached
[mp3 @ 0x2ad37dc0] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x2ad37dc0] Invalid size in frame rmat, skipping the rest of tag.
[mp3 @ 0x2ad37dc0] max_analyze_duration reached
[mp3 @ 0x2ad46600] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x2ad46600] Invalid size in frame n an, skipping the rest of tag.
[mp3 @ 0x2ad46600] max_analyze_duration reached
[mp3 @ 0x2ad34860] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x2ad34860] Invalid size in frame n an, skipping the rest of tag.
[mp3 @ 0x2ad34860] max_analyze_duration reached
[mp3 @ 0x2a6b2d40] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x2a6b2d40] Invalid size in frame , skipping the rest of tag.
[mp3 @ 0x2a6b2d40] max_analyze_duration reached
[mp3 @ 0x2a9d86c0] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x2a9d86c0] Invalid size in frame , skipping the rest of tag.
[mp3 @ 0x2a9d86c0] max_analyze_duration reached
[wav @ 0x7ff0b43aaf80] max_analyze_duration reached
[wav @ 0x7ff0b43ab500] max_analyze_duration reached
[wav @ 0x7ff0b43d20e0] max_analyze_duration reached
[wav @ 0x7ff0ad673b00] max_analyze_duration reached
[mp3 @ 0x7ff0b43f5d40] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x7ff0b43f5d40] Invalid size in frame , skipping the rest of tag.
[mp3 @ 0x7ff0b43f5d40] max_analyze_duration reached
[mp3 @ 0x7ff0b43e4c20] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x7ff0b43e4c20] Invalid size in frame , skipping the rest of tag.
[mp3 @ 0x7ff0b43e4c20] max_analyze_duration reached
[mp3 @ 0x4058d80] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x4058d80] Invalid size in frame info, skipping the rest of tag.
[mp3 @ 0x4058d80] max_analyze_duration reached
[mp3 @ 0x40592e0] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x40592e0] Invalid size in frame info, skipping the rest of tag.
[mp3 @ 0x40592e0] max_analyze_duration reached
[mp3 @ 0x7ff0ad6c7e00] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x7ff0ad6c7e00] Invalid size in frame info, skipping the rest of tag.
[mp3 @ 0x7ff0ad6c7e00] max_analyze_duration reached
[mp3 @ 0x7ff0ad6c8600] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x7ff0ad6c8600] Invalid size in frame info, skipping the rest of tag.
[mp3 @ 0x7ff0ad6c8600] max_analyze_duration reached
[mp3 @ 0x2c9af520] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x2c9af520] Invalid size in frame , skipping the rest of tag.
[mp3 @ 0x2c9af520] max_analyze_duration reached
[mp3 @ 0x2c9a75a0] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x2c9a75a0] Invalid size in frame , skipping the rest of tag.
[mp3 @ 0x2c9a75a0] max_analyze_duration reached
[mp3 @ 0x31d0360] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x31d0360] Invalid size in frame , skipping the rest of tag.
[mp3 @ 0x31d0360] max_analyze_duration reached
[mp3 @ 0x2ca16520] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x2ca16520] Invalid size in frame , skipping the rest of tag.
[mp3 @ 0x2ca16520] max_analyze_duration reached
[mp3 @ 0x3d47500] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x3d47500] Invalid size in frame etta, skipping the rest of tag.
[mp3 @ 0x3d47500] max_analyze_duration reached
[mp3 @ 0x3d47ca0] Skipping encrypted/compressed ID3v2 frame .
[mp3 @ 0x3d47ca0] Invalid size in frame etta, skipping the rest of tag.
[mp3 @ 0x3d47ca0] max_analyze_duration reached
kdenlive: symbol lookup error: kdenlive: undefined symbol: _ZN3Mlt5Frame12get_positionEv
Steps To ReproducePreviously saved project was opened, add clip button was pressed, .MOV file was chosen, the program crashed.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon OldestRoad-August11.kdenlive [^] (406,261 bytes) 2012-08-11 15:18

- Relationships

-  Notes
(0008212)
vpinon (administrator)
2012-08-24 11:41

Hi,
Seems kdenlive cannot find Mlt::Frame get_position function, which was added to MLT in February.
How old is your MLT version ? Could you upgrade it and test ?
BR
(0008229)
catvomit (reporter)
2012-08-25 11:45

i think i figured it out.

this is what i did:

added the svn PPA, installed the latest svn.

opened the same project, did the same action.

error message appeared: no such encoder, libmp3lame.

basically, the program failed to create a proxy clip.

i am 99% sure that this is what was happening with 0.9.2, because when i installed the libmp3lame library, and downgraded back to 0.9.2, the crashes stopped happening.
(0008230)
vpinon (administrator)
2012-08-25 14:48

good you found a solution; we should just not crash when a file is missing but warn & survive (ideally)
(0008242)
j-b-m (administrator)
2012-09-01 21:05

Marking as resolved since git version correctly reports the error without crashing

- Issue History
Date Modified Username Field Change
2012-08-11 15:18 catvomit New Issue
2012-08-11 15:18 catvomit File Added: OldestRoad-August11.kdenlive
2012-08-24 11:41 vpinon Note Added: 0008212
2012-08-24 11:41 vpinon Assigned To => vpinon
2012-08-24 11:41 vpinon Status new => feedback
2012-08-25 11:45 catvomit Note Added: 0008229
2012-08-25 11:45 catvomit Status feedback => assigned
2012-08-25 14:48 vpinon Note Added: 0008230
2012-09-01 21:05 j-b-m Note Added: 0008242
2012-09-01 21:05 j-b-m Status assigned => resolved
2012-09-01 21:05 j-b-m Fixed in Version => Recent git
2012-09-01 21:05 j-b-m Resolution open => fixed
2013-01-28 19:50 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:50 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker