Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002715KdenliveUser Interfacepublic2012-09-03 03:362013-01-28 19:51
ReporterZoop 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSChakraOS VersionClaire
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002715: [regression] Clicking in the timeline doesn't move the playhead
DescriptionMy version of Kdenlive+libs compiled on August 30 and before don't have this problem at all. From my Kdenlive compiled on Septembe 1'st (and again on the 2'nd) though I have the following problem:

1. The playhead only moves to where I click in the timeline, the first time I click. After that, it just stays where it is, and a small blue square is drawn at the top of the timeline (see screenshot).

2. Every time I click play / pause (space), I'm able to click one more time, and have the playhead move to where I clicked, but *only* once.

3. The playhead moves as expected when playing without me clicking. If I click anywhere while playing though it also only moves on the first click, and not subsequent ones.
Steps To Reproduce1. Import anything into the timeline.
2. Click somewhere on the timeline. The playhead moves to that spot.
3. Click somewhere on the timeline again. The playhead remains where it is.
4. Press space once to play, and once to pause. Go back to step 2.

TagsNo tags attached.
Build/Install MethodBuild Script
Attached Filespng file icon playhead-no-move.png [^] (103,633 bytes) 2012-09-03 03:36

- Relationships

-  Notes
(0008263)
j-b-m (administrator)
2012-09-03 18:24

I did make some changes to the way seeking works, but I cannot repoduce your problem. Does the same problem happen when you click in the timeline ruler? And what about the monitor ruler?
(0008264)
eddrog (developer)
2012-09-03 19:12

I can't reproduce this behaviour either but the blue square is shown where I click immediately (timeline and project monitor) and the playhead moves delayed to the clicked position. Is this desired?

By the way in the project and clip monitor the i/o keys don't work for me. In the timeline I get the desired overlay. Can you reproduce this ?
(0008267)
j-b-m (administrator)
2012-09-04 00:04

Yes, the blue square / playhead delay is a new feature. Previously, when clicking and dragging somewhere in timeline, Kdenlive asked MLT to seek to every position of the cursor, which meant that you sometimes saw the timeline cursor jump back and forth between the position you wanted, and the position where MLT was (trying to catch up all the seek requests).

With the changes (that I copied from Shotcut), the blue square shows the position where you want to seek, while the timeline cursor shows where the MLT engine really is.

Previously, when clicking somewhere there was no reaction until MLT had moved to the seek point. Now, you have an immediate reaction (blue cursor) and the seeking speed is still the same as before (can take some time when working with AVCHD).

However, I can confirm the i/o keys issue, will work on that later.
(0008289)
Zoop (reporter)
2012-09-07 15:23

Problem seems to have gone away for me. Not sure why. Anyway, I think we can close this one down.

- Issue History
Date Modified Username Field Change
2012-09-03 03:36 Zoop New Issue
2012-09-03 03:36 Zoop File Added: playhead-no-move.png
2012-09-03 18:24 j-b-m Note Added: 0008263
2012-09-03 18:24 j-b-m Assigned To => j-b-m
2012-09-03 18:24 j-b-m Status new => feedback
2012-09-03 19:12 eddrog Note Added: 0008264
2012-09-04 00:04 j-b-m Note Added: 0008267
2012-09-07 15:23 Zoop Note Added: 0008289
2012-09-07 15:23 Zoop Status feedback => assigned
2012-09-07 15:27 j-b-m Status assigned => resolved
2012-09-07 15:27 j-b-m Fixed in Version => Recent git
2012-09-07 15:27 j-b-m Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker