Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000272KdenliveUser Interfacepublic2008-10-23 20:172008-12-29 15:37
Reportermadsdyd 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.7.1Fixed in Version0.7.1 
Summary0000272: Add or delete timeline track
DescriptionOn the roadmap for kdenlive 0.7.1: http://www.kdenlive.org/roadmap [^] [^]
 
Implement the ability to add and remove tracks to the timeline.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files? file icon kbw.gdb.output.sze17768 [^] (20,722 bytes) 2008-12-07 11:28

- Relationships
parent of 0000331closedGranjow Video and Audio tracks naming and behaviour 
parent of 0000332closed Send audio from video tracks to dedicated audio track 
parent of 0000397acknowledged Difficult to select keyframes for volume-effect 
parent of 0000452closed Add track creates a crash every time 
has duplicate 0000186closed Insert track and delete track has no effect 
related to 0000015closed Freezes upon deleting a track 
child of 0000380closedadministrator Vertical timeline zoom 
Not all the children of this issue are yet resolved or closed.

-  Notes
(0001558)
madsdyd (administrator)
2008-12-07 11:25

There have been some changes in commits up to 2757 (which I am testing with).

2757 allows to add and remove tracks in the timeline. Seems to be working, but I have found at least some issues:

a) You can not change the number of tracks through the "project settings" dialog. It either does not work, or crash. (Attaching crash log shortly).

Steps to reproduce:

- start kdenlive
- select Project|Project settings
- increase the number of both video and audio tracks by one
- click OK
- crash (on my system).

The backtrack looks weird, and it might be some kind of Qt issue again (like 0000314, which is hard to reproduce outside my system).

However, if I only add a single video track, I do not get a crash, but it will not turn up in the timeline.

Likewise, if I add a video/audio track in the timeline, it does not show in the project settings dialog.

b) Tracks are not actually inserted where I would expect them, when using *after*

Steps to reproduce

- start kdenlive.
- in the timeline/track overview, click add track
- add an *audio* track *after* track 0: The track is inserted as the first track!

c) Extra tracks are not realiably saved to the project file.

Steps to reproduce:

- start kdenlive
- add an audio track before track 0. Track order is: avvvaa
- save the project
- stop kdenlive
- start kdenlive
- load the project from before: Track order is vvvvaa != avvvaa

Given the above, I think this functionality still needs a little bit of work.
(0001559)
madsdyd (administrator)
2008-12-07 11:27

Reminder sent to: administrator

I have now finally been able to look at this issue, sorry about the delay. I have found some problems, which I have described in a note.
(0001561)
madsdyd (administrator)
2008-12-07 17:02

commit 2759 appears to fix issue a and b, but c appears to remain.
(0001579)
madsdyd (administrator)
2008-12-08 21:06

Commit 2764 is marked as a cleanup of track handling, but issue c remains.
(0001602)
cinephiliac (updater)
2008-12-10 22:02

SVN 2766 seems to be designed to fix this, however I am currently unable to confirm if it does or not because of issue 0000452.
(0001619)
cinephiliac (updater)
2008-12-12 21:51

Confirmed fixed in 2775

- Issue History
Date Modified Username Field Change
2008-10-23 20:17 madsdyd New Issue
2008-10-23 20:17 madsdyd Status new => acknowledged
2008-10-23 20:18 madsdyd Relationship added has duplicate 0000186
2008-10-23 20:20 madsdyd Relationship added related to 0000015
2008-11-10 16:24 madsdyd Relationship added parent of 0000331
2008-11-10 16:25 madsdyd Relationship added parent of 0000332
2008-11-21 08:52 madsdyd Relationship added child of 0000380
2008-11-23 19:05 cinephiliac Relationship added parent of 0000397
2008-12-07 11:25 madsdyd Note Added: 0001558
2008-12-07 11:27 madsdyd Note Added: 0001559
2008-12-07 11:28 madsdyd File Added: kbw.gdb.output.sze17768
2008-12-07 17:02 madsdyd Note Added: 0001561
2008-12-08 21:06 madsdyd Note Added: 0001579
2008-12-10 22:00 cinephiliac Relationship added related to 0000452
2008-12-10 22:01 cinephiliac Relationship deleted related to 0000452
2008-12-10 22:01 cinephiliac Relationship added parent of 0000452
2008-12-10 22:02 cinephiliac Note Added: 0001602
2008-12-12 21:51 cinephiliac Build/Install Method => Build Wizard
2008-12-12 21:51 cinephiliac Note Added: 0001619
2008-12-12 21:51 cinephiliac Status acknowledged => resolved
2008-12-12 21:51 cinephiliac Resolution open => fixed
2008-12-22 22:12 madsdyd Fixed in Version => Recent git
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker