Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000277KdenliveUser Interfacepublic2008-10-23 23:052010-09-14 23:29
Reportermadsdyd 
Assigned Toddennedy 
PrioritylowSeveritycrashReproducibilitysometimes
StatusclosedResolutionsuspended 
PlatformLinuxOSKubuntuOS Version8.04
Product Version 
Target VersionFixed in Version 
Summary0000277: Crash when pressing play on empty project right after start
DescriptionIf I start kdenlive, and as the first thing, press "play" on the project monitor, it will sometimes crash. Crash log attached.

I think there is a race condition, or something, as its a pthread_mutex that gets killed. This laptop has two cores, so it may require a multicore to get the problem. More info in the crash log.
TagsNo tags attached.
Build/Install Method
Attached Files? file icon kbw.gdb.output.hkEI3266 [^] (24,875 bytes) 2008-10-23 23:05
? file icon kbw.gdb.output.SMvc2099 [^] (21,135 bytes) 2008-12-30 00:29

- Relationships

-  Notes
(0000729)
repli2dev (reporter)
2008-10-28 14:27

I am not having this problem.
Dualcore x86_64 system, Kdenlive SVN 2581
(0000741)
madsdyd (administrator)
2008-10-28 23:33

I can still reproduce in 2585, but I had to try four times to do it.
(0000766)
madsdyd (administrator)
2008-10-30 09:01

Removing target version for this one, as it is probably a mistake to set a target version for an unconfirmed issue. (I still think it is real :-)
(0000782)
cinephiliac (updater)
2008-10-31 01:51
edited on: 2008-11-10 01:57

Not reproducable on my system with:

OS: Kubuntu 8.10 i386 version
VIDEO: ATI HD4850 (w fglrx Ubuntu 8.10 version)
CPU: Single core Intel 32 bit CPU.

Kdenlive Builder Wizard version: 0.6.1
ffmpeg: Revision: 15796 Last Changed Date: 2008-11-08 14:47:10 -0500 (Sat, 08 Nov 2008)
mlt: Revision: 1232 Last Changed Date: 2008-11-09 00:30:39 -0500 (Sun, 09 Nov 2008)
mlt++: Revision: 1232 Last Changed Date: 2008-11-06 00:32:23 -0500 (Thu, 06 Nov 2008)
kdenlive: Revision: 2637 Last Changed Date: 2008-11-08 19:32:25 -0500 (Sat, 08 Nov 2008)
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)



Even after trying 10-12 times in a row.

(0000943)
ddennedy (developer)
2008-11-09 02:54

according to log, this is occurring in MLT, but unable to reproduce on my 32-bit dual core. I can test it on my dual core x86-64 system soon.
(0000957)
madsdyd (administrator)
2008-11-09 11:04

Can still reproduce in

ffmpeg: Revision: 15796 Last Changed Date: 2008-11-08 20:47:10 +0100 (lør, 08 nov 2008)
mlt: Revision: 1229 Last Changed Date: 2008-11-08 21:05:37 +0100 (lør, 08 nov 2008)
mlt++: Revision: 1229 Last Changed Date: 2008-11-06 06:32:23 +0100 (tor, 06 nov 2008)
kdenlive: Revision: 2636 Last Changed Date: 2008-11-08 15:03:51 +0100 (lør, 08 nov 2008)

Essentially the same log.

Had to try four times again.
(0001007)
cinephiliac (updater)
2008-11-10 01:54

Acknowledging as seems to be reproducible by Mads at least.

Would be worth getting more detailed info from everyone on their setups to isolate if it's setup specific.

I've updated my specs above accordingly.
(0001775)
xzhayon (developer)
2008-12-18 00:11

i can't reproduce this

os: freebsd 7-stable
cpu: intel core duo (32 bit)
video: intel 82945gm

ffmpeg rev 14424
mlt rev 1265
mlt++ rev 1265
kdenlive rev 2803
(0001973)
madsdyd (administrator)
2008-12-30 00:31

I can still reproduce on my intel 32 bit cual core system, running kubuntu 8.04, on these versions (took two tries):

Kdenlive was installed by Kdenlive Builder Wizard 0.7.1
Information about revisions of modules at the time of compilation:
ffmpeg: Revision: 16391 Last Changed Date: 2008-12-29 18:14:30 +0100 (Mon, 29 Dec 2008)
mlt: Revision: 1300 Last Changed Date: 2008-12-29 21:54:04 +0100 (Mon, 29 Dec 2008)
mlt++: Revision: 1300 Last Changed Date: 2008-12-29 00:35:06 +0100 (Mon, 29 Dec 2008)
kdenlive: Revision: 2859 Last Changed Date: 2008-12-29 14:18:51 +0100 (Mon, 29 Dec 2008)

However, I do not think this should be "acknowledged", when noone else can reproduce. So, I reluctantly put it back into feedback.
(0002570)
rouge568 (reporter)
2009-03-20 17:38
edited on: 2009-03-20 17:51

I can reproduce here.
Kdenlive 0.7.2.1 , using the Ubuntu 8.10 alternate repository. (http://ppa.launchpad.net/baudm/ubuntu [^])

OS: Kubuntu 8.10 i386
VIDEO: nvidia 177.82 driver
CPU: Intel Dual Core 32bit

(0002733)
sunab (developer)
2009-04-14 22:23

feedback : can 't reproduce this bug, all seems to be fine with :

os : ubuntu 9.04 64bits beta
cpu : intel core2duo
video : virtualbox guest driver 2.2.0

ffmpeg rev.17737
mlt rev.1401
kdenlive rev.3292
(0003280)
xzhayon (developer)
2009-06-18 01:28

no way to reproduce it on rev. 3566
mads, what about you?
(0005006)
LeHomard (developer)
2010-04-10 22:10

Is the issue still present with version 0.7.7 or latest svn ? If the issue isn't confirmed I'll go ahead and close the bug report.
(0005019)
rouge568 (reporter)
2010-04-11 16:31

I no longer have this issue with an update to 0.7.7. Unless someone else can reproduce, this bug can be safely closed.
(0005039)
ddennedy (developer)
2010-04-16 05:24

fixed itself.

- Issue History
Date Modified Username Field Change
2008-10-23 23:05 madsdyd New Issue
2008-10-23 23:05 madsdyd File Added: kbw.gdb.output.hkEI3266
2008-10-28 14:27 repli2dev Note Added: 0000729
2008-10-28 23:33 madsdyd Note Added: 0000741
2008-10-30 09:00 madsdyd Target Version 0.7.0 => 0.7.1
2008-10-30 09:01 madsdyd Note Added: 0000766
2008-10-30 09:01 madsdyd Target Version 0.7.1 =>
2008-10-31 01:51 cinephiliac Note Added: 0000782
2008-10-31 17:33 cinephiliac Note Added: 0000788
2008-11-06 07:11 cinephiliac Note Edited: 0000782
2008-11-06 07:11 cinephiliac Note Deleted: 0000788
2008-11-09 02:54 ddennedy Note Added: 0000943
2008-11-09 06:54 cinephiliac Note Edited: 0000782
2008-11-09 11:04 madsdyd Note Added: 0000957
2008-11-10 01:54 cinephiliac Note Added: 0001007
2008-11-10 01:54 cinephiliac Status new => acknowledged
2008-11-10 01:55 cinephiliac Note Edited: 0000782
2008-11-10 01:57 cinephiliac Note Edited: 0000782
2008-11-12 22:32 madsdyd Target Version => 0.7.1
2008-11-17 20:54 madsdyd Target Version 0.7.1 => future version
2008-12-18 00:11 xzhayon Note Added: 0001775
2008-12-30 00:29 madsdyd File Added: kbw.gdb.output.SMvc2099
2008-12-30 00:31 madsdyd Note Added: 0001973
2008-12-30 00:31 madsdyd Status acknowledged => feedback
2009-03-20 17:38 rouge568 Note Added: 0002570
2009-03-20 17:45 rouge568 Note Edited: 0002570
2009-03-20 17:51 rouge568 Note Edited: 0002570
2009-04-14 22:23 sunab Note Added: 0002733
2009-06-18 01:28 xzhayon Note Added: 0003280
2010-04-10 22:10 LeHomard Note Added: 0005006
2010-04-11 16:31 rouge568 Note Added: 0005019
2010-04-16 05:24 ddennedy Note Added: 0005039
2010-04-16 05:24 ddennedy Status feedback => resolved
2010-04-16 05:24 ddennedy Resolution open => suspended
2010-04-16 05:24 ddennedy Assigned To => ddennedy
2010-09-14 23:29 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker