Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000283KdenliveUser Interfacepublic2008-10-27 12:132010-09-22 17:54
Reporteraspiers 
Assigned ToGranjow 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.8Fixed in Version0.7.8 
Summary0000283: crash when Split view selected in Project Monitor window
DescriptionI simply selected Split view in the Project Monitor window and kdenlive crashed. Attaching debug...
TagsNo tags attached.
Build/Install Method
Attached Files? file icon kbw.gdb.output.GjROa2Iq [^] (72,229 bytes) 2008-10-27 12:13
? file icon kbw.gdb.output.IUR10001 [^] (50,668 bytes) 2008-10-28 11:02

- Relationships

-  Notes
(0000708)
aspiers (reporter)
2008-10-27 12:14

Worth noting that this was with the same 832x604 custom project settings I have been using when submitting several other bugs.
(0000723)
madsdyd (administrator)
2008-10-28 11:00

Confirmed.

Steps to reproduce (deduced from reading the backtrace, and confirmed locally):

- start kdenlive
- add two different clips to the timeline, with an overlap
- add a composite transition
- at the end of the composite transition, add a keyframe with a opacity of 0
- move to about the center of the transition in the project monitor
- right click monitor, select split view: instant-crash(tm)

versions:
ffmpeg: Revision: 15732 Last Changed Date: 2008-10-28 06:37:02 +0100 (tir, 28 okt 2008)
mlt: Revision: 1208 Last Changed Date: 2008-10-28 00:58:39 +0100 (tir, 28 okt 2008)
mlt++: Revision: 1208 Last Changed Date: 2008-10-25 21:05:12 +0200 (lør, 25 okt 2008)
kdenlive: Revision: 2580 Last Changed Date: 2008-10-28 01:34:22 +0100 (tir, 28 okt 2008)

The crash happens two level deep in an inline function in mlt, so, my backtrace is slightly different, but the same neighbourhood. (Will be attaching shortly.)

Btw: What good is the splitview for anyway?
(0001095)
cinephiliac (updater)
2008-11-11 07:25
edited on: 2008-11-11 07:25

Hmmm... I don't see any crash on 0002665, but then again I don't see split view actually doing anything. :? I'm assuming the idea is to be able to have clip / project / record monitors in different windows, or then again maybe it's the gui to switch on dual monitor support.

Can any dev answer, what is splitview is?

(0001106)
administrator (administrator)
2008-11-11 10:46

Split view splits the project monitor in 4 areas, and each area shows one track, so you can see up to 4 tracks on the same view, can be usefull for syncro purposes
(0001125)
madsdyd (administrator)
2008-11-11 23:52

This issue still exists in

ffmpeg: Revision: 15802 Last Changed Date: 2008-11-11 19:50:38 +0100 (tir, 11 nov 2008)
mlt: Revision: 1234 Last Changed Date: 2008-11-11 08:05:14 +0100 (tir, 11 nov 2008)
mlt++: Revision: 1234 Last Changed Date: 2008-11-06 06:32:23 +0100 (tor, 06 nov 2008)
kdenlive: Revision: 2684 Last Changed Date: 2008-11-11 23:04:00 +0100 (tir, 11 nov 2008)
(0004953)
Granjow (developer)
2010-04-10 12:52

Could not reproduce here; could you please check whether this bug is still valid?
(0005022)
aspiers (reporter)
2010-04-11 22:16

Sorry - don't have time to do this any time soon :-(
(0005181)
xzhayon (developer)
2010-05-20 10:17

i cannot reproduce it, and since the bug was last confirmed lots of things changed

granjow: i suggest closing this
(0005199)
Granjow (developer)
2010-05-24 11:45

Aye, closing :)
Feel free to re-open if magically reproducible again.

- Issue History
Date Modified Username Field Change
2008-10-27 12:13 aspiers New Issue
2008-10-27 12:13 aspiers File Added: kbw.gdb.output.GjROa2Iq
2008-10-27 12:14 aspiers Note Added: 0000708
2008-10-28 11:00 madsdyd Note Added: 0000723
2008-10-28 11:00 madsdyd Status new => acknowledged
2008-10-28 11:02 madsdyd File Added: kbw.gdb.output.IUR10001
2008-10-28 11:02 madsdyd Target Version => 0.7.1
2008-11-11 07:25 cinephiliac Note Added: 0001095
2008-11-11 07:25 cinephiliac Note Edited: 0001095
2008-11-11 10:46 administrator Note Added: 0001106
2008-11-11 23:52 madsdyd Note Added: 0001125
2008-11-17 20:54 madsdyd Target Version 0.7.1 => future version
2010-04-10 12:52 Granjow Note Added: 0004953
2010-04-10 12:52 Granjow Assigned To => Granjow
2010-04-10 12:52 Granjow Status acknowledged => feedback
2010-04-10 13:33 Granjow Tag Attached: old
2010-04-11 22:16 aspiers Note Added: 0005022
2010-04-11 22:16 aspiers Status feedback => assigned
2010-05-20 10:17 xzhayon Note Added: 0005181
2010-05-24 11:45 Granjow Note Added: 0005199
2010-05-24 11:45 Granjow Status assigned => resolved
2010-05-24 11:45 Granjow Fixed in Version => Recent git
2010-05-24 11:45 Granjow Resolution open => unable to reproduce
2010-05-28 18:15 Granjow Tag Detached: old
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:01 j-b-m Status resolved => closed
2010-09-22 17:54 Granjow Target Version future version => 0.7.8


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker