Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002870KdenliveUser Interfacepublic2012-12-11 15:572013-01-28 19:51
Reporterevorster 
Assigned Toeddrog 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSLinuxOS Version3.4.20
Product VersionRecent git 
Target VersionFixed in Version0.9.4 
Summary0002870: Video playback in preview window hangs interface
DescriptionRecently ( last couple of weeks ) the playback of video clips would freeze the interface completely.
Steps To ReproduceLoad a couple of clips into kdenlive.
Click on one to get it to display in the preview window.
Let it play until the end.
Click close to the end, let it play to the end again.
Do this a few times.
The UI will hang after a few playbacks to the end of the clip.
Additional InformationI have noticed this on footage from various cameras. I have only been using 50fps profiles, so I don't know if it occurs on others.

I have not been able to reproduce this error with only one clip loaded into the project, maybe I have not been persistent enough. It does seem to happen more often with a large number of clips loaded.

I have been running it through gdb, and it does not show a segfault, also, cpu usage drops as if no button was clicked.

I am able to exit from the UI by clicking on the "x", and waiting for kde to kill it.

TagsNo tags attached.
Build/Install MethodManual build from Git
Attached Files

- Relationships

-  Notes
(0008742)
evorster (reporter)
2012-12-12 06:24

This issue is still bugging me.
If one uses clips with white noise in the audio channel, there are some more hints of what is going on.

When any clip, or portion of a clip ( even on the timeline ) plays to the end, the last frame's sound is played over and over again, like a stuck record, sounding a little like: tsk-tsk-tsk-tsk

If you click in the slider bar and pull back the video a little, and click the video playback button, the sound stops, and hitting the button starts playback again. If one selects another clip while the tsk-tsk-tsk sound is playing.... then the UI hangs, and one needs to close kdenlive.

My audio backend is gst-streamer, and kdenlive is set up to output to ALSA. This combination has worked pretty well for me for a long time, and allows me to listen to music, and get sound on web pages all the while doing editing.

-Evert-
(0008755)
eddrog (developer)
2012-12-12 21:29

I can reproduce! There is something in reaching eof => crazy sound. Trying several times hanging => crash!
(0008767)
evorster (reporter)
2012-12-13 05:32

I managed to crash kdenlive with the crazy sound still going. There was one kdenlive process still running:
evert 10180 3017 0 Dec12 ? 00:03:37 /usr/bin/kdenlive --icon kdenlive -caption Kdenlive

When I killed it, the sound stopped. Hope this provides a clue?

P.S. I am VERY glad that this is not isolated to me only....
(0008795)
eddrog (developer)
2012-12-15 18:26

Ok I found it. This behaviour was introduced with commit (Improve stop handling in mlt_consumer) e33dedb46c0e4786023e1fe0a618e3f4a35728ae in MLT.

Trying to find solution.
(0008797)
eddrog (developer)
2012-12-15 18:51

The hanging on reaching eof is reproducable with melt (sdl_preview). I found the change causing the problem but I think Dan has to look at it because it is in the deep of mlt framework.
(0008800)
eddrog (developer)
2012-12-16 12:52

Is fixed in recent MLT git.

Feedback is appreciated!
(0008801)
evorster (reporter)
2012-12-16 16:01

Fix confirmed. Good job!

- Issue History
Date Modified Username Field Change
2012-12-11 15:57 evorster New Issue
2012-12-12 06:24 evorster Note Added: 0008742
2012-12-12 21:29 eddrog Note Added: 0008755
2012-12-12 21:29 eddrog Assigned To => eddrog
2012-12-12 21:29 eddrog Status new => acknowledged
2012-12-13 05:32 evorster Note Added: 0008767
2012-12-15 18:26 eddrog Note Added: 0008795
2012-12-15 18:51 eddrog Note Added: 0008797
2012-12-16 12:52 eddrog Note Added: 0008800
2012-12-16 12:53 eddrog Status acknowledged => feedback
2012-12-16 16:01 evorster Note Added: 0008801
2012-12-16 16:01 evorster Status feedback => assigned
2012-12-16 17:37 eddrog Status assigned => resolved
2012-12-16 17:37 eddrog Fixed in Version => Recent git
2012-12-16 17:37 eddrog Resolution open => fixed
2013-01-28 19:49 j-b-m Fixed in Version Recent git => 0.9.4
2013-01-28 19:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker