Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002905KdenliveUser Interfacepublic2012-12-27 14:402013-04-07 08:45
Reportereddrog 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
Platform64 bitOSUbuntuOS Version12.10
Product VersionRecent git 
Target VersionRecent gitFixed in Version0.9.6 
Summary0002905: Timeline corruption on moving clips in timeline
Description1) Moving clip (fast?) in timeline sometimes causes timeline corruption. To reproduce this bug is very hard and the solution is only possible in an analytic way :-((

2) Moving clip to locked tracks should be forbidden and impossible => no input for timeline corruption.
Steps To Reproduce1) add clip(s) into timeline
2) move clip (fast) in one track or between tracks
TagsNo tags attached.
Build/Install MethodBuild Script
Attached Files

- Relationships

-  Notes
(0008920)
j-b-m (administrator)
2012-12-28 13:04

I just fixed the locked track bug, and several issues in group move. Also I fixed a recent regression causing timeline corruption when moving a group containing a clip with slowmotion effect.

Maybe these fixes will solve the problem reported.
(0008922)
eddrog (developer)
2012-12-28 16:20

>> I just fixed the locked track bug => fixed

great and thanx. I think so it is absolutely clean. Locked is locked :-))

I'm working on a project now and I merged to current git. I think this is a good test for timeline corruption issues. If I find anythink I'll be loud!
(0008926)
eddrog (developer)
2012-12-28 21:43

@j-b-m: hi there is another issue - it is possible to add clip/sound in track free area at the bottom => timeline corruption. I think it should be forbidden like locked tracks.
(0008927)
eddrog (developer)
2012-12-28 21:46

@j-b-m: it is possible to add clips/sound to locked tracks if you drag'&'drop it from project view. Should be forbidden like move clips in timeline into locked tracks.
(0008929)
j-b-m (administrator)
2012-12-28 22:06

Should be fixed now, thanks
(0008930)
eddrog (developer)
2012-12-28 22:53

>> @j-b-m: it is possible to add clips/sound to locked tracks if you drag'&'drop it from project view. Should be forbidden like move clips in timeline into locked tracks.

Still possible :-(((
(0008931)
eddrog (developer)
2012-12-28 23:44

@j-b-m: there is a regression if you want to add a clip from project view into timeline under an existing clip in timeline => very strange behaviour and timeline corruption. Clips disappear and so on ...
(0008932)
j-b-m (administrator)
2012-12-29 11:03

I just fixed the locked track and outside of tracks problem. I cannot reproduce the issue in your last comment. Can you test with latest git and give me more infos?
(0008975)
eddrog (developer)
2012-12-31 10:11

>> I cannot reproduce the issue in your last comment.

The beer was tasty and it was very late :-))). Ok now I can not reproduce it either.

The other points work so far but I want to do some more tests while working an a project.
(0009188)
eddrog (developer)
2013-02-05 18:09

Looks good.

- Issue History
Date Modified Username Field Change
2012-12-27 14:40 eddrog New Issue
2012-12-27 14:40 eddrog Status new => assigned
2012-12-27 14:40 eddrog Assigned To => j-b-m
2012-12-28 13:04 j-b-m Note Added: 0008920
2012-12-28 13:04 j-b-m Status assigned => feedback
2012-12-28 16:20 eddrog Note Added: 0008922
2012-12-28 16:20 eddrog Status feedback => assigned
2012-12-28 21:43 eddrog Note Added: 0008926
2012-12-28 21:46 eddrog Note Added: 0008927
2012-12-28 22:06 j-b-m Note Added: 0008929
2012-12-28 22:53 eddrog Note Added: 0008930
2012-12-28 23:44 eddrog Note Added: 0008931
2012-12-29 11:03 j-b-m Note Added: 0008932
2012-12-31 10:11 eddrog Note Added: 0008975
2013-02-05 18:09 eddrog Note Added: 0009188
2013-02-05 18:09 eddrog Status assigned => resolved
2013-02-05 18:09 eddrog Resolution open => fixed
2013-04-07 08:45 j-b-m Fixed in Version => 0.9.6
2013-04-07 08:45 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker