Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002955KdenliveUser Interfacepublic2013-01-24 11:452013-04-07 08:45
Reporterttguy 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntuOS Version12.04
Product Version 
Target VersionFixed in Version0.9.6 
Summary0002955: Stabilize transcode - maxangle parameter - crazy max value allowed
DescriptionIn Stabilize transcode there is a maxangle parameter which means "maximum angle to rotate - in radians. default = -1 which means no limit"

At the moment kdnelive allows min -1 and max 1000 on this parameter.

But this is not sensible. If kdenlive passes the values entered off to stabilize unchanged then the sensible maximum would either be 3.142 radians (180 degrees ) or 6.28 radians (360 degrees)

But 1000 radians is a bit crazy.

I would suggest making the range -1 to 360 and having kdenlive pass -1 straight through to stabilize to make it run with "no limit" but for values 0 to 360 convert this from degrees to radians before passing it on to stabilize.

This would make the maxangle a bit more consistent with other bits of kdenlive where the units are in degrees (well fractions of degrees at least).
You could make the units 10ths of degrees I guess - consistent with the rotate units in the affine transition. ie min -1 max 3600

This brings up the issue of consistency of units. Because I have also noted that the units of tilt on the alpha shapes in in 1000ths of a full circle ie 500 tilt units = 180 degrees.

Some work maybe could be done to improve consistency of angle measurement in kdenlive. It would make the project a bit more professional.
Additional Informationkdenlive 0.9.3+git20130117.91ea0353-0ubuntu0~sunab~precise1
mlt 0.8.7+git20130109.ba392dac-0ubuntu0~sunab~precise1
frei0r 1.3.0+git20130119.c3fdd674-0ubuntu0~sunab~precise1
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships

-  Notes
(0009117)
ttguy (reporter)
2013-01-24 12:13

Discussed in this http://www.kdenlive.org/forum/stabilize-transcode-option-maxangle [^] thread
(0009383)
ttguy (reporter)
2013-03-14 12:59

So I figured that this is a issue on the MLT side.
And apparently Dan Dennedy has fixed this on http://sourceforge.net/p/mlt/bugs/189/ [^] git commit 41d044a so that the max angle is 3.142 radians.
This will probably mean the Kdenlive GUI for this will need to be changed to reflect the new max value of 3.142 radians (rather than the 1000 that is the max in the kdenlive GUI at the moment)
(0009446)
j-b-m (administrator)
2013-03-31 21:13

Ok, I now fixed the Kdenlive UI. I also sent a patch for MLT since the maxangle param seems to be retrieved as an integer in MLT.

- Issue History
Date Modified Username Field Change
2013-01-24 11:45 ttguy New Issue
2013-01-24 12:13 ttguy Note Added: 0009117
2013-03-14 12:59 ttguy Note Added: 0009383
2013-03-31 21:13 j-b-m Note Added: 0009446
2013-03-31 21:13 j-b-m Status new => resolved
2013-03-31 21:13 j-b-m Fixed in Version => Recent git
2013-03-31 21:13 j-b-m Resolution open => fixed
2013-03-31 21:13 j-b-m Assigned To => j-b-m
2013-04-07 08:45 j-b-m Fixed in Version Recent git => 0.9.6
2013-04-07 08:45 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker