Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002963KdenliveEffectspublic2013-02-01 12:362013-04-07 08:45
Reporterstophel 
Assigned Toddennedy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bit intel and alikeOSOpenSUSEOS Version12.2
Product VersionRecent git 
Target VersionFixed in Version0.9.6 
Summary0002963: Speed effect makes kdenlive crash
Descriptionadding speed effect to video clip, set speed >100%; then play -> kdenlive crashes
Steps To Reproduceadding speed effect to video clip, set speed >100%; then play -> kdenlive crashes
Additional Informationapplies also to 0.9.4
TagsNo tags attached.
Build/Install MethodBuild Script
Attached Files

- Relationships
has duplicate 0003051assignedj-b-m Crash when changing Position or doing playback after loading of project created with 0.9.2 

-  Notes
(0009249)
Scary Hallo (reporter)
2013-02-10 16:37

Same here on Ubuntu 12.04 KXStudio 64-bit
Kdenlive 9.4.0
It also crashes at speeds < 100%
(0009254)
j-b-m (administrator)
2013-02-11 18:48

I cannot reproduce. Can someone create a backtrace so that I can understand what is going on?

Check section 3 on that page for instructions on creating a backtrace:
http://kdenlive.org/bug-reports [^]
(0009289)
mupuf (reporter)
2013-02-17 18:45
edited on: 2013-02-17 18:46

I managed to reproduce this issue on Archlinux (64 bits) but with the stable version (0.9.4). It doesn't actually crash when we set a speed different from 100%, it "only" asserts:

Assertion (int64_t)st2->time_base.num*ast2->rate == (int64_t)st2->time_base.den*ast2->scale failed at libavformat/avidec.c:1512

Hope it helps.
Cheers

(0009290)
j-b-m (administrator)
2013-02-17 20:34

Ok, thanks. This seems to be an avi format specific issue. Transcoding the file to another format like mp4 works. I will try to find a workaround for that crash problem.
(0009347)
ddennedy (developer)
2013-02-25 02:29

Fixed in MLT git commit 632008f.
I am not sure what to set "Fixed in Version" to.

- Issue History
Date Modified Username Field Change
2013-02-01 12:36 stophel New Issue
2013-02-10 16:37 Scary Hallo Note Added: 0009249
2013-02-11 18:48 j-b-m Note Added: 0009254
2013-02-11 18:48 j-b-m Assigned To => j-b-m
2013-02-11 18:48 j-b-m Status new => feedback
2013-02-17 18:45 mupuf Note Added: 0009289
2013-02-17 18:46 mupuf Note Edited: 0009289 View Revisions
2013-02-17 20:34 j-b-m Note Added: 0009290
2013-02-17 20:34 j-b-m Status feedback => acknowledged
2013-02-25 02:29 ddennedy Note Added: 0009347
2013-02-25 02:29 ddennedy Status acknowledged => resolved
2013-02-25 02:29 ddennedy Resolution open => fixed
2013-02-25 02:29 ddennedy Assigned To j-b-m => ddennedy
2013-04-06 20:47 j-b-m Relationship added has duplicate 0003051
2013-04-07 08:45 j-b-m Fixed in Version => 0.9.6
2013-04-07 08:45 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker