Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002998KdenliveBuild Systempublic2013-02-24 14:462013-04-07 08:45
ReporterMZ 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSKubuntuOS Version12.04
Product Version0.9.4 
Target VersionFixed in Version0.9.6 
Summary0002998: Crashes randomly
DescriptionKdenlive crashes systematically but randomly and very quickly few seconds after that I add a clip in the timeline.
The proxy is on and I waited until the end of proxy conversion.
Only one clip in the timeline (I had no time to do more...)
I conld not identify a typical action that provokes the crash. It can be no more than just moving along the timeline.
It does not depend on the clip format.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filestxt file icon log-gdb.txt [^] (18,727 bytes) 2013-02-24 18:40 [Show Content]

- Relationships

-  Notes
(0009331)
j-b-m (administrator)
2013-02-24 15:46

To understand what happens, we need a backtrace. You can find instructions on how to create a backtrace on that page:
http://kdenlive.org/bug-reports [^]
Under: "How to get useful crash information (backtrace)"
(0009340)
MZ (reporter)
2013-02-24 18:46

I attached log-gdb.txt.
I think I have only one mlt installed: by typing "locate mlt" I find only one mlt directory : /usr/share/mlt/
and in /var/cache:
/var/cache/apt/archives/libmlt++3_0.8.8-0ubuntu0~sunab~precise1_amd64.deb
/var/cache/apt/archives/libmlt-data_0.8.8-0ubuntu0~sunab~precise1_all.deb
/var/cache/apt/archives/libmlt5_0.8.8-0ubuntu0~sunab~precise1_amd64.deb

Tell me if you need anything else.
Michel
(0009342)
j-b-m (administrator)
2013-02-24 18:58

I think it is caused by this bug in MLT:
http://sourceforge.net/p/mlt/bugs/186/ [^]

The bug was fixed in MLT's current git, so you might want to try sunab's eyperimental PPA that contains latest MLT and Kdenlive from git, might solve your problem.

Instructions for this PPA:
http://kdenlive.org/download-development [^]

Under "Development packages"
(0009346)
MZ (reporter)
2013-02-24 21:29

It solved the problem.
Thank you !

- Issue History
Date Modified Username Field Change
2013-02-24 14:46 MZ New Issue
2013-02-24 15:46 j-b-m Note Added: 0009331
2013-02-24 15:46 j-b-m Assigned To => j-b-m
2013-02-24 15:46 j-b-m Status new => feedback
2013-02-24 18:40 MZ File Added: log-gdb.txt
2013-02-24 18:46 MZ Note Added: 0009340
2013-02-24 18:46 MZ Status feedback => assigned
2013-02-24 18:58 j-b-m Note Added: 0009342
2013-02-24 21:29 MZ Note Added: 0009346
2013-02-24 21:56 j-b-m Status assigned => resolved
2013-02-24 21:56 j-b-m Fixed in Version => Recent git
2013-02-24 21:56 j-b-m Resolution open => fixed
2013-04-07 08:45 j-b-m Fixed in Version Recent git => 0.9.6
2013-04-07 08:45 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker