Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003018KdenliveRenderingpublic2013-03-13 10:282013-04-07 08:45
Reporterttguy 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntuOS Version12.04
Product VersionRecent git 
Target VersionFixed in Version0.9.6 
Summary0003018: trim spaces from end of filename supplied in the Output File field in the render dialog
DescriptionIt would probably be good if the application trimed the string that is entered into the Output File field in the render dialog before processing.

This would prevent the accidental creation of output files where the file name ends in a space. File like this cause a lot of frustration because ...
1. The don't appear under the "supported files" filter when you attempt to add them to project trees.
2. They cause files rendered from them to be "invalid".

Steps To Reproduceenter a space after the end of the file name in the Output File field in the render dialog. Say no to the - do you want to add a file extension?
Render the project.
Note that the resulting file name ends in a space.
TagsNo tags attached.
Build/Install Method(select)
Attached Filespng file icon render_with_space.png [^] (104,348 bytes) 2013-03-13 10:28

- Relationships

-  Notes
(0009379)
ttguy (reporter)
2013-03-13 10:29

See also http://www.kdenlive.org/mantis/view.php?id=3017 [^] about files ending in space causing invalid clips
(0009454)
j-b-m (administrator)
2013-04-01 12:09

Fixed in git

- Issue History
Date Modified Username Field Change
2013-03-13 10:28 ttguy New Issue
2013-03-13 10:28 ttguy File Added: render_with_space.png
2013-03-13 10:29 ttguy Note Added: 0009379
2013-04-01 12:09 j-b-m Note Added: 0009454
2013-04-01 12:09 j-b-m Status new => resolved
2013-04-01 12:09 j-b-m Fixed in Version => Recent git
2013-04-01 12:09 j-b-m Resolution open => fixed
2013-04-01 12:09 j-b-m Assigned To => j-b-m
2013-04-07 08:45 j-b-m Fixed in Version Recent git => 0.9.6
2013-04-07 08:45 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker