Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000031KdenliveUser Interfacepublic2007-11-07 06:072008-10-23 00:22
Reportermgmiller 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000031: No audio within kdenlive playing any kind of clip
DescriptionI have Ubuntu 7.10 with kdenlive installed from the repos. version 0.5.0
I can import .avi or .mp3 or .vob, etc. All the video plays fine, but there is no audio output at all.
If I create a simple test with 2 video clips and a transition and save it as an .avi, the resulting file plays with normal audio in (Totem) movie player.
I have tried changing the audio settings preferences from auto to alsa and to everything else in the list with no results. The audio slider in the preview window is pushed all the way up.
I am unable to hear any kind of audio within the program itself.
TagsNo tags attached.
Build/Install Method
Attached Files

- Relationships

-  Notes
(0000061)
flrtx (reporter)
2007-11-14 18:46

I have exactly the same problem: Ubuntu 7.10, Kdenlive 0.5 (using KDE 3.5.8) and absolutely no sound (besides Knotify).
Its really really anoying because like that I just can't work on my movie...
(0000062)
flrtx (reporter)
2007-11-15 17:32

If I start Kdenlive from a terminal I get the message: SDL failed to open audio: No available audio device

If I trie to configure the audio device in settings -> configure kdenlive -> hardware I have only one choice for the audio device: default.
(0000063)
mgmiller (reporter)
2007-11-16 13:34

I also tried running it from terminal to see what happens. Below is my terminal output for starting the program, importing a clip and trying to play it. The last line gives me the SDL failed message.

marty@tux:~$ kdenlive
X Error: BadDevice, invalid or uninitialized input device 171
  Major opcode: 149
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 171
  Major opcode: 149
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
kdenlive: + + YOUR MLT INSTALL WAS FOUND IN: /usr
kdenlive: Mlt inited
kdenlive: Creating new document
kdenlive: deleting contents...
kdenlive: Creating new document DONE
kdenlive: **************** INIT DOCUMENT VIEW ***************
kdenlive: + + CREATING CONSUMER WITH PROFILE: atsc_1080i_60
kdenlive: + + CREATING CONSUMER WITH PROFILE: atsc_1080i_60
kdenlive: WARNING: Got a request for a changed clip that is not in the document : mvi_0544.avi
kdenlive: *** DOCUMENT adding clip: mvi_0544.avi
SDL failed to open audio: No available audio device
(0000067)
flrtx (reporter)
2007-11-18 19:08
edited on: 2007-11-18 19:09

I get four of these X Errors but besides that my output is more less the same.

I thought that this problem might be caused because of conflicts between two Kdenlive or MLT versions. After updating to Gutsy I removed my kdenlive package (0.5svn...) and then my apt-get told me he had an error with the package mlt. The guys in the IRC-channel told me just to delete this package, because libmlt should be the right packages. So I deleted mlt and mlt++ and installed kdenlive 0.5 from the official sources with libmlt and libmlt++. The sound never worked in this installation. So perhaps there is still something wrong with mlt...

What can I do? It would be great if the problem could be fixed soon.

(0000078)
administrator (administrator)
2007-12-02 10:08

This is not really a Kdenlive bug. The problem is that SDL, which is used for sound output, cannot find an available device.

First question:
Do you have the libsdl1.2debian-all package installed ?

Otherwise, it means that the audio device is blocked by another audio system or that the soundcard is not properly configured... Looks like most people experiencing that problem are running Ubuntu. I am myself on a Kubuntu system, and cannot reproduce the bug, so I think it might be related to the gnome sound system config...
(0000081)
mgmiller (reporter)
2007-12-02 13:00

administrator asked:
"First question:
Do you have the libsdl1.2debian-all package installed ?"

I discovered that I had libsdl1.2debian-oss installed. When I installed the -all package, it replaced the -oss package and the audio in kdelive started working.

Now I can really start trying to use this application. Thank you. For the folks running Ubuntu instead of kubuntu, you should consider making the libsdl1.2debian-all package one of the dependencies.

IMHO this application should be considered for inclusion as one of the default programs installed with Ubuntu/Kubuntu.
(0000085)
flrtx (reporter)
2007-12-02 18:26

administrator, thanks a lot.

I installed libsdl1.2debian-all, my Ubuntu deleted libsdl1.2debian-oss and now the kdenlive-sound works better than before. Thanks.

- Issue History
Date Modified Username Field Change
2007-11-07 06:07 mgmiller New Issue
2007-11-14 18:46 flrtx Note Added: 0000061
2007-11-15 17:32 flrtx Note Added: 0000062
2007-11-16 13:34 mgmiller Note Added: 0000063
2007-11-18 19:08 flrtx Note Added: 0000067
2007-11-18 19:09 flrtx Note Edited: 0000067
2007-12-02 10:08 administrator Note Added: 0000078
2007-12-02 13:00 mgmiller Note Added: 0000081
2007-12-02 18:26 flrtx Note Added: 0000085
2007-12-02 20:17 administrator Status new => resolved
2007-12-02 20:17 administrator Resolution open => fixed
2008-10-23 00:22 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker