Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000317KdenliveUser Interfacepublic2008-11-08 16:592010-11-14 22:07
Reporterel_jefe 
Assigned ToGranjow 
PrioritylowSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.6 
Summary0000317: Add default shortcut keys to select Razor/Select/Spacer tool
DescriptionI would love a shortcut keybindings to switch between the various tools in the Tools menu; even better (future releases?) would be to define them but let users change them if they have something they're already accustomed to.

Maybe:
[r] - Razor tool
[s] - selection tool
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships
related to 0000271closed Spacer tool: add and remove space in timeline 
parent of 0001076closedGranjow Remove focus on text input elements when pressing Esc 
has duplicate 0000602closedGranjow Shortcuts for selection/cut/space tools and others 
related to 0000369closed Set section in timeline also by 'I' and 'O' keys as in monitor 
related to 0000370closed enhanced play shortcuts 
child of 0000471assignedmadsdyd Clean up default keyboard shortcuts - add defaults for all applicable actions 

-  Notes
(0000879)
madsdyd (administrator)
2008-11-08 17:05

Acknowledged for 0.7.1

Note, that you can customize your shortcut settings to e.g. the keys you have suggested, so this issue is about defining some sensible default values out of the box.
(0000888)
cinephiliac (updater)
2008-11-08 18:18

Key bindings would be great.

The problem with r and s is that they only make sense in English. Might I suggest using keys that matched the buttons visually by their position. Something like , and . which are in the bottom right of the keyboard, just as the buttons for those tools are in the bottom right corner of the screen.

Also, at the moment it's kind of strange that we call it the *razor* tool, and yet the picture is a pair of *scissors*. I suggest that this tool be renamed something simple and generic such as "Cut tool" or "Slice" but maybe that should be for another report.
(0001465)
madsdyd (administrator)
2008-11-30 21:31

Updated to include also default shortcuts for the spacer tool (which is now partially implemented as of svn rev 2738).
(0001479)
madsdyd (administrator)
2008-12-01 08:10

Adding comment from Cinephiliac:

I would like to suggest regarding the keyboard shotcuts, though. I'd like to propose:
 , for the spacer tool
 . for select
 / for the razor tool (which really should be called cut, as the icon is not a razor)
 
 The icons are easy for anyone in any language to understand and remember. By choosing the three unusual keys, in a similar position on the keyboard to where they are on screen, in the same order as the icons, we make it very easy for anyone of any language to remember. Also a slash for cut/razor visually makes sense.
(0001480)
madsdyd (administrator)
2008-12-01 08:16

A comment to ,./ : "please do not assume anything about the keyboard layout :-)"

http://en.wikipedia.org/wiki/Keyboard_layout [^]
http://commons.wikimedia.org/wiki/Image:Computer_keyboard_with_danish_layout.jpg [^]
http://carbon.cudenver.edu/~tphillip/GermanKeyboardLayout.html [^]
http://en.wikipedia.org/wiki/Image:French_pc_keyboard.svg [^]

The suggestion may be fine though, just do not think that the keys make as much sense on non-us keyboards as on us keyboards...
(0001514)
cinephiliac (updater)
2008-12-03 20:01

Hmm... good point. So a lot of keyboards don't have ,./ in the bottom right. I still think that the main point of not just basing shortcuts on the first letter of the word *in English* makes sense.
(0001570)
madsdyd (administrator)
2008-12-08 09:10

OK, we do have the option of taking two shortcuts for each. How about

"," and ";" for the spacer tool
"." and ":" for the select tool
"/" and "-" for the razor/scissor tool

?
(0002302)
madsdyd (administrator)
2009-01-31 17:04

Moved to 0.7.3
(0003747)
Granjow (developer)
2009-07-30 18:08

Who is against
Ctrl-1: Select
Ctrl-2: Razor
Ctrl-3: Spacer
?
(0003769)
xzhayon (developer)
2009-08-03 12:05

i agree we need these shortcuts. personally i'm not a big fan of ctrl+[number] shortcuts, but i don't mind, and i'm not that good in this thing

i don't dislike your suggestion from 0000471:
"s: Select is okay (like e.g. Inkscape)
x: Razor (x looks like the Razor symbol; r depends on the language)
m: Spacer (for «move»; depends on the language too, but m is also used in Gimp for moving objects.)"
that makes more sense to me: hit just one key for the main tools (and for playing, am i correct?) instead of not so handy combinations (ctrl+3 is not really comfortable)
(0003770)
Granjow (developer)
2009-08-03 12:34

The problem with my suggestion there is localization. Okay for latin keyboards, but as soon as you're using a Greek or Cyrillian keyboard …

Otherwise. We could mark the shortcut key for translation. Yes, why not? That would also be the first step towards a shortcut manager for the settings ;)

Inkscape is using F1 for Select, F2 for the node tool, F3 and so on for other tools. This would be keyboard independant too, but we've already got the Help on F1, therefore I suggested Ctrl-1. But I agree these wouldn't be too handy.

Should I find time today I'd test sxm today.
(0003773)
Granjow (developer)
2009-08-03 16:26

Added in r3798 (sorry mads for taking over the issue :)), is it okay?

- Issue History
Date Modified Username Field Change
2008-11-08 16:59 el_jefe New Issue
2008-11-08 17:05 madsdyd Note Added: 0000879
2008-11-08 17:05 madsdyd Priority normal => low
2008-11-08 17:05 madsdyd Status new => acknowledged
2008-11-08 17:05 madsdyd Target Version => 0.7.1
2008-11-08 18:18 cinephiliac Note Added: 0000888
2008-11-17 20:54 madsdyd Target Version 0.7.1 => future version
2008-11-17 21:14 madsdyd Target Version future version => 0.7.1
2008-11-17 21:14 madsdyd Summary Shortcut keys to select Razor tool/Select tool => Add default shortcut keys to select Razor tool/Select tool
2008-11-19 22:33 cinephiliac Relationship added related to 0000369
2008-11-19 22:38 cinephiliac Relationship added related to 0000370
2008-11-30 21:30 madsdyd Relationship added related to 0000271
2008-11-30 21:31 madsdyd Build/Install Method => Build Wizard
2008-11-30 21:31 madsdyd Note Added: 0001465
2008-11-30 21:31 madsdyd Summary Add default shortcut keys to select Razor tool/Select tool => Add default shortcut keys to select Razor/Select/Spacer tool
2008-12-01 08:10 madsdyd Note Added: 0001479
2008-12-01 08:16 madsdyd Note Added: 0001480
2008-12-03 20:01 cinephiliac Note Added: 0001514
2008-12-08 09:10 madsdyd Note Added: 0001570
2008-12-08 09:10 madsdyd Status acknowledged => assigned
2008-12-08 09:10 madsdyd Assigned To => madsdyd
2008-12-15 11:01 madsdyd Relationship added parent of 0000471
2008-12-29 15:08 madsdyd Target Version 0.7.1 => 0.7.2
2009-01-31 17:04 madsdyd Note Added: 0002302
2009-01-31 17:04 madsdyd Target Version 0.7.2 => 0.7.3
2009-06-17 10:16 Granjow Relationship added has duplicate 0000602
2009-07-30 18:08 Granjow Note Added: 0003747
2009-08-03 12:05 xzhayon Note Added: 0003769
2009-08-03 12:06 xzhayon Target Version 0.7.3 => future version
2009-08-03 12:34 Granjow Note Added: 0003770
2009-08-03 14:49 Granjow Relationship added parent of 0001076
2009-08-03 16:26 Granjow Note Added: 0003773
2010-11-14 22:07 ttill Assigned To madsdyd => Granjow
2010-11-14 22:07 ttill Severity feature => tweak
2010-11-14 22:07 ttill Status assigned => resolved
2010-11-14 22:07 ttill Resolution open => fixed
2010-11-14 22:07 ttill Fixed in Version => 0.7.6
2010-11-14 22:07 ttill Status resolved => closed
2010-11-14 22:08 ttill Relationship replaced child of 0000471


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker