Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003170KdenliveFile Loadingpublic2013-10-01 10:012014-04-14 13:14
Reporterbarade 
Assigned Toj-b-m 
PriorityurgentSeverityblockReproducibilityalways
StatusfeedbackResolutionopen 
Platform64 bitOSGentoo LinuxOS Version2008.0
Product Version0.9.6 
Target VersionFixed in Version 
Summary0003170: Adding h264 clip fails
DescriptionAdding a clip cut with avidemux using the following script:
Editor.closeVideo();
Editor.openVideo("00052.MTS");
Editor.segments.clear()
Editor.segments.add(24560000, 43240000, 0);
Editor.setMarkers(0, 43240000);

Editor.currentVideoEncoder = X264VideoEncoder;
Editor.audioOutputs.clear();

audioOutput = new CopyAudioEncoder();
Editor.audioOutputs.add(0, audioOutput);
Editor.audioOutputs[0].drcEnabled = false;
Editor.audioOutputs[0].timeShift = 0;

Editor.currentMuxer = MkvMuxer;

fails with the following console output:
[matroska,webm @ 0x7f8130212550] decoding for stream 0 failed
[matroska,webm @ 0x7f8130212550] Could not find codec parameters (Video: h264, 1920x1080)

Of course I can play the file using mplayer or vlc.
TagsNo tags attached.
Build/Install Method(select)
Attached Files

- Relationships

-  Notes
(0009619)
barade (reporter)
2013-10-14 16:40

The clip works when using xvid4 encoder in avidemux instead of x264. Maybe this is related to how kdenlive detects valid clips by getting the codec?

For xvid4 encoder the codec is named:
MPEG-4 Video (mp4v)

For x264 (which does not work) it is named:
H264 - MPEG-4 AVC (part 10) (avc1)
(0009991)
j-b-m (administrator)
2014-04-14 13:14

Kdenlive uses MLT as video backend, and MLT relies on FFmpeg or LibAV to do the audio/video encoding/decoding.

You have to check if your FFmpeg or LibAV install supports this clip.

For FFmpeg:
ffplay myclip.mp4

For LibAV:
avplay myclip.mp4

If your LibAV or FFmpeg install does not play the clip, maybe you need to install some extra packages. Ubuntu has some libavcodec-extra packages, I don't know how it works on Gentoo.

- Issue History
Date Modified Username Field Change
2013-10-01 10:01 barade New Issue
2013-10-14 16:40 barade Note Added: 0009619
2014-04-14 13:14 j-b-m Note Added: 0009991
2014-04-14 13:14 j-b-m Assigned To => j-b-m
2014-04-14 13:14 j-b-m Status new => feedback


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker