Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000330KdenliveRenderingpublic2008-11-10 05:572009-07-01 21:57
Reporterkl1278 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.5Fixed in Version0.7.5 
Summary0000330: Crash related to zero length transition
DescriptionI've build kdenlive 0.7, and it's working fine, except for transitions.
No transitions appear during rendering, or in real time display.
I've build kdenlive with the wizardbuilder script on
Ubuntu 8.04
and also on
kubuntu 8.10
Both had the same problem.
TagsNo tags attached.
Build/Install Method(select)
Attached Files? file icon kbw.log.20081110.204126.xWq30899 [^] (100,660 bytes) 2008-11-10 13:10

- Relationships

-  Notes
(0001027)
madsdyd (administrator)
2008-11-10 09:15

Could you please attach a build log?

Are you able to add transitions - and they do just not appear?
(0001030)
kl1278 (reporter)
2008-11-10 13:12

I've uploaded the builder log file.
Yes, I'm able to add transitions, and the rectangular box appears. (but with a question mark in it?) I can resize the transition box and move it around. But when I scroll the timeline marker over the transition, nothing happens in the preview, and neither does it render the transition.
(0001092)
ddennedy (developer)
2008-11-11 06:08

Might be helpful to upload your project file or a screenshot showing the cursor in the middle of the transition on the timeline and showing the preview window.
(0001096)
kl1278 (reporter)
2008-11-11 07:31

I've put two video's online showing the problems:

http://www.vimeo.com/2211629 [^]

http://www.vimeo.com/2211621 [^]
(0001101)
ddennedy (developer)
2008-11-11 08:58

I only got half way through the first one. :-)
Thanks, that was extremely illustrative.

You have to put the clips on separate tracks. The fact that the arrows to insert the transition point downward and the transition block is half over one track and half over another track were supposed to be hints.
(0001102)
ddennedy (developer)
2008-11-11 09:03

Heh, now I just watched the second video. Two more things. You have to make the clips overlap each other a little. Secondly, they have to be neighboring tracks. Once you see it, it will be really obvious how the transition block nicely illustrates the timeline and then it should all just click in your head!
(0001103)
kl1278 (reporter)
2008-11-11 09:16
edited on: 2008-11-11 09:25

You are right, it's working now:)

But, we might have found another bug:
There is a crash happening that is reproducible and that is
happening in the video I posted as well:
Put a video on track one,
Another on track two, not overlapping with the first one, but right 'next' to
it. Add a transition in the first one.
Now, nothing visible appears. However, when one moves both video's out of the way,
one can see the transition as a little vertical line. If you try to remove it kdenlive crashes.

edit: in this video you can see the crash happening
http://www.vimeo.com/2211621 [^]

edit2: for some reason vimeo doesn't display this video correctly, however,
if you download it from the link on the same page it is possible to view it.

(0001114)
ddennedy (developer)
2008-11-11 18:44

madsdyd: please change the summary and description for the segfault bug
(0001123)
madsdyd (administrator)
2008-11-11 23:45

Status changed by request from Dan.
(0003279)
xzhayon (developer)
2009-06-18 01:26

i can't reproduce this on rev. 3566, the shortest transition i can make is one frame long
a lots of fixes were made to transitions, if no one can confirm this in a week i'm going to close it
(0003497)
xzhayon (developer)
2009-06-27 09:11

must have been fixed then

- Issue History
Date Modified Username Field Change
2008-11-10 05:57 kl1278 New Issue
2008-11-10 09:15 madsdyd Note Added: 0001027
2008-11-10 09:15 madsdyd Status new => feedback
2008-11-10 13:10 kl1278 File Added: kbw.log.20081110.204126.xWq30899
2008-11-10 13:12 kl1278 Note Added: 0001030
2008-11-11 06:08 ddennedy Note Added: 0001092
2008-11-11 07:31 kl1278 Note Added: 0001096
2008-11-11 08:58 ddennedy Note Added: 0001101
2008-11-11 09:03 ddennedy Note Added: 0001102
2008-11-11 09:16 kl1278 Note Added: 0001103
2008-11-11 09:21 kl1278 Note Edited: 0001103
2008-11-11 09:25 kl1278 Note Edited: 0001103
2008-11-11 18:44 ddennedy Note Added: 0001114
2008-11-11 23:45 madsdyd Note Added: 0001123
2008-11-11 23:45 madsdyd Status feedback => acknowledged
2008-11-11 23:45 madsdyd Target Version => 0.7.1
2008-11-11 23:45 madsdyd Summary No changes (transitions) in real time, or rendering. => Crash related to zero length transition
2008-11-17 20:54 madsdyd Target Version 0.7.1 => future version
2009-06-03 06:56 ddennedy Build/Install Method => (select)
2009-06-03 06:56 ddennedy Severity major => crash
2009-06-18 01:26 xzhayon Note Added: 0003279
2009-06-18 01:26 xzhayon Status acknowledged => feedback
2009-06-26 21:13 administrator Target Version future version => 0.7.5
2009-06-27 09:11 xzhayon Note Added: 0003497
2009-06-27 09:11 xzhayon Status feedback => resolved
2009-06-27 09:11 xzhayon Fixed in Version => Recent git
2009-06-27 09:11 xzhayon Resolution open => fixed
2009-06-27 09:11 xzhayon Assigned To => xzhayon
2009-06-27 09:12 xzhayon Assigned To xzhayon =>
2009-07-01 20:02 j-b-m Fixed in Version Recent git => 0.7.5
2009-07-01 21:57 xzhayon Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker