Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000348KdenliveUser Interfacepublic2008-11-14 00:132010-09-14 23:00
Reporterreinhard 
Assigned ToLeHomard 
PrioritylowSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
Platformi386OSlinuxOS Version8.10
Product Version0.7.0 
Target VersionFixed in Version0.7.8 
Summary0000348: Most transitions lack of a 'reverse transition' option.
DescriptionOnly the luma transition has this useful feature, but also the other might need this option as well - at least the wipe transition, I think.
Did not tested 'alpha transparency' so far, due to lack of footage with alpha channel...
Tagseffects, key, transitions
Build/Install Method
Attached Files

- Relationships
duplicate of 0000278closedLeHomard Reverse transitions 

-  Notes
(0001185)
cinephiliac (updater)
2008-11-14 07:24

Setting to an acknowledged wishlist item.

Out of interest, you can effectively reverse Composite and AffineComposite as they are both key generated. Wipe is also easily reversed, as it's options only require 2-4 clicks to set.
(0001217)
reinhard (reporter)
2008-11-14 14:15

ok, but for many, if not most, users this are 1-3 unnecessary clicks too much ;)

But seriously - maybe it would be sufficient to change the default values?

The actual default values (start == right, end == center) can introduce a little bit confusion in a composition like this:
Video 1 (10 sec.) is placed in track 0 from the beginning.
Video 2 (10 sec.) in track 1 starting at 9 sec.
So there is an overlapping area of 1 sec. where the wipe transition is applied.

In this situation the wipe goes from track 1 to track 0 - which collides with my personal logic, since I've expected it to work the other way around, but this is another story ;) - this means that video 1 is played till the beginning of video 2, than it switch to video 2, the wipe starts, but with video 1 as source and after the end of the wipe, where video 1 comes fullscreen again, it finally switch over to video 2.
A little bit too much back and forth for me ;)

So, I would like to suggest to set both default values to center or, the better solution IMHO, kdenlive can hopefully check the arrangement of the clips and choose the default values bases on this check, to avoid this toggle.
(0004969)
LeHomard (developer)
2010-04-10 18:54

In current svn alla animated transitions have a "reverse" option.

- Issue History
Date Modified Username Field Change
2008-11-14 00:13 reinhard New Issue
2008-11-14 07:09 cinephiliac Tag Attached: effects
2008-11-14 07:09 cinephiliac Tag Attached: key
2008-11-14 07:09 cinephiliac Tag Attached: transitions
2008-11-14 07:24 cinephiliac Note Added: 0001185
2008-11-14 07:24 cinephiliac Status new => acknowledged
2008-11-14 07:26 cinephiliac Priority normal => low
2008-11-14 07:26 cinephiliac Severity minor => feature
2008-11-14 07:26 cinephiliac Product Version 0.7.0 beta => 0.7.0
2008-11-14 14:15 reinhard Note Added: 0001217
2008-11-14 15:17 administrator Relationship added duplicate of 0000278
2010-04-10 18:54 LeHomard Note Added: 0004969
2010-04-10 18:54 LeHomard Status acknowledged => resolved
2010-04-10 18:54 LeHomard Fixed in Version => Recent git
2010-04-10 18:54 LeHomard Resolution open => fixed
2010-04-10 18:54 LeHomard Assigned To => LeHomard
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:00 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker