Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000367KdenliveUser Interfacepublic2008-11-19 13:032008-12-29 15:37
Reporterreinhard 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformi386OSlinuxOS Versionkubuntu
Product VersionRecent git 
Target VersionFixed in Version0.7.1 
Summary0000367: Wrong behaviour when moving several clips at once
DescriptionTransitions will be copied or stay/remain at the original position when I select several clips and move them to another track.
Steps To Reproduce- add clip 1 on at the beginning of track 0
- add a luma transition (to black) at the beginning of clip 1
- add clip 2 in track 1 with an overlapped region of 1 sec. , for example
- add another luma transition to this overlapped region
- select all stuff using 'shift + move mouse'
- drag the stuff to another track
Additional InformationIn this example above, the transition at the beginning remain in track 0 and the other transition seems to be copied to track 2.

And also here undo seems not to work as expected:
Sometimes all transitions are gone but sometimes only the first one,...
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files? file icon capture0007.ogv [^] (4,003,732 bytes) 2008-11-20 00:04

- Relationships
related to 0000417closedj-b-m Ctrl selecting multiple clips+transitions moves them to the wrong track erratically 
related to 0000427closedLeHomard different behaviours caused by how to select segments and transitions 
related to 0000421closedLeHomard undo is broken after moving several clips at once like in issue 0000367 

-  Notes
(0001261)
cinephiliac (updater)
2008-11-19 21:47

Hi there Reinhardt,

Thanks for the bug report. Keeping reports to one single issue per report helps us greatly as we don't need to manually split them up. That said, the first part of your report (transitions not moving) is addressed in issue 0000361. We'll assume that this report is mainly about the second part ("Undo not working as expected").

If I understand you correctly, you're saying that when you add transitions, you can use undo to remove all of them but the first one. Is this correct? If it isn't then it would help to provide a step by step guide to creating this problem.

Thanks!

Cinephiliac
(0001262)
cinephiliac (updater)
2008-11-19 21:54

I just tried to reproduce by adding 4 clips with transitions and then clicking undo until they were all gone. This works for me in:
Kdenlive Builder Wizard version: 0.7.0
ffmpeg: Revision: 15884 Last Changed Date: 2008-11-19 09:57:48 -0500 (Wed, 19 Nov 2008)
mlt: Revision: 1240 Last Changed Date: 2008-11-17 00:57:32 -0500 (Mon, 17 Nov 2008)
mlt++: Revision: 1240 Last Changed Date: 2008-11-06 00:32:23 -0500 (Thu, 06 Nov 2008)
kdenlive: Revision: 2716 Last Changed Date: 2008-11-19 06:13:31 -0500 (Wed, 19 Nov 2008)
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)
Kdenlive: 0.7


You can let us know your version by navigating to where your kdenlive_start.sh script is and in the command line typing ./kdenlive_start --version

Cheers

Cinephiliac
(0001271)
reinhard (reporter)
2008-11-20 00:39

Hi,

as I queried in another note:
Can you add 'KBW build' to 'Product Version'?
This way it would be clear how kdenlive was build.

So, to ask your question first - I use latest KBW.

I general, the step by step guide you can find above.
Undo don't work correct AFTER the selected clips and transitions (using 'shift + drag over them with the left mouse button hold down') was moved to another track, in one go.
This means - the clips moved back to the initial tracks, but the transitions are gone.

btw - you can create really crazy stuff (means a lot of copied transitions) when moving the whole group again and again, back and forth and from track to track ;)
(0001273)
cinephiliac (updater)
2008-11-20 04:57

Hi Reinhardt,

OK, I understand what you mean a bit better now. I've also managed to reproduce the problem so we can acknowledge it.


DESCRIPTION:
The problem seems to be that if:
1. Multiple clips with a transition are selected at the same time and
2. They are dragged by the mouse
that they duplicate the clips and transition at random places on the timeline.


STEPS TO REPRODUCE:
1. Import 2 clips on the the timeline overlapping.
2. Add a composite (tested with Luma and AffineComposite)
3. Hold Ctrl and select clips and transition.
4. Drag the selected block to different areas of the timeline.


TESTED ON:
Kdenlive Builder Wizard version: 0.7.0
ffmpeg: Revision: 15883 Last Changed Date: 2008-11-18 20:40:09 -0500 (Tue, 18 Nov 2008)
mlt: Revision: 1240 Last Changed Date: 2008-11-17 00:57:32 -0500 (Mon, 17 Nov 2008)
mlt++: Revision: 1240 Last Changed Date: 2008-11-06 00:32:23 -0500 (Thu, 06 Nov 2008)
kdenlive: Revision: 2716 Last Changed Date: 2008-11-19 06:13:31 -0500 (Wed, 19 Nov 2008)
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)
Kdenlive: 0.7


Regarding version numbers:
The builder wizard builds a different version depending on when you run it. It always creates the most up to date version. Because we have no way of knowing what day and time you ran the builder wizard, the version numbers are important.

You can also find the version numbers by:
1. Running the wizard again
2. Clicking next to get to the screen that shows version numbers
3. Clicking "Update" to make sure it's up to date.


Now we've got that info, let's see if we can get this fixed. :)
(0001418)
cinephiliac (updater)
2008-11-26 04:05

Fixed and tested in revision 0002732.

Awesome. :)
(0001420)
cinephiliac (updater)
2008-11-26 04:13

Oh, and you'll notice there's a dropdown now for "Install method" separate from the "Version" one which includes "KBW". :) I'd love to take credit, but I suspect you have Mads to thank for that one...

- Issue History
Date Modified Username Field Change
2008-11-19 13:03 reinhard New Issue
2008-11-19 21:47 cinephiliac Note Added: 0001261
2008-11-19 21:47 cinephiliac Status new => feedback
2008-11-19 21:54 cinephiliac Note Added: 0001262
2008-11-20 00:04 reinhard File Added: capture0007.ogv
2008-11-20 00:39 reinhard Note Added: 0001271
2008-11-20 04:57 cinephiliac Note Added: 0001273
2008-11-20 04:57 cinephiliac Status feedback => acknowledged
2008-11-26 04:05 cinephiliac Build/Install Method => Build Wizard
2008-11-26 04:05 cinephiliac Note Added: 0001418
2008-11-26 04:05 cinephiliac Status acknowledged => resolved
2008-11-26 04:05 cinephiliac Resolution open => fixed
2008-11-26 04:13 cinephiliac Note Added: 0001420
2008-11-28 21:42 madsdyd Fixed in Version => Recent git
2008-12-03 17:23 cinephiliac Relationship added related to 0000427
2008-12-03 17:25 cinephiliac Relationship added related to 0000417
2008-12-03 17:33 cinephiliac Relationship added related to 0000421
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker