Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000037KdenliveUser Interfacepublic2007-11-17 18:052009-06-16 09:35
Reporterstbenl 
Assigned Toadministrator 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000037: Crash while editing track
DescriptionI can crash kdenlive very quickly while editing a track.

The problem appears related to the UI because if I save often, and restart kdenlive after a crash, things are back to normal. It doesn't seem to relate the video itself because what I'm doing at the time of the crash is always different.

The video in question is a large mpg video produced by my PVR 150.

I'm running ubuntu 7.10 on a Core2 Duo (using 32bit distro)
Additional Information...
...
[Thread -1255810160 (LWP 7787) exited]
[New Thread -1255810160 (LWP 7788)]
[New Thread -1292895344 (LWP 7789)]
[Thread -1255810160 (LWP 7788) exited]
[Thread -1292895344 (LWP 7789) exited]
[New Thread -1292895344 (LWP 7790)]
[New Thread -1255810160 (LWP 7791)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1292895344 (LWP 7790)]
0xb63d7107 in ?? () from /usr/lib/mlt/modules/libmltavformat.so
(gdb) where
#0 0xb63d7107 in ?? () from /usr/lib/mlt/modules/libmltavformat.so
#1 0xb2311f48 in ?? ()
0000002 0xb63dbbda in ?? () from /usr/lib/mlt/modules/libmltavformat.so
0000003 0x00000000 in ?? ()
(gdb)
TagsNo tags attached.
Build/Install Method
Attached Files? file icon testclip.mpg [^] (4,630,778 bytes) 2007-11-17 18:34

- Relationships

-  Notes
(0000064)
stbenl (reporter)
2007-11-17 18:32

1) Start a new project with MLT_NORMALISATION=NTSC kdenlive
2) add clip testclip.mpg (attached)
3) drag clip to a track
4) split the track in a few places
5) move the cursor over the track back and forth

Doing the above, I get a crash very rapidly.
(0000177)
tkroenert (reporter)
2008-04-11 23:53

1. merge 2 or more 1GB avi Clips - i.e. grabed with dvgrab - with avidemux together
2. Add >1GB Clip to kdenlive
3. add the clip in the timeline
4. try to seek after the 1GB ==> CRASH

Work a round:
split the avi in 1000MB parts (i.e. with avisplit from the transcode pack)
(0001189)
cinephiliac (updater)
2008-11-14 08:01

Hi there,

Could you please post the version number of your Kdenlive? Due to large changes in the codebase between version 0.6 and 0.7 bugfixing has currently moved to the 0.7 version, as this fixes most known 0.5 / 0.6 bugs. If you are on a 0.7.x version of Kdenlive, then posting version numbers for your install of ffmpeg and MLT would also be useful. These can be found in one of two ways:

If you installed through your distro: Just look up these packages in your package manager (eg Adept, Synaptic etc). Usually there is a "More Info" or "Details" type of button which will let you see these numbers.

If you installed with the Kdenlive Builder Wizard (KBW), just navigate to the folder you normally run Kdenlive from and post the output of: ./kdenlive_start --version

Many thanks


Cinephiliac
(0003227)
administrator (administrator)
2009-06-16 09:14

not relevant anymore

- Issue History
Date Modified Username Field Change
2007-11-17 18:05 stbenl New Issue
2007-11-17 18:32 stbenl Note Added: 0000064
2007-11-17 18:34 stbenl File Added: testclip.mpg
2008-04-11 23:53 tkroenert Note Added: 0000177
2008-11-14 08:01 cinephiliac Note Added: 0001189
2008-11-14 08:01 cinephiliac Status new => feedback
2009-06-16 09:14 administrator Note Added: 0003227
2009-06-16 09:14 administrator Status feedback => resolved
2009-06-16 09:14 administrator Resolution open => won't fix
2009-06-16 09:14 administrator Assigned To => administrator
2009-06-16 09:35 administrator Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker