Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000373KdenliveUser Interfacepublic2008-11-20 03:352008-12-29 16:27
Reportermfgkden 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version0.7.0 
Target VersionFixed in Version 
Summary0000373: kdenlive crashes before it starts
Descriptiondownloaded 64bit compiled version by Marillat
installed in kubuntu intrepid with appropriate dependencies via adept.
 
Additional Informationmfg@jtakel:~$ kdenlive
kdenlive(9954) MainWindow::parseProfiles: RESULTINGĂ‚ MLT PATH: "/usr/share/mlt/profiles/"
KCrash: Application 'kdenlive' crashing...
sock_file=/home/mfg/.kde/socket-jtakel/kdeinit4__0

Application: Kdenlive (kdenlive), signal SIGSEGV
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7f39195766f0 (LWP 9954)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)

[KCrash handler]
0000005 0x00007f39041cf82d in ?? () from /lib/libselinux.so.1
0000006 0x00007f39041c22ff in ?? () from /lib/libselinux.so.1
0000007 0x0000000001834d68 in ?? ()
0000008 0x0000000000000000 in ?? ()
#0 0x00007f39152765f0 in nanosleep () from /lib/libc.so.6


TagsNo tags attached.
Build/Install Method
Attached Files

- Relationships

-  Notes
(0001274)
cinephiliac (updater)
2008-11-20 05:00

Hmmmm... Unfortunately I can't reproduce this as I don't have access to a 64bit machine. Does anyone else?
(0001275)
ddennedy (developer)
2008-11-20 05:22

I have a x86-64 Arch Linux install that I test out, and it works for me.

I do not believe it is safe to use debian-multimedia.org packages on Ubuntu. Now, people are being directed to Medibuntu for multimedia packages on Ubuntu.
(0001276)
ddennedy (developer)
2008-11-20 05:23

Oh, and I do not use SELinux on that installation.
(0001278)
madsdyd (administrator)
2008-11-20 10:05

Given that you are running packages built for another distribution, and the issues with selinux, I think that in order to acknowledge this issue, we need you to run your kdenlive installation in gdb.

Check this page for more info: http://en.wikibooks.org/wiki/Kdenlive/Troubleshooting [^]

(0001280)
elhoir (reporter)
2008-11-20 10:41

you can only run 64-bits package in (k/x/go)ubuntu, unless you have the ia32-libs package installed... are you sure you have it?
(0001289)
mfgkden (reporter)
2008-11-20 18:29

1 I do not use selinux. (only libselinux1 package is installed by default)
2 ia32-libs package is installed
3 if I run gdb kdenlive all I get is:

mfg@jtakel:~$ gdb kdenlive
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> [^]
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu"...
(no debugging symbols found)
(gdb)
(0001290)
madsdyd (administrator)
2008-11-20 19:03

Ok, nice to get 1 and 2 sorted out.

Re 3 - my apologies, I think everyone sort of assumed that it "everybody" know you need to type "run" in gdb to start kdenlive.

Then, you can follow the steps at http://en.wikibooks.org/wiki/Kdenlive/Troubleshooting#Publishing_a_gdb_trace [^] :

bt
thread apply all bt
where full

and paste/attach the output here.

More detailed instructions (but still missing the "run" part!) is available at above link.

Regards

Mads
(0001291)
ddennedy (developer)
2008-11-20 19:04

you have to type 'run<enter>' at the (gdb) prompt. Then, when it crashes type 'thread apply all bt' and paste results here. Thanks!
(0001295)
opensourcecat (reporter)
2008-11-20 19:46

Here in openSUSE 11.1 works as in 32 bit for the little i tested out (add footage and render out)
(0001299)
mfgkden (reporter)
2008-11-20 20:06

Thank you for your advice.
I paste the output here (although it is not much).

mfg@jtakel:~$ gdb kdenlive
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> [^]
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu"...
(no debugging symbols found)
(gdb) run
Starting program: /usr/bin/kdenlive
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread 0x7fefb537c6f0 (LWP 20287)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
kdenlive(20287) MainWindow::parseProfiles: RESULTINGĂ‚ MLT PATH: "/usr/share/mlt/profiles/"
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fefb537c6f0 (LWP 20287)]
0x00007fef9ffd482d in ?? () from /lib/libselinux.so.1
(gdb) bt
#0 0x00007fef9ffd482d in ?? () from /lib/libselinux.so.1
#1 0x00007fef9ffc72ff in ?? () from /lib/libselinux.so.1
0000002 0x0000000001a15cf8 in ?? ()
0000003 0x0000000000000000 in ?? ()
(gdb) thread apply all bt

Thread 1 (Thread 0x7fefb537c6f0 (LWP 20287)):
#0 0x00007fef9ffd482d in ?? () from /lib/libselinux.so.1
#1 0x00007fef9ffc72ff in ?? () from /lib/libselinux.so.1
0000002 0x0000000001a15cf8 in ?? ()
0000003 0x0000000000000000 in ?? ()
(gdb) where full
#0 0x00007fef9ffd482d in ?? () from /lib/libselinux.so.1
No symbol table info available.
#1 0x00007fef9ffc72ff in ?? () from /lib/libselinux.so.1
No symbol table info available.
0000002 0x0000000001a15cf8 in ?? ()
No symbol table info available.
0000003 0x0000000000000000 in ?? ()
No symbol table info available.
(gdb) quit
The program is running. Exit anyway? (y or n) y
mfg@jtakel:~$
(0001305)
ddennedy (developer)
2008-11-20 21:23

There is not much to go on from the backtrace, but it clearly is something related to libselinux again. I do not think we should be bother trying to figure this out because you are using the wrong packages for your distribution.
(0001313)
madsdyd (administrator)
2008-11-20 21:58

Closing issue - won't fix.

I am sorry, but given that the packages are buitd without debug symbols, for another platform (debian != ubuntu) it appears impossible to actually fix it (only after you ran gdb, did I realise that there are no debug symbols in the package, which I should have know, sorry).

I suggest you try to build Kdenlive 0.7 yourself at this point.

If you have trouble building the KDE4/qt4 version of Kdenlive, please consult http://www.kdenlive.org/compile [^]

You may especially be interessted in the Kdenlive Builder Wizard, available at http://www.kde-apps.org/content/show.php?content=85826 [^] .
 

- Issue History
Date Modified Username Field Change
2008-11-20 03:35 mfgkden New Issue
2008-11-20 05:00 cinephiliac Note Added: 0001274
2008-11-20 05:22 ddennedy Note Added: 0001275
2008-11-20 05:23 ddennedy Note Added: 0001276
2008-11-20 10:05 madsdyd Note Added: 0001278
2008-11-20 10:05 madsdyd Status new => feedback
2008-11-20 10:41 elhoir Note Added: 0001280
2008-11-20 18:29 mfgkden Note Added: 0001289
2008-11-20 19:03 madsdyd Note Added: 0001290
2008-11-20 19:04 ddennedy Note Added: 0001291
2008-11-20 19:46 opensourcecat Note Added: 0001295
2008-11-20 20:06 mfgkden Note Added: 0001299
2008-11-20 21:23 ddennedy Note Added: 0001305
2008-11-20 21:58 madsdyd Note Added: 0001313
2008-11-20 21:58 madsdyd Status feedback => resolved
2008-11-20 21:58 madsdyd Resolution open => won't fix
2008-12-29 16:27 madsdyd Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker